Simple Machines Community Forum

SMF Support => Server Performance and Configuration => Topic started by: silber112 on January 02, 2018, 09:25:00 PM

Title: Fresh SMF 2.0.15 isnt workign on my server configuration
Post by: silber112 on January 02, 2018, 09:25:00 PM
 I just did a fresh install of SMF:

- Fresh SMF 2.0.15
- CHMOD 777 to all files
GD version: 2.2.5
Database Server: MariaDB
MySQL version: 5.5.56-MariaDB
PHP: 5.6.32
Server version: nginx/1.12.2


I cant install mods:
You cannot download or install new packages because the Packages directory or one of the files in it are not writable!

I cant acces to the simplemachines news:
You are unable to connect to simplemachines.org's latest news file.

And autocomplete doesnt work...


The issue has to be some server configuration. Is there any specific set up you need?
-> My vps has installed centos 7 nginx php-fpm + vestacp + iptables + fail2ban..

Thanks in advance
Title: Re: Fresh SMF 2.0.15 isnt workign on my server configuration
Post by: Kindred on January 02, 2018, 10:14:10 PM
Well, smf does not officially support mariadb

That being said, your issue is not a db issue... but you may encounter some issues eventually.

The packages error is almost definitely due to a missing or bad chmod on the temp folder inside the packages folder
 
The autocomplete issue is usually due to JavaScript conflicts
Title: Re: Fresh SMF 2.0.15 isnt workign on my server configuration
Post by: Aleksi "Lex" Kilpinen on January 03, 2018, 04:24:03 AM
Duplicate? Autocomplete issue (https://www.simplemachines.org/community/index.php?topic=558068.0)
Title: Re: Fresh SMF 2.0.15 isnt workign on my server configuration
Post by: silber112 on January 03, 2018, 04:43:37 AM
Well, smf does not officially support mariadb

That being said, your issue is not a db issue... but you may encounter some issues eventually.

The packages error is almost definitely due to a missing or bad chmod on the temp folder inside the packages folder
 
The autocomplete issue is usually due to JavaScript conflicts

Its a fresh installation, there are no mods that could produce conflicts.. Yes, its posible to install mods with the temp folder, but the issue with autocomplete and the connection to smf remains

Duplicate? Autocomplete issue (https://www.simplemachines.org/community/index.php?topic=558068.0)
I cant delete my own post. I realised that it was in the wrong place so i moved it..
Title: Re: Fresh SMF 2.0.15 isnt workign on my server configuration
Post by: silber112 on January 03, 2018, 07:13:44 AM
Sorry.. It was cloudflare.
Title: Re: Fresh SMF 2.0.15 isnt workign on my server configuration
Post by: Kindred on January 03, 2018, 01:01:53 PM
yup.... cloudflare - especially for a forum - is really not worth the hassle, IMO