Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: xena1997 on January 09, 2018, 06:47:39 AM

Title: https forum
Post by: xena1997 on January 09, 2018, 06:47:39 AM
on my forum I have version 2.0.15
with ssl certificate and https
the problem that the green lock does not always appear
more often than not, the padlock near https remains yellow
How can I solve the problem?
regards
Title: Re: https forum
Post by: Kindred on January 09, 2018, 07:06:05 AM
did you change ALL of your forum URLs to https?
themes, smilies, avatars, attachments?

Are you using a custom theme with hardcoded images? Are you using any mods with images or javascript? Did you turn on the proxy for old images in posts or external avatars?
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 07:10:39 AM
I can not tell you friend
if you place the forum link you can understand it?
Title: Re: https forum
Post by: Shambles on January 09, 2018, 08:26:43 AM
Your browser should be able to identify which elements are insecure.
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 11:26:43 AM
the url of the smile themes and images are with https

help me thanks
Title: Re: https forum
Post by: Shambles on January 09, 2018, 11:36:32 AM
Quote from: Kindred
did you change ALL of your forum URLs to https?
... avatars, attachments?

Link to your forum?
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 11:38:42 AM
link forum

https://crackingeurope.eu/index.php
Title: Re: https forum
Post by: Shambles on January 09, 2018, 11:42:27 AM
Is your forum hidden from guests?
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 11:45:56 AM
ok bro

https://crackingeurope.eu/index.php
Title: Re: https forum
Post by: Shambles on January 09, 2018, 11:47:42 AM
As I mentioned, you can use your browser to isolate/identify the rogue images.


Here's an example:

(https://i.imgur.com/dddotFf.jpg)
Title: Re: https forum
Post by: Shambles on January 09, 2018, 11:50:14 AM
All your board icons too:

(https://i.imgur.com/kBFE8DL.jpg)
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 11:52:37 AM
to put those icons I can not remember the name of the mod I installed
Title: Re: https forum
Post by: Shambles on January 09, 2018, 12:00:32 PM
It'll be a board icons mod. Look in your package manager for the name. It looks like Board Icons https://custom.simplemachines.org/mods/index.php?mod=3604
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 12:04:29 PM
I have this mod Board Icons
I try to uninstall it?
Title: Re: https forum
Post by: Shambles on January 09, 2018, 12:06:19 PM
Quote
I have this mod Board Icons
I try to uninstall it?

What's the point? Just reconfigure the URL for the board icons from http: to https: in all your boards. It should work for postimg and imgur.
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 12:13:28 PM
I try and let you know ok?
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 12:23:18 PM
bro mod not support https
link mod
https://custom.simplemachines.org/mods/index.php?mod=3604

(https://custom.simplemachines.org/mods/index.php?action-download;mod=3604;id=214973;image)
Title: Re: https forum
Post by: Shambles on January 09, 2018, 12:29:54 PM
In that case, take a copy of all the images and place them in a forum folder like in the example on the mod page.

(https://i.imgur.com/EcmvlFP.jpg)
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 12:31:34 PM
I did not understand, can you give me a precise example?
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 12:44:49 PM
so from cpnael I create a folder in the theme that I use and I call it icons?
I insert all the images inside them
and then as shown in the figure the themes?
Title: Re: https forum
Post by: Shambles on January 09, 2018, 12:53:27 PM
Yes I believe that will work.
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 02:21:13 PM
friend the icons I have arranged and work
but https does not work
helpme
Title: Re: https forum
Post by: Shambles on January 09, 2018, 02:42:48 PM
Is your forum hidden from guests?

I can't see to check what you've done.
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 02:44:03 PM
ok bro
Title: Re: https forum
Post by: Shambles on January 09, 2018, 02:47:30 PM
You've almost got it all done, but using the browser tools (which you also have) I can see two image calls which haven't been converted.

(https://i.imgur.com/qm8TQ1W.jpg)

They appear to be off-site so check to see if you actually need these images at all.
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 02:49:53 PM
good was the old domain
how can i remove?
Title: Re: https forum
Post by: Shambles on January 09, 2018, 03:11:37 PM
Do you have a chat system/mod installed, such as SaChat?
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 03:14:27 PM
yes I have that mod sachat that was on the old domain and then they moved me all over the new domain and now and it works on the new domain
Do I have to uninstall the mod and reinstall it?
Title: Re: https forum
Post by: Shambles on January 09, 2018, 03:20:56 PM
Can you go to the SaChat configuration page and look at the settings in there? See if some features of your old domain still exist, and change/remove them.

I don't know anything about SaChat so can't direct you with any more detail.

Title: Re: https forum
Post by: xena1997 on January 09, 2018, 03:26:46 PM
There is nothing in the sachat settings
can I uninstall it and remove the folder from cpanel?
then do a new installation?
Title: Re: https forum
Post by: Shambles on January 09, 2018, 03:27:58 PM
There's nothing to stop you uninstalling then reinstalling SaChat if you wish. Not sure if it will resolve those two "old" image links. Try it.
Title: Re: https forum
Post by: Shambles on January 09, 2018, 03:31:39 PM
I just tried registering on your forum and it appears you have aggressive antispam controls which aren't working too well  ::) ::) ::)

(https://i.imgur.com/ryu1LMk.jpg)
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 03:39:33 PM
bro work


Registration Successful




Thank you for registering. You will receive an email soon with a link to activate your account. If you don't receive an email after some time, check your spam folder


please bro try again
Title: Re: https forum
Post by: Shambles on January 09, 2018, 03:45:47 PM
No need for me to do that now.

Your two rogue images are coming from your database table {db_prefix}2sichat_barlinks

Did you uninstall/reinstall yet?
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 03:50:54 PM
no friend, I was waiting for you to tell me what to do
I uninstall the mod and delete sachat folder from cpanel and install the mod again?
Title: Re: https forum
Post by: Shambles on January 09, 2018, 03:51:54 PM
Just uninstall then reinstall. Don't delete anything.

Make sure you are installing v1.0a1
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 04:04:29 PM
the leggend very thanks super work

https yes

https://crackingeurope.eu/index.php

do you still have problems registering with the forum?
Title: Re: https forum
Post by: Shambles on January 09, 2018, 04:09:34 PM
Quote from: xena1997
do you still have problems registering with the forum?

Glad it's all now working.

I wanted an account to see if there might be any other "non guest" devices that might show up as insecure, but now I see you are fully https so I no longer need that.

All you now need to do is sort out your multiple footer entry issue. Start another thread for that if you need help.

In bocca al lupo!
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 04:13:54 PM
I did not understand the problem you told me

All you now need to do is sort out your multiple footer entry issue. Start another thread for that if you need help.

sei italiano?
Title: Re: https forum
Post by: Shambles on January 09, 2018, 04:17:00 PM
You have multiple footer entries, most likely due to duplicated installation of a mod.

If you need help clearing it up, start another thread :)

(https://i.imgur.com/PbowzBd.jpg)
Title: Re: https forum
Post by: xena1997 on January 09, 2018, 04:20:57 PM
ok the leggend thanks