Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: nadeem34 on April 21, 2018, 02:24:47 PM

Title: Deleted the Prett URL mod but URL Remains the same?
Post by: nadeem34 on April 21, 2018, 02:24:47 PM
Hello every one

I am in big trouble please help me
At the beginning i thought pretty_url is good mod for SEO but as time passed and looked over review regarding this mod i decided to remove and delete it. After deleting it disappeared from "browse packages" and "installed packages" in the admin area.

But URL still remains the same nothing changed I don't know why? and in the "MOdify boards" sections pretty url option is still there to change the url for boards. How is this possible? isn't it very funny!
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: @rjen on April 21, 2018, 02:34:34 PM
Deleting the package does not uninstall it.
You should uninstall the package first...

Try uploading the package again. You should then be able to uninstall. Delete the package only after successful uninstall...
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: drewactual on April 21, 2018, 03:20:26 PM
I had same issue after properly uninstalling the package.

The uninstall didn't remove the entries in htaccess.  Remove those, and your issue will resolve.  Reference the package install xml to find the precise lines to remove.
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: nadeem34 on April 21, 2018, 03:44:27 PM
Quote
I had same issue after properly uninstalling the package.

The uninstall didn't remove the entries in htaccess.  Remove those, and your issue will resolve.  Reference the package install xml to find the precise lines to remove.

Can you please explain it easily how can i remove it from .htaccess what code i remove? Thank you
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: Sir Osis of Liver on April 21, 2018, 03:58:07 PM
Post your .htaccess.
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: nadeem34 on April 21, 2018, 04:00:34 PM
Quote
Post your .htaccess.

Please attached .htaccess file
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: Sir Osis of Liver on April 21, 2018, 04:08:15 PM
Attached.
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: nadeem34 on April 21, 2018, 04:26:55 PM
Can you please give me one more favor  :-* :-*

My website not working https://discusscryptocurrency.com/ (https://discusscryptocurrency.com/) it shows this error in error_log

[21-Apr-2018 20:20:02 UTC] PHP Parse error:  syntax error, unexpected '**' (T_POW) in /home/username/public_html/Sources/QueryString.php on line 558

[21-Apr-2018 06:01:43 UTC] PHP Deprecated:  Function create_function() is deprecated in /home/username/public_html/Sources/Load.php on line 268

Can you please help for this. The problem begins when i deleted the pretty url from cpanel and website stopped working and i upload it again but not worked
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: Sir Osis of Liver on April 21, 2018, 04:31:54 PM
Was pretty urls the last mod you installed?
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: nadeem34 on April 21, 2018, 04:34:42 PM
Quote
Was pretty urls the last mod you installed?

No it was not last mod After it i installed many others
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: Sir Osis of Liver on April 21, 2018, 04:37:59 PM
The problem begins when i deleted the pretty url from cpanel and website stopped working and i upload it again but not worked

What exactly did you delete?
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: nadeem34 on April 21, 2018, 04:55:55 PM
Quote
What exactly did you delete?

Before few days By mistake, I moved public_html to newly created folder. At once my site stopped working i felt i did something wrong so I reverse the process. Though my website start working but some mods including pretty urls that were installed in admin area "browse packages" they appear as not installed and even not showing in "installed packages" (but at site all the mods were working properly urls were pretty and other mods were also working but in admin area they appeared as not installed)

Today:  I tried to look over this problem so I clicked on "install package"(pretty urls) in the "browse packages" It showed me the error that you are installing this package but it will not install successfully but still i installed it and ignored the error. As the package installed at once website stopped working and shows this error https://discusscryptocurrency.com/. Then i deleted the pretty url from cpanel not worked again and i upload it again but still not worked and now begging help from you

 am i so stupid.!!!
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: Sir Osis of Liver on April 21, 2018, 05:12:50 PM
 (https://www.simplemachines.org/community/proxy.php?request=http%3A%2F%2Fwww.thekrashsite.com%2Fpics%2Ffp.gif&hash=a0475caffc214db9329a3219dd7fbd7c)  At this point, best thing you can do is upload a clean set of files.  You won't lose any content, but you'll have to reinstall the mods you wish to keep.  If it's any consolation, you learn more by screwing things up than if you get it right first time.

https://wiki.simplemachines.org/smf/How_to_upload_a_fresh_set_of_files
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: nadeem34 on April 21, 2018, 05:21:10 PM
ok let me try it

And Thank you very much
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: Illori on April 21, 2018, 05:26:31 PM
check if your host is using php 7.2, if so you need to downgrade to at least 7.0 as SMF 2.0 does not support php 7.2. this may resolve the other errors you are getting as well.
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: nadeem34 on April 21, 2018, 11:17:09 PM
Quote
check if your host is using php 7.2, if so you need to downgrade to at least 7.0 as SMF 2.0 does not support php 7.2. this may resolve the other errors you are getting as well.

This is not host error the error is somewhere in the coding or files
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: nadeem34 on April 22, 2018, 05:10:48 AM
Quote
  At this point, best thing you can do is upload a clean set of files.  You won't lose any content, but you'll have to reinstall the mods you wish to keep.  If it's any consolation, you learn more by screwing things up than if you get it right first time.

https://wiki.simplemachines.org/smf/How_to_upload_a_fresh_set_of_files

I have done everything but I am stuck again upon new set of installation files it requires database information to be filled i filled all the information correct but it shows the server cannot connect error. Image is attached

Please help me...
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: Illori on April 22, 2018, 06:01:53 AM
if you follow the directions on the wiki page it tells you to use the large upgrade, you are using the installer.

also the error you got about Function create_function() is deprecated in /home/username/public_html/Sources/Load.php on line 268 is from php 7.2, which SMF 2.0 does NOT support.
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: nadeem34 on April 22, 2018, 06:17:21 AM
Code: [Select]
if you follow the directions on the wiki page it tells you to use the large upgrade, you are using the installer.

also the error you got about Function create_function() is deprecated in /home/username/public_html/Sources/Load.php on line 268 is from php 7.2, which SMF 2.0 does NOT support.

I am using smf 2.0.15. I changed the php version but it still shows the database error.
Quote
it tells you to use the large upgrade, you are using the installer.

Please explain the above quote again what deos it means
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: Kindred on April 22, 2018, 08:25:49 AM
you went to the downloads page and downloaded the full install archive.

don't do that.

go to the downloads page and download the one UNDER that...  the one labelled "Large Upgrade" (which is what the Wiki says to do)
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: nadeem34 on April 22, 2018, 09:09:13 AM
Quote
you went to the downloads page and downloaded the full install archive.

don't do that.

go to the downloads page and download the one UNDER that...  the one labelled "Large Upgrade" (which is what the Wiki says to do)

I did the same as you told downloaded the large upgrade and extracted in smf root directory but still a message appears cannot connect to the database server
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: Kindred on April 22, 2018, 09:32:53 AM
if that is the case, then either the settings in your Settings.php file are incorrect or your host has limited your user access to the database for some reason...

Also, if you completed the install and input the same database info, there's a chance that you deleted your database contents.

Restore from a backup and then try again.
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: Sir Osis of Liver on April 22, 2018, 10:33:46 PM
If you uploaded the full install package, it overwrote Settings.php with a scratch file, your db credentials are gone.  You can edit them directly in Settings.php.
Title: Re: Deleted the Prett URL mod but URL Remains the same?
Post by: GigaWatt on April 23, 2018, 10:18:40 AM
Or with repair_settings.php (https://wiki.simplemachines.org/smf/Repair_settings.php).