Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: landyvlad on June 13, 2018, 10:56:13 AM

Title: Strange 'Theme Directory Error' message
Post by: landyvlad on June 13, 2018, 10:56:13 AM
At the top of the forum this has suddenly appeared (I've only just noticed it today)

Quote
The default theme's directory is wrong. Please correct it by clicking this text.
(on a full width field with pink background, so its hard to miss)


I've not made ANY changes so there is no way that I know of that the directory would have changed.

When I do click on it, it takes me to the Help Theme Settings - SMF Default Theme - Curve

settings are as follows:

Quote
This theme's URL:  http://gsx1400owners.org/forum/Themes/default
This theme's images URL:  http://gsx1400owners.org/forum/Themes/default/images
This theme's directory:  /home3/gsxowner/public_html/forum/Themes/default

These are in line with the defaults, are they not?

So can anyone tell me why that error message is appearing, and what I can do about it?

Thanks
Title: Re: Strange 'Theme Directory Error' message
Post by: Illori on June 13, 2018, 11:05:45 AM
take a look at What is repair_settings.php? (https://wiki.simplemachines.org/smf/Repair_settings.php), it shows you all themes paths/urls, which you can compare to see if they are correct.
Title: Re: Strange 'Theme Directory Error' message
Post by: landyvlad on June 14, 2018, 09:31:50 AM
repair setting appears to have fixed it...

it had /home3 in the folder tree rather than /home

I have no idea why - but that's now been corrected and touch wood it's fixed now !

Thanks