Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: TheSnake on February 16, 2019, 06:29:27 PM

Title: "Fatal error: require_once(): Failed opening required '"...
Post by: TheSnake on February 16, 2019, 06:29:27 PM
Hi!
One of the forums got this
Quote
Fatal error: require_once(): Failed opening required '/home/forum/abc/Sources/smfhacks_source/global-hf.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/forum/abc/Sources/Load.php on line 1606

Tried repair_settings.php, but no success. Other ways?
Title: Re: "Fatal error: require_once(): Failed opening required '"...
Post by: Shambles on February 16, 2019, 06:31:57 PM
Quote
Failed opening required '/home/forum/abc/Sources/smfhacks_source/global-hf.php'

And does that file exist?
Title: Re: "Fatal error: require_once(): Failed opening required '"...
Post by: shawnb61 on February 16, 2019, 06:36:56 PM
This is likely a problem with Global Headers and Footers mod.

You might want to try the support thread here:
https://www.simplemachines.org/community/index.php?topic=103464.0
Title: Re: "Fatal error: require_once(): Failed opening required '"...
Post by: TheSnake on February 16, 2019, 07:07:29 PM
Yes.
Title: Re: "Fatal error: require_once(): Failed opening required '"...
Post by: TheSnake on February 16, 2019, 07:07:54 PM
Yes. What should I do? :o
Title: Re: "Fatal error: require_once(): Failed opening required '"...
Post by: shawnb61 on February 16, 2019, 07:28:49 PM
You should ask for help on that support thread.

It seems like there is an issue with the install.  Maybe they've seen it before.
Title: Re: "Fatal error: require_once(): Failed opening required '"...
Post by: TheSnake on February 16, 2019, 07:43:53 PM
Thanks! Almost done. One problem left
Quote
Unable to load the 'global_hf_above' template.
Maybe it's easier to deal with?
Title: Re: "Fatal error: require_once(): Failed opening required '"...
Post by: vbgamer45 on February 16, 2019, 08:05:10 PM
Copy the global header footers mod template to your themes/default folder
Title: Re: "Fatal error: require_once(): Failed opening required '"...
Post by: Kindred on February 16, 2019, 11:57:27 PM
Once again, mod specific questions should be asked in the thread dedicated to supporting that mod
Title: Re: "Fatal error: require_once(): Failed opening required '"...
Post by: TheSnake on February 17, 2019, 02:05:23 AM
OK. I'll try.
Thanks!