Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: arielvered on May 08, 2019, 12:18:20 PM

Title: can only login in incognito mode
Post by: arielvered on May 08, 2019, 12:18:20 PM
My site is running 2.0.15
The site address is https://amyloidosis.org.uk/forum

Only some, but not all computers, we can only login using incognito mode. This is true for all users. The same user can also login from other machines.

I have tried researching the problem and this and changed this in the theme:

Quote
<form id="guest_form" action="', $scripturl, '?action=login2" method="post" accept-charset="', $context['character_set'], '" ', empty($context['disable_login_hashing']) ? ' onsubmit="hashLoginPassword(this, \'' . $context['session_id'] . '\');"' : '', '>
                        <div class="info">', sprintf($txt['welcome_guest'], $txt['guest_title']), '</div>';
         
                  if (!empty($modSettings['enableOpenID']))
                     echo '
                        <br /><input type="text" name="openid_identifier" id="openid_url" size="25" class="input_text openid_login" />';
         
                  echo '
                        <input type="hidden" name="hash_passwrd" value="" />
                        <input type="hidden" name="', $context['session_var'], '" value="', $context['session_id'], '" />
                     </form>';

This has not helped.
I have tried local things like clearing browser, which seems logical as I can login using incognito, but it didn't help.
I also tried switching theme, but this happened on both the Default theme and the Dani theme.
The mods that I have installed are "anti Bot" and GDPR Helper.

I also tried changing some server settings, this also hasn't helped. What I currently have is attached.

I greatly appreciate any ideas about how to fix this.
Title: Re: can only login in incognito mode
Post by: d3vcho(); on May 08, 2019, 12:25:41 PM
Hello,

I've noticed that in the footer of your forum does not appear SMF's copyright. As for that, I will reserve my right to provide you assistance with this problem.
Title: Re: can only login in incognito mode
Post by: Sir Osis of Liver on May 08, 2019, 12:30:59 PM
That's odd, just looked at forum a few minutes ago and copyright was there, now it's not?

It's on registration page, but not home.
Title: Re: can only login in incognito mode
Post by: d3vcho(); on May 08, 2019, 12:34:39 PM
Err... yeah, that's right. Although there's something wrong with it on index. There's just a large white box and if you click it, it redirects to SMF's License.
Title: Re: can only login in incognito mode
Post by: arielvered on May 08, 2019, 12:35:22 PM
Quote
I've noticed that in the footer of your forum does not appear SMF's copyright.
I really don't know a lot about this. I didn't erase any copyright information.

Maybe that happened when I switched from the default theme to Dani and this theme removed the footer.
The Dani theme was the theme recommended by simplemachines when I looked for something that worked on mobile.

I did that because google said that my forum wasn't readable on mobile devices.

I changed the theme back to default and now the footer is there.
Title: Re: can only login in incognito mode
Post by: d3vcho(); on May 08, 2019, 12:37:46 PM
That's right. Can you provide some information to log in and test the problem?
Title: Re: can only login in incognito mode
Post by: arielvered on May 08, 2019, 12:40:55 PM
Quote
That's right. Can you provide some information to log in and test the problem?
Am I understanding correctly that you want me to make a user login for you as Admin?
Title: Re: can only login in incognito mode
Post by: Sir Osis of Liver on May 08, 2019, 12:42:29 PM
Dani theme displays copyright correctly out-of-box.  Either a mod or edit removed it.
Title: Re: can only login in incognito mode
Post by: d3vcho(); on May 08, 2019, 12:42:46 PM
As Admin or as normal user, all I need is login info so I can see the problem. You can send it to me via PM.
Title: Re: can only login in incognito mode
Post by: Shambles on May 08, 2019, 01:48:53 PM
Quote
Dani theme displays copyright correctly out-of-box.  Either a mod or edit removed it.


He has the copyright class set as "color:rgb(255,255,255)" so it's there if you try and select it amongst the white background.
Title: Re: can only login in incognito mode
Post by: arielvered on May 08, 2019, 03:12:26 PM
Quote
He has the copyright class set as "color:rgb(255,255,255)" so it's there if you try and select it amongst the white background.
If I understand correctly, the text is set to white on white.
Which file do I change this in? I didn't see the string "copyright class" in any of the files for the theme.
And to what should I change it so that it shows up?

I prefer to keep on using Dani, as Google seems to dislike default.
Title: Re: can only login in incognito mode
Post by: SychO on May 08, 2019, 03:17:26 PM
Actually, it's not the text's color that was changed to white, it's the container background that was set to white,

if you go to the theme's folder > index.template.php, look for id="footer" and right after it class="wrapper" remove that class
Title: Re: can only login in incognito mode
Post by: d3vcho(); on May 08, 2019, 03:22:02 PM
I now have admin access to the said forum. Will be performing some checks, but I managed to log in using Firefox.

edit: I have successfully loged in the account using Firefox and Chrome, both with the default and Dani theme.
edit2: Also tried with Edge.
Title: Re: can only login in incognito mode
Post by: arielvered on May 08, 2019, 03:45:57 PM
Actually, it's not the text's color that was changed to white, it's the container background that was set to white,

if you go to the theme's folder > index.template.php, look for id="footer" and right after it class="wrapper" remove that class
Thanks. I did that and now the footer is showing up using the Dani theme.
Title: Re: can only login in incognito mode
Post by: arielvered on May 08, 2019, 03:47:37 PM
I now have admin access to the said forum. Will be performing some checks, but I managed to log in using Firefox.

edit: I have successfully loged in the account using Firefox and Chrome, both with the default and Dani theme.
edit2: Also tried with Edge.

I also manage on some machines. But some not.
The admin's computer will only work in incognito mode (also from edge didn't work), and also on her phone, but I can log her in from different machines.

Thanks so much for your help.
Title: Re: can only login in incognito mode
Post by: d3vcho(); on May 08, 2019, 04:28:36 PM
That's really odd it works on some computers and in some others not...
Title: Re: can only login in incognito mode
Post by: Kindred on May 08, 2019, 04:50:56 PM
WHat is the SPECIFIC error received when the individual is unable to log in?
Title: Re: can only login in incognito mode
Post by: arielvered on May 08, 2019, 05:35:59 PM
i have attached a screen cap.
incognito logged in, regular one with the error message.
Title: Re: can only login in incognito mode
Post by: GigaWatt on May 08, 2019, 08:21:30 PM
What's the login cookie's name and timeout interval?

Admin --> Configuration --> Server Settings --> Cookies and Sessions
Title: Re: can only login in incognito mode
Post by: arielvered on May 09, 2019, 02:43:15 AM
What's the login cookie's name and timeout interval?

Admin --> Configuration --> Server Settings --> Cookies and Sessions
Attached to the first message.
Title: Re: can only login in incognito mode
Post by: d3vcho(); on May 09, 2019, 04:55:03 AM
i have attached a screen cap.
incognito logged in, regular one with the error message.

That's familiar to me and has probably to do with your current theme. Please, check this page: Login error 2.0.14 (https://wiki.simplemachines.org/smf/Login_error_2.0.14). If you can't figure out how to achieve that, please attach your index.template.php of the current theme here so we can take a look at it.
Title: Re: can only login in incognito mode
Post by: arielvered on May 09, 2019, 05:50:48 AM
That's familiar to me and has probably to do with your current theme. Please, check this page: Login error 2.0.14 (https://wiki.simplemachines.org/smf/Login_error_2.0.14). If you can't figure out how to achieve that, please attach your index.template.php of the current theme here so we can take a look at it.
I already tried implementing that before I asked for help, and the solution recommended there is in my original post here, but perhaps I didn't understand the instructions there and added the extra "input" value in the wrong place.

I have attached my index.template.php file

Title: Re: can only login in incognito mode
Post by: GigaWatt on May 09, 2019, 07:52:36 PM
Regarding the loging fix, everything seems to be OK in your index.template.php file.

Quote
SMF 2.0.14+ now requires the a session check in the <form> for the login function. If your custom theme has a login form, such as in index.template.php, boardindex.template.php or login.template.php, you will need to modify the theme to allow the login function to work correctly. In order to modify the theme, add the following code along with the other "hidden" input types, or anywhere before the closing </form> tag in the login form.

Code: [Select]
<input type="hidden" name="', $context['session_var'], '" value="', $context['session_id'], '" />
This code is used to help increase security for SMF.

Did you apply it in the other 2 places (if those files exist in your current theme)?

Also, try setting changing the login cookie name to something else.
Title: Re: can only login in incognito mode
Post by: shawnb61 on May 09, 2019, 08:33:54 PM
Hate to ask the obvious,  but...

Have the folks experiencing problems cleared their browser cookies?  Sure sounds like a stale cookie.



Title: Re: can only login in incognito mode
Post by: arielvered on May 10, 2019, 01:38:30 AM

Did you apply it in the other 2 places (if those files exist in your current theme)?

Also, try setting changing the login cookie name to something else.
I don't have the boardindex.template.php or login.template.php files in my theme. Presumably it will take from the default them if they don't exist?
Title: Re: can only login in incognito mode
Post by: arielvered on May 10, 2019, 01:42:13 AM

Also, try setting changing the login cookie name to something else.
Hooray! That fixed it.
Thanks so much for your help
Title: Re: can only login in incognito mode
Post by: arielvered on May 10, 2019, 01:44:18 AM
I want to thank the kind people here for helping me.
I not only resolved my problem, I also resolved a few I didn't know I had.

Much appreciated.