Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: MacGig on February 17, 2020, 11:38:52 AM

Title: 2.0.15 to 2.0.16 error?
Post by: MacGig on February 17, 2020, 11:38:52 AM
I want to upgrade to 2.0.16. getting this error. what does it mean? screenshot shows currently install packages.

 Error in Package Installation
At least one error was encountered during a test installation of this package. It is strongly recommended that you do not continue with installation unless you know what you are doing, and have made a backup very recently. This error may be caused by a conflict between the package you're trying to install and another package you have already installed, an error in the package, a package which requires another package that you don't have installed yet, or a package designed for another version of SMF.
Title: Re: 2.0.15 to 2.0.16 error?
Post by: MacGig on February 17, 2020, 11:44:21 AM
some errors so I was unsure if I should proceed with the upgrade or not?
Title: Re: 2.0.15 to 2.0.16 error?
Post by: Sir Osis of Liver on February 17, 2020, 11:50:41 AM
Package manager can't find target code, usually because it's been changed by a mod.  You have to manually edit those files before installing upgrade or bad things will happen.  Click the edit icon left side of error files, it will display target code and replacement code.
Title: Re: 2.0.15 to 2.0.16 error?
Post by: MacGig on February 17, 2020, 12:41:13 PM
thanks I'll look and see if I can figure it out. :)
Title: Re: 2.0.15 to 2.0.16 error?
Post by: MacGig on February 17, 2020, 01:50:13 PM
on one of the file edits, its telling me to replace code that is not in the file.. frustrating. cant replace code that is not there.
Title: Re: 2.0.15 to 2.0.16 error?
Post by: Sir Osis of Liver on February 17, 2020, 09:05:12 PM
Should be something similar.  Try to find part of the target code, not all of it.  If it was all there, you wouldn't have an error.