Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: _.EvilExecutor._ on May 30, 2020, 12:39:34 AM

Title: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on May 30, 2020, 12:39:34 AM
Hey,

I have SMF installed in my site (forum.lazergaming.net) and I'm facing a problem right now.

Everything is configured all right(from what I know) but profile picture doesnt show up in some mobile devices. I didn't show up in Samsung A20 and some other devices.

I tried clearing cache, changing the theme and stuff. I will add an attachment to show how it looks like. Any help is welcomed!

Note: The profile Pic doesnt show up in the default SMF theme also
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: m4z on May 30, 2020, 12:54:58 AM
I believe that is by design.

Re: default theme, are you also referring to mobile, or desktop?
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on May 30, 2020, 01:10:26 AM
I'm speaking about mobile version(No problem in desktop version.). Switching between themes wont work. So I assume it has nothing to do with the theme.

Any ideas about what I can do?
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: m4z on May 30, 2020, 01:45:54 AM
You'd have to manually edit the theme. AFAIK, the developers decided to not show avatars on mobile, so it's not there, not even as a user option.
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on May 30, 2020, 02:11:52 AM
Yeah Maybe. Still confused why it's showing up in some mobile devices...(oh and i noted in this community profile pics show up in mobile devices without issues)

Anyways how can I edit files and make the profile pics appear in any device?
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on May 30, 2020, 04:53:38 AM
GOOD NEWS: I fixed it. I was using http when I uploaded the profile pic,  so re-uploading it with https fixed. So i doesnt have anything to do with theme or SMF

And Thanks For The Help Offered!
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: m4z on May 30, 2020, 05:09:00 AM
Hmm, interesting. I guess what I said above must be wrong then.
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: Illori on May 30, 2020, 05:46:13 AM
then you should enable the image proxy, that would fix this issue and avatars linked to http would show up correctly.
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on June 04, 2020, 07:46:08 AM
BUMP!

I thought the problem was fixed after re-uploading because at that time it worked. But I was wrong. The problem doesn't apply only for mobile. Time to time profile pictures wont show up doesn't matter what device it is.

I tried clearing cache many occasions but it didn't work. But clearing the browsers cache was a temporary fix I found. It fix the issue but it causes again.

I'm using SMF 2.0.17 with Sunrise theme. Below mods are used,

TinyPortal   
Optimus   
@mention members   
Activity in Profile   
Profile Views   
Team Page   

EDIT: Maybe these things are useless but just in case I changed forum fro http to https & the forum is at forum.lazergaming.net though its installed at lazergaming.net/forum.

Any help welcomed.

Thanks
_.EE._
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: Illori on June 04, 2020, 08:23:48 AM
Quote from: Illori on May 30, 2020, 05:46:13 AM
then you should enable the image proxy, that would fix this issue and avatars linked to http would show up correctly.

Have you done this?
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on June 04, 2020, 08:37:22 AM
Yeah I have enabled that setting.
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: Kindred on June 04, 2020, 09:00:14 AM
please include the URL of a page demonstrating the problem??
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on June 04, 2020, 09:20:24 AM
since it doesn't happen all the time and doesn't happen to every user I doubt I can provide something like that but it looks like..

and same with desktop too..
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on June 04, 2020, 10:32:53 AM
It just happend again when I'm using desktop...

Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: Horme Gaming on June 04, 2020, 10:43:53 AM
does it happen when you use the SMF default theme (the one that is used here) ?
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on June 04, 2020, 11:08:03 AM
Quote from: _.EvilExecutor._ on May 30, 2020, 12:39:34 AM
I tried clearing cache, changing the theme and stuff. I will add an attachment to show how it looks like. Any help is welcomed!

Note: The profile Pic doesnt show up in the default SMF theme also

Yeah same with it too :(
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: Arantor on June 04, 2020, 11:10:25 AM
Whichever portal you are using needs an update to use the image proxy.
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: Kindred on June 04, 2020, 11:37:59 AM
you have some problem with your general configuration....  because when I go to your site, it shows me http, not https -- and this prevents many images form appearing.

I can't debug further, because your site requires a login to see anything
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on June 04, 2020, 11:47:11 AM
Yeah I' aware of that. I mean once you are logged in you will redirect to https.

I made a test account

user: test
pass : test
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: m4z on June 04, 2020, 11:47:39 AM
If you just "changed to HTTPS" in the Admin Control Panel, I think you need to run repair_settings afterwards, to change the URLs of your themes, avatars, attachments, etc., to HTTPS, too.

What Kindred refers to is that many browsers nowadays won't show some HTTP ("mixed") content (https://developer.mozilla.org/en-US/docs/Web/Security/Mixed_content/How_to_fix_website_with_mixed_content) when your site is HTTPS. Images would fall under "passive mixed content", and I don't know if (or which) current browsers block them by default.
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: Kindred on June 04, 2020, 11:52:42 AM
right....   so, something is bad in your configuration.

Could be as Arantor suggests and be related to the portal settings...  but your avatar fails to show in https and shows in http

does not show, asks for a login every time, even when I am logged in
https://forum.lazergaming.net/index.php?action=dlattach;attach=14;type=avatar

displays the avatar...
http://forum.lazergaming.net/index.php?action=dlattach;attach=14;type=avatar
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on June 04, 2020, 12:03:24 PM
well for me both the links you provided works...

And I also ran repair tool and changed all link to https.

IDK where I did wrong :(
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: Kindred on June 04, 2020, 01:07:01 PM
your avatar -- is it one of the internal avatars that anyone can choose from, or is it an external avatar from somewhere else?

If it's from somewhere else, and was chosen specifically by/for you --- Did you put it in by URL or did you upload it?
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on June 04, 2020, 08:32:32 PM
I directly uploaded it from my pc to the forum.
Title: Re: Profile Picture Not Showing Up On Mobile!
Post by: _.EvilExecutor._ on June 05, 2020, 08:49:17 PM
Quote from: Kindred on June 04, 2020, 11:37:59 AM
because when I go to your site, it shows me http, not https -- and this prevents many images form appearing.

I was able to fix this by overwriting the .htaccess file using this code
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]


Yet I've got no clue why the profile pictures wont appear sometimes when they are uploaded to the forum.