Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: SALocalcom on June 17, 2020, 10:47:05 PM

Title: Questions as set the forum up
Post by: SALocalcom on June 17, 2020, 10:47:05 PM
I'm trying different themes...a lot of them.  Some of them I don't want to keep.  Can you uninstall them?  I know I can delete them off the server, but then they still show up in theme management, don't they?

Thanks
Title: Re: Questions as set the forum up
Post by: Sir Osis of Liver on June 17, 2020, 11:10:03 PM
Admin -> Themes and Layout -> Theme Settings

Click the red X.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 18, 2020, 12:53:19 PM
Quote from: Sir Osis of Liver on June 17, 2020, 11:10:03 PM
Admin -> Themes and Layout -> Theme Settings  Click the red X.

Thanks, I don't know how I missed that. 

I have another issue.  I copied the themes I like so I could retittle them to indicate to users which works for mobile, desktop...or both.  Just now the copies wouldn't work.  I don't know why, except in the place where you pick which themes can be used, I unchecked the originals so they couldn't be picked.  I was going to uninstall and delete the originals to save disk space.  I can't delete the originals and use the renamed copies?
.
Title: Re: Questions as set the forum up
Post by: I B D on June 18, 2020, 04:21:07 PM
Quote from: SALocalcom on June 18, 2020, 12:53:19 PM
I have another issue.  I copied the themes I like so I could retittle them to indicate to users which works for mobile, desktop...or both.  Just now the copies wouldn't work.  I don't know why, except in the place where you pick which themes can be used, I unchecked the originals so they couldn't be picked.  I was going to uninstall and delete the originals to save disk space.  I can't delete the originals and use the renamed copies?
.

You should be able to however what do you mean originals?  The only theme you CANNOT delete is the default one listed in Themes/default aby other theme you should be able to.

Are you getting an error when you try? what is happening to prevent you
Title: Re: Questions as set the forum up
Post by: Sir Osis of Liver on June 18, 2020, 04:43:59 PM
Where did you change the titles?
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 19, 2020, 10:29:54 AM
themes and layout/manage and install

down at the bottom is...

From a directory on the server:..../public_html/comalnet_frm/Themes/
Create a copy of Default named:  whatever you want to name it.

I've already got the default changed to the one I want to copy.

Then you click install.

.
Title: Re: Questions as set the forum up
Post by: Kindred on June 19, 2020, 11:26:19 AM
create a copy of default DOES NOT create a copy of "your current default theme"

it creates a copy of Curve, aka the SMF default theme (the one in that MUST STAY the /default folder)
Title: Re: Questions as set the forum up
Post by: Sir Osis of Liver on June 19, 2020, 12:32:59 PM
If you just want to change the name of a theme, you have to edit the name in theme_info.xml, remove the theme in Theme Settings, and reinstall it from directory.

Title: Re: Questions as set the forum up
Post by: Arantor on June 19, 2020, 12:37:02 PM
Quote from: Sir Osis of Liver on June 19, 2020, 12:32:59 PM
If you just want to change the name of a theme, you have to edit the name in theme_info.xml, remove the theme in Theme Settings, and reinstall it from directory.


You can rename the human-displayed name from the settings just fine, once a theme is installed.
Title: Re: Questions as set the forum up
Post by: Sir Osis of Liver on June 19, 2020, 01:03:53 PM
Didn't see that, just click on theme name in Theme Settings and there's a page of options.  If copied themes were installed correctly they should work.  I believe you'll have to remove the installed theme before installing a copy of same theme.

Title: Re: Questions as set the forum up
Post by: SALocalcom on June 19, 2020, 06:00:55 PM
Quote from: Arantor on June 19, 2020, 12:37:02 PM
Quote from: Sir Osis of Liver on June 19, 2020, 12:32:59 PM
If you just want to change the name of a theme, you have to edit the name in theme_info.xml, remove the theme in Theme Settings, and reinstall it from directory.

You can rename the human-displayed name from the settings just fine, once a theme is installed.

Yes i'm just trying to rename what the users see when switching themes.  I someone on ah iphone or android accidentally switches to a theme that's not responsive, they're going to have a difficult time switching back.  .....and on some themes switch themes seems hard to find, anyway.

But this looks like 2 ways of doing it, or am i not understanding.
.
Title: Re: Questions as set the forum up
Post by: Arantor on June 19, 2020, 06:09:16 PM
Well, I'm not quite sure you done in terms of copying; my method just changes what name users see - nothing to do with making copies of anything.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 19, 2020, 07:11:14 PM
Quote from: Arantor on June 19, 2020, 12:37:02 PM
You can rename the human-displayed name from the settings just fine, once a theme is installed.

Ok, this worked.  In "current theme". Thanks!

I do also like copies, so I can mess with them and not loose anything.......but really right now there are some basics I need to cover.  One will be the zip code registration I'd mentioned....that might be next.
.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 20, 2020, 09:28:46 AM
Ok, here's my next issue.  Can't find a mod for it...or the right one.

Most people have no idea of how to format a photo.  They just upload whatever is in their phone or camera.  You end up with hugh images that just slow page loading down to a crawl.  I've seen this all over the place.  I thought there were mods that would resize images to the specs you determine.  Am I wrong, there isn't....or just not for smf 2.0.17 ?
Title: Re: Questions as set the forum up
Post by: Doug Heffernan on June 20, 2020, 10:38:40 AM
Quote from: SALocalcom on June 20, 2020, 09:28:46 AM
Ok, here's my next issue.  Can't find a mod for it...or the right one.

Most people have no idea of how to format a photo.  They just upload whatever is in their phone or camera.  You end up with hugh images that just slow page loading down to a crawl.  I've seen this all over the place.  I thought there were mods that would resize images to the specs you determine.  Am I wrong, there isn't....or just not for smf 2.0.17 ?

Have a look at this mod.

https://custom.simplemachines.org/mods/index.php?mod=2206
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 20, 2020, 10:57:00 AM
2.0.17 isn't listed in the specs.

What is the GD module....required for some settings in the attachment settings?

.....tried one didn't work. Called ncode.
Title: Re: Questions as set the forum up
Post by: Doug Heffernan on June 20, 2020, 11:00:35 AM
Quote from: SALocalcom on June 20, 2020, 10:57:00 AM
2.0.17 isn't listed in the specs.

It does not matter. It should work with 2.0.17 as well.

Quote from: SALocalcom on June 20, 2020, 10:57:00 AM
What is the GD module....required for some settings in the attachment settings?

....and I tried the one from smfhacks.  It installed, but doesn't seem to work.

I do not use either of those mods myself, so I can not be of much help. It would be best if you posted your questions at their respective support topics. You might get better help there.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 20, 2020, 11:08:41 AM
Wasn't from smfhacks, somebody else.

I'll see if it installs.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 20, 2020, 11:19:05 AM
Quote from: Doug Heffernan on June 20, 2020, 10:38:40 AM

Have a look at this mod.

https://custom.simplemachines.org/mods/index.php?mod=2206

Yes, this one works fine.  Thanks!
Title: Re: Questions as set the forum up
Post by: Doug Heffernan on June 20, 2020, 11:27:37 AM
Quote from: SALocalcom on June 20, 2020, 11:19:05 AM
Quote from: Doug Heffernan on June 20, 2020, 10:38:40 AM

Have a look at this mod.

https://custom.simplemachines.org/mods/index.php?mod=2206

Yes, this one works fine.  Thanks!

No problem.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 21, 2020, 09:37:17 AM
Quote from: Arantor on June 12, 2020, 02:14:21 PM
If you only have 6 zip codes, that'll fit.

You set up the custom field, set the validation to regex, and then add the mask as:
/^(12345|23456|34567|45678|56789|67890)$/

To force people to enter a zip code during registration, in an effort to keep the forum restricted to residents of one county.....

Ok, I need help understanding this....is this something I need to change in a php page?  Is there a function in the registration I need to add, or a mod I need to install first?

How would I go about doing this, please?

Thanks

Sorry for the multiple posts.  Someone marked the topic solved.  I changed that.  It's an ongoing topic for now, and when I changed it all the posts where there all of a sudden.  I deleted the extra posts.
.
Title: Re: Questions as set the forum up
Post by: Arantor on June 21, 2020, 11:35:11 AM
No, as explained, you create a custom field in the admin panel, set it to required on registration, set its validation to regex, and then put that in the box it gives you.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 21, 2020, 11:49:57 AM
Quote from: Arantor on June 21, 2020, 11:35:11 AM
No, as explained, you create a custom field in the admin panel, set it to required on registration, set its validation to regex, and then put that in the box it gives you.

Ok, I'll look and see...never noticed those functions.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 21, 2020, 11:58:13 AM
Custom profile field.
Title: Re: Questions as set the forum up
Post by: Arantor on June 21, 2020, 12:00:14 PM
Admin > Configuration > Core Features, tick 'advanced profile fields', press save.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 21, 2020, 12:31:43 PM
 Profile Section:
Section of profile this is edited in.

pick; None, account settings, forum profile?

not searchable

users can't see field, admin can edit?

...and I checked this,
Active:
If not selected this field will not be shown to anyone.
not sure if I needed to.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 21, 2020, 12:48:59 PM
That worked as I typed in last post.  Tried the wrong zip, it gives you another chance.  Is there a way to limit the times you can try?

Thanks
Title: Re: Questions as set the forum up
Post by: Illori on June 21, 2020, 01:03:10 PM
no, they can try a million times if they have the time.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 21, 2020, 01:30:06 PM
Any other ideas how to keep people, not from this county out of the forum?

I'm also looking at this mod.
https://custom.simplemachines.org/mods/index.php?mod=2155

Thanks
Title: Re: Questions as set the forum up
Post by: Arantor on June 21, 2020, 01:53:22 PM
The thing is, if you do implement some of these things, you also reduce the chance of getting help if you have a problem down the line.

I'm not in your county; I'm not even in your country...

And the best suggestion for anti-spam actually works here: put questions in on registration that only residents would know.

I'd also point out that in practice other than spammers (who won't care anyway), your main problem will actually be getting people to your forum, not keeping them away.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 21, 2020, 02:03:38 PM
Good points, I do lots of backups if I mess something up.

I'm in one of the fastest growing counties in the US.  I wish they weren't building so many houses in my rural area, but they are.  Lots of these people know little about the county, except it's 50 miles North of San Antonio....moving here to from all over the place, for the jobs.

I appreciate all your help!!
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 22, 2020, 11:26:18 PM
When I created the new profile field, I noticed a field, "255".  Number of characters?  Can you increase that?  It was a field that you could type into.  Could you put 500 or 1000?

Thanks
Title: Re: Questions as set the forum up
Post by: Sir Osis of Liver on June 22, 2020, 11:30:26 PM
Yes, you can increase field length by setting a higher number.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 23, 2020, 08:45:44 AM
More important question.

If I wanted to change my primary domain name, would I have to reinstall the whole forum?

I saw some places, in the themes and layouts with absolute urls which can be changed, but most urls are fully local.

Thanks.
Title: Re: Questions as set the forum up
Post by: Illori on June 23, 2020, 09:12:30 AM
What is repair_settings.php? (https://wiki.simplemachines.org/smf/Repair_settings.php)
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 23, 2020, 12:27:20 PM
The place to fix it.

Thanks, good hint.
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 23, 2020, 12:42:59 PM
Quote from: Illori on June 23, 2020, 09:12:30 AM
What is repair_settings.php? (https://wiki.simplemachines.org/smf/Repair_settings.php)

Yep!  Looks like that did it.

Thanks!!!
Title: Re: Questions as set the forum up
Post by: SALocalcom on June 23, 2020, 07:50:33 PM
I tried adding a privacy policy and checking the box to force it during registration.

It didn't come up.

Is there something somewhere else I need to do?

Thanks