Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: ecotypes@verizon.net on August 31, 2020, 06:15:58 PM

Title: Attachments no longer readable
Post by: ecotypes@verizon.net on August 31, 2020, 06:15:58 PM
Upgraded from 2.0.11. 2.0.17

Database seems to have come over OK

Attachments are, at best, mangled.  I tried setting the Cookie per repair_settings suggestion.  No.  I tried setting it to match the old forum.  No.
However, I can load a new attachment and download it successfully.

Both new and old attachments are in the correct directory.

Something similar happened to user avatars.  Avatars uploaded by the old forum could not be loaded.  Avatars uploaded in the new version load fine.

Does anyone have any ideas of what the issue could be?  There are at least a thousand attachment, so I need a solution.

Thank you in advance. 
Title: Re: Attachments no longer readable
Post by: Arantor on August 31, 2020, 06:19:32 PM
Did you move servers during the upgrade?
Title: Re: Attachments no longer readable
Post by: ecotypes@verizon.net on August 31, 2020, 06:28:27 PM
Yes.  Completely different server.
Title: Re: Attachments no longer readable
Post by: Arantor on August 31, 2020, 06:35:17 PM
Please read https://www.simplemachines.org/community/index.php?topic=374178.0

In short: the way you downloaded them from the old server and uploaded to the new damaged them.

Fixing them without redownloading the original files correctly is borderline impossible and would have to be done forensically at the binary level. (=very time consuming, very expensive if it's even achievable; some kinds of files it is simply not achievable for)
Title: Re: Attachments no longer readable
Post by: ecotypes@verizon.net on August 31, 2020, 06:42:15 PM
Thank you!  I'll download and re-upload them again per this information.

Title: Re: Attachments no longer readable
Post by: jdgretz on September 01, 2020, 08:15:35 PM
Great link - solved a problem that was on my to-do list

jdg
Title: Re: Attachments no longer readable
Post by: ecotypes@verizon.net on September 01, 2020, 08:49:56 PM
The solution worked and worked well.  I would never have guessed that Filezilla would have changed that default.

Thanks!