Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: willerby on May 02, 2021, 12:54:38 PM

Title: ... Home Page redirects
Post by: willerby on May 02, 2021, 12:54:38 PM
Hi, I've recently set up a separate WordPress website which now sits around my forum. The forum set up 13+ years ago (!) was established in a sub-directory ( ??? ??.com/forum) and previously ran the few webpages we had through SimplePortal. The Portal was set to 'Front Page' mode so that anyone visiting the main domain or logging in to the forum was redirected to the 'Home' page set up on SP. I didn't set up a redirect, this was managed either by SMF being set up in a sub-directory or by SimplePortal through its 'front page' setting. I honestly can't recall what was set up 13 years ago or how but that's how it all worked.
So now I have a new home page and various other pages set up in sub-directory ??? ??.com/web. All working great with one exception. Anyone new visiting us using the root domain ??? ??.com (or its variants) still gets redirected to the /forum. I've tried setting a redirect on my server but that just results in a browser error as the max number of redirects is exceeded - I think the server redirect creates a loop with the forum or SP redirect but I'm not really sure :(
This may be a SimplePortal issue but I seem to remember that the prior to uing SP when we just had SMF it used to redirect from the root to the forum.
Can anyone explain what I need to do to resolve?
I have switched SimplePortal to Integrated mode which avoids it using it's old home page when users access the forum, instead they now get the Board Index as is usual. But visitors to lrsoc.com are also being redirected to the Board Index - eg the /forum rather than the home page /web
I hope that makes sense to someone...

My host techies have been unable to resolve, referring me to the forum software. Many thanks for any help you can offer.
Title: Re: ... Home Page redirects
Post by: Kindred on May 03, 2021, 05:59:59 PM
Has to be an htaccess redirect
Title: Re: ... Home Page redirects
Post by: Illori on May 03, 2021, 07:57:38 PM
your site seems to work fine for me, i went to the .com URL and ended up at .com/web not /forum.

i bet people have your forum bookmarked and that is causing the issue.