Simple Machines Community Forum

General Community => Site Comments, Issues and Concerns => Topic started by: Antechinus on September 04, 2021, 06:55:18 PM

Title: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on September 04, 2021, 06:55:18 PM
There you go. Not sure what else I can say. :)
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Mick. on September 04, 2021, 06:59:24 PM
Well then. It works here but not in my own site  :o
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on September 04, 2021, 07:09:47 PM
What are you using to access it here?
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Mick. on September 04, 2021, 07:32:53 PM
Quote from: Antechinus on September 04, 2021, 07:09:47 PMWhat are you using to access it here?
Firefox Developer latest version




Testing quick edit ~ Steve
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Steve on September 05, 2021, 06:42:48 AM
Works with Firefox 91.0.2 + Windows 10 for me.  :)
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Aleksi "Lex" Kilpinen on September 05, 2021, 09:24:50 AM
Testpost.

Quick Edit with FF on Win10.
Modify with FF on Win10.
Quick Edit with Chrome on Win10.
Modify with Chrome on Win10.

Seems to work just fine for me.
Tested FF 91.0.2 and Chrome 92.0.4515.159 on Windows 10 Pro 21H1 Build 19043.1165
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Shambles on September 05, 2021, 10:06:12 AM
Have you got a javascript blocker/extension running?

Just tested it here, and Quick Edit doesn't react if my js blocker is active.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on September 05, 2021, 03:08:00 PM
Ok, gonna try a test. See if I can edit this now.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on September 05, 2021, 03:09:25 PM
Nope. But opened the console in dev tools, and I'm getting this when I try to edit:
Uncaught ReferenceError: oQuickModify is not defined
    onclick https://www.simplemachines.org/community/index.php?topic=578824.new#new:1
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on September 14, 2021, 12:42:08 PM
Ok, you lot. I haz done some more testing. :P

Quick reply is not working for me, at all, with FF 92.0, FF Dev Build 93.0 b4, Chrome 93.0.4577.82, or Edge Version 93.0.961.47. With all of these browsers I get the exact same error in the console and debugger:
Code (Console) Select
Uncaught ReferenceError: oQuickModify is not defined at HTMLLIElement.onclick (VM93 index.php:1323)
Code (Debugger) Select
oQuickModify.modifyMsg('4097895', '')Yes, this is for a message that is still within the editable time limit (just to stave off the obvious muppet question :D ).

The source code for that message just shows the basic markup, with no trace of anything related to quick edit functionality. I think this is going to have to be called an actual bug in 2.1 RC4.
Code (Page source) Select
<div class="keyinfo">
<div id="subject_4097895" class="subject_title subject_hidden">
<a href="https://www.simplemachines.org/community/index.php?msg=4097895" rel="nofollow">Re: [Preview] Ice Cream theme [SMF 2.1 RC4]</a>
</div>
<h5>
<span class="messageicon" >
<img src="https://static.simplemachinesweb.com/smf/smsite/images/post/xx.png" alt="" id="msg_icon_4097895">
</span>
<a href="https://www.simplemachines.org/community/index.php?msg=4097895" rel="nofollow" title="Reply #9 - Re: [Preview] Ice Cream theme [SMF 2.1 RC4]" class="smalltext"><strong>Today</strong> at 02:19:38 AM</a>
<span class="page_number floatright">
#9
</span>
<span class="smalltext modified floatright" id="modified_4097895">
</span>
</h5>
<div id="msg_4097895_quick_mod"></div>
</div><!-- .keyinfo -->
<div class="post">
<div class="inner" data-msgid="4097895" id="msg_4097895">
I am deliberately playing for cool and icy. Summer here can be hell on Earth. Cool and icy is good sometimes. <img src="https://static.simplemachinesweb.com/smf/smileys/simple/wink.gif" alt=";&#41;" title="Wink" class="smiley"><br><br>Anyway it&#39;s still WIP. The basic idea is sound, and it will evolve into something usable.
</div>
</div><!-- .post -->
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Aleksi "Lex" Kilpinen on September 14, 2021, 01:05:40 PM
I'm not at all doubting your report here, but confused about what differs in these cases then - It works for others, on the same browsers on the same os.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on September 14, 2021, 01:13:10 PM
I'm confused too. :D
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: lurkalot on September 14, 2021, 01:59:55 PM
Quote from: Antechinus on September 14, 2021, 01:13:10 PMI'm confused too. :D

I just tested it again here with the same version of Edge you are using. https://www.simplemachines.org/community/index.php?topic=578955.0

Edit

Testing quick edit in Edge in Win 10
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on September 14, 2021, 02:02:28 PM
That doesn't help me. :D :D :D :D :D :D :D
Ok, can anyone think of any other way I can test it, to nail this down?

I have already tried disabling all extensions in FF, and it makes no difference.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Steve on September 14, 2021, 08:36:04 PM
Reinstall Firefox?
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on September 14, 2021, 08:42:11 PM
I doubt that will fix the problem. :D
Quote from: Antechinus on September 14, 2021, 12:42:08 PMQuick reply is not working for me, at all, with FF 92.0, FF Dev Build 93.0 b4, Chrome 93.0.4577.82, or Edge Version 93.0.961.47.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on September 15, 2021, 05:13:14 PM
Just had a bright idea: tried testing quick edit on a standard member account on local RC4. Works perfectly. So, it's something specific to this site.

Yes, have tried clearing cache and cookies, doing hard refresh, restarting browser, all the usual. ;)
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Aleksi "Lex" Kilpinen on September 15, 2021, 07:24:51 PM
Well that's actually a good hint - there are a few different yet somewhat similar issues on this site that I've randomly come across lately, so yeah - there might be something odd going on somewhere.

I was logged in, and checking a like only to learn that I'm banned.
You cannot view this attachment.

I was logged in, and tried to clear my alerts only to be presented a login form.
You cannot view this attachment.

To name a couple examples.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on September 15, 2021, 07:45:08 PM
Lol. Who banned the project manager? :D :D :D
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Aleksi "Lex" Kilpinen on September 15, 2021, 07:52:41 PM
I'd love to blame it all on Liroy, but since immediately after another attempt was fine and getting that notice didn't seem to leave any log entry - I'll file it under "random hiccups".
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: shadav on September 15, 2021, 08:11:39 PM
yeah I randomly get the log in screen on the alerts a page fresh usually fixes it
however I use chrome
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: SleePy on September 15, 2021, 08:19:37 PM
Do you sit on that page for a while?  I.e, long enough that your session times out on the forum?
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Aleksi "Lex" Kilpinen on September 15, 2021, 08:22:51 PM
I can actually replicate that login issue 100% of the time by first going to https://simplemachines.org/ and then opening the alerts, and clicking mark read while on that page. 
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Diego Andrés on September 15, 2021, 09:15:08 PM
So that's not a cust site issue only, good to know  :laugh:
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: SleePy on September 15, 2021, 09:21:26 PM
Ahh yea.  Looks like that page isn't responding properly when the request comes from a cors domain.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on October 23, 2021, 06:16:55 PM
The quick edit is working for me now, at least with Firefox. Firefox is up to v93.0 now, but I don't know if that is relevant.

Have not got around to checking other browsers yet.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on October 25, 2021, 02:04:53 PM
Lol. Stopped working again.  :P
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: SleePy on November 05, 2021, 08:39:40 PM
Try again?
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on November 05, 2021, 08:40:08 PM
Ok. Hang on. Test post.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on November 05, 2021, 08:40:25 PM
Nope. Is still kaput.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: SleePy on November 05, 2021, 08:41:03 PM
I just tested in firefox (mac) with a cleared cache, no issue.  No addons running on it.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on November 05, 2021, 08:47:38 PM
Is still kaput on Windoze 10.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: SleePy on November 05, 2021, 10:47:17 PM
Are you receiving any javascript errors by chance?
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on November 06, 2021, 01:04:42 AM
Ok, another test post.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on November 06, 2021, 01:06:50 AM
Console error message:
Uncaught ReferenceError: oQuickModify is not defined
    onclick https://www.simplemachines.org/community/index.php?topic=578824.new#new:1
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: SleePy on November 06, 2021, 11:25:50 AM
Do you have it in your html source code:
var oQuickModify = new QuickModify
Also type in the console:
window.XMLHttpRequest
Either the code is missing for some reason, or the browser isn't supporting javascript properly to do xhjr.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on November 06, 2021, 04:31:55 PM
I have this (from another thread where I have just posted):

            <li class="quick_edit" id="modify_button_4102136" onclick="oQuickModify.modifyMsg('4102136', '')">
                <a href="javascript:void(0);">
                    <span class="main_icons quick_edit_button"></span>Quick Edit
                </a>
            </li>

And:
            if ('XMLHttpRequest' in window)
            {
                var oQuickModify = new QuickModify({
                    sScriptUrl: smf_scripturl,
                    sClassName: 'quick_edit',
                    bShowModify: true,
                    iTopicId: 579468,
                    sTemplateBodyEdit: '\n\t\t\t\t\t\t<div id="quick_edit_body_container">\n\t\t\t\t\t\t\t<div id="error_box" class="error"><' + '/div>\n\t\t\t\t\t\t\t<textarea class="editor" name="message" rows="12" tabindex="4">%body%<' + '/textarea><br>\n\t\t\t\t\t\t\t<input type="hidden" name="c93aa3d" value="c7b9857a7a00cae8c7f111fd4213ac77">\n\t\t\t\t\t\t\t<input type="hidden" name="topic" value="579468">\n\t\t\t\t\t\t\t<input type="hidden" name="msg" value="%msg_id%">\n\t\t\t\t\t\t\t<div class="righttext quickModifyMargin">\n\t\t\t\t\t\t\t\t<input type="submit" name="post" value="Save" tabindex="5" onclick="return oQuickModify.modifySave(\'c7b9857a7a00cae8c7f111fd4213ac77\', \'c93aa3d\');" accesskey="s" class="button"> <input type="submit" name="cancel" value="Belay That" tabindex="6" onclick="return oQuickModify.modifyCancel();" class="button">\n\t\t\t\t\t\t\t<' + '/div>\n\t\t\t\t\t\t<' + '/div>',
                    sTemplateSubjectEdit: '<input type="text" name="subject" value="%subject%" size="80" maxlength="80" tabindex="7">',
                    sTemplateBodyNormal: '%body%',
                    sTemplateSubjectNormal: '<a hr'+'ef="' + smf_scripturl + '?topic=579468.msg%msg_id%#msg%msg_id%" rel="nofollow">%subject%<' + '/a>',
                    sTemplateTopSubject: '%subject%',
                    sTemplateReasonEdit: 'Reason for editing: <input type="text" name="modify_reason" value="%modify_reason%" size="80" maxlength="80" tabindex="8" class="quickModifyMargin">',
                    sTemplateReasonNormal: '%modify_text',
                    sErrorBorderStyle: '1px solid red',
                    sFormRemoveAccessKeys: 'postmodify'
                });

Typing that code you suggested into the console yields this result:
Uncaught ReferenceError: oQuickModify is not defined
    onclick https://www.simplemachines.org/community/index.php?topic=579468.msg4102136#msg4102136:1
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Kindred on November 06, 2021, 04:37:44 PM
I have no issues with the function
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: SleePy on November 08, 2021, 08:07:44 PM
Typing that code should not mention anything about oQuickModify.  Your browser should respond with something about a function existing.  Chrome responds with:
ƒ XMLHttpRequest() { [native code] }
Right now its like a extension isn't allowing that function to exist, so of course its not working.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on November 09, 2021, 02:41:48 PM
Ok, when I get some coffee into me I'll go through disabling extensions, and see if that makes a difference.

I suspect it won't, because when I first reported this I tried it with every browser I have installed, and had the same issue with all of them, and most of them are not running any extensions at all. Still, it's an easy check for Firefox, so worth trying.
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on February 18, 2022, 06:12:32 PM
This seems to be fixed now. It has just started working again today. Not sure if there were site code changes involved, or if it's just eddies in the space-time continuum. Marking as solved anyway. :)
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Arantor on February 18, 2022, 06:41:05 PM
What's Eddy doing in the space time continuum anyway?
Title: Re: Quick edit not working at all: Firefox + Windows 10
Post by: Antechinus on February 18, 2022, 06:46:31 PM
He likes to hang out there. Thinks it makes him look cool.  8)