Simple Machines Community Forum

SMF Support => SMF 2.1.x Support => Topic started by: chadon on March 12, 2022, 07:34:19 PM

Title: Issues with alerts
Post by: chadon on March 12, 2022, 07:34:19 PM
Since upgrading from 2.1 RC3 to 2.1.1. members of my forum are complaining because they don't receive alerts when there is an answer to their topics and sometimes they all arrive in same time.

Some say they resolve the issue when they delete all their read alerts and it starts again after a few days.
I also have the read alerts set to auto delete each week in the admin panel but nothing happens, I still have alerts from a couple weeks ago.

On Simplemachines, I subscribed to receive alerts for this section a few weeks ago but I never received any while many new topics have been created.
Is this a known bug ? I didn't find any topics about it.
Title: Re: Issues with alerts
Post by: chadon on March 15, 2022, 08:20:03 AM
Nobody else has issues with alerts with his forum?

Is it a know bug or is it just my forum?
Title: Re: Issues with alerts
Post by: Arantor on March 15, 2022, 08:30:49 AM
How busy is your forum?
Title: Re: Issues with alerts
Post by: chadon on March 15, 2022, 09:40:26 AM
Not as busy as it used to be. It has over 1 million total messages and 11 000 total members but now it has about 200 members online and 100 new posts each day.
Title: Re: Issues with alerts
Post by: chadon on March 17, 2022, 01:17:14 PM
Quote from: Arantor on March 15, 2022, 08:30:49 AMHow busy is your forum?
Did you have any idea?

Anyways, I confirm, the alert system is no more functional with SMF 2.1.1.

I don't receive any alerts for subscribed topics or boards on Simplemachines.org and two other forums running under SMF 2.1.1.
Title: Re: Issues with alerts
Post by: Aleksi "Lex" Kilpinen on March 17, 2022, 01:20:44 PM
That's kind of odd, because I do. On this forum. Have you checked your personal notification settings?
Title: Re: Issues with alerts
Post by: Kindred on March 17, 2022, 03:02:52 PM
I receive alerts/notifications on both this and the other 2 2.1.1 sites that I use....

I think your issue is related to something in your personal system....
Title: Re: Issues with alerts
Post by: chadon on March 17, 2022, 05:04:09 PM
Do you receive alerts for topics and boards?

I did receive an alert on March 15 but it was for an updated "Team page" mod, nothing about this topic or the "SMF 2.1.x Support" board.

I also have many users saying they don't receive alerts since the 2.1.1 upgrade.
Title: Re: Issues with alerts
Post by: Illori on March 17, 2022, 05:05:38 PM
they need to set the alerts again for the topics they may have had on watch in SMF 2.0.
Title: Re: Issues with alerts
Post by: chadon on March 17, 2022, 05:24:41 PM
I havn't been using SMF 2.0 since about a couple years when 2.1 RC1 came out and everything was running fine until the 2.1.1 upgrade.

I also started to setup alerts here and on a 3rd forum only after they were upgraded to 2.1.1.
Title: Re: Issues with alerts
Post by: chadon on May 20, 2022, 12:36:19 PM
One month later, my forum has been updated to 2.1.2 and now nobody ever receives alerts.
One month later, Simplemachines has been updated to 2.1.2 and I still didn't receive a single alert.
Does anyone receive alerts other than Kindred ?
Title: Re: Issues with alerts
Post by: Arantor on May 20, 2022, 12:43:23 PM
Yes, I've had alerts today for posts of mine that people have liked.
Title: Re: Issues with alerts
Post by: FrizzleFried on May 20, 2022, 12:46:04 PM
I get alerts here.  I had 3 this morning.

Title: Re: Issues with alerts
Post by: Doug Heffernan on May 20, 2022, 12:50:36 PM
Quote from: chadon on May 20, 2022, 12:36:19 PMOne month later, my forum has been updated to 2.1.2 and now nobody ever receives alerts.
One month later, Simplemachines has been updated to 2.1.2 and I still didn't receive a single alert.
Does anyone receive alerts other than Kindred ?

Personally I have not experienced any issues with alerts.
Title: Re: Issues with alerts
Post by: Aleksi "Lex" Kilpinen on May 20, 2022, 01:49:09 PM
I some times see some lag with alerts here, and then they suddenly come up all at once - but generally alerts work pretty well for me, both here and on my own forum.
Title: Re: Issues with alerts
Post by: Shades. on May 20, 2022, 02:06:16 PM
None today so far but got 9 or 10 yesterday! Seems to be working like it should! 8)
Title: Re: Issues with alerts
Post by: shawnb61 on May 20, 2022, 02:21:32 PM
We should dissect this one piece at a time.

If chadon isn't getting alerts here, let's start with that.  I'd first look at:
 - Confirm Notification settings
 - Confirm you're watching some boards/topics
 - Open the browser console - ensure there are no errors; alerts are dependent on .js

Once chadon starts seeing them here, then cut over to diagnosing the forum.

Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 08:50:24 AM
I received an alert for this topic because Doug Heffernan quoted me but nothing about replies to this topic.

Quote from: shawnb61 on May 20, 2022, 02:21:32 PM- Confirm Notification settings
At the top and bottom of this topic it shows "receive alerts".

- If I go on my profile's watched topics list, it shows :
"Issues with alerts in SMF 2.1.x Support" = No Alerts or Emails

That doesn't make any sense.

- If I go on my profile's watched boards list, it shows :

Current Board Notifications SMF 2.1.x Support New       =  Alert Preferences :receive Alerts.

It shows a new icon because new topics are created regulary and I didn't read them but since I subscribed to this topic a month ago, I didn't receive a single alert.

On my forum, under the 2.1.1 version, I received alerts when I was quoted, when I was mentioned but never when a reply was posted.
Since the 2.1.2 update, I receive no alert at all, not even when I am quoted.

Quote from: shawnb61 on May 20, 2022, 02:21:32 PM- Confirm you're watching some boards/topics
I confirm

Quote from: shawnb61 on May 20, 2022, 02:21:32 PM- Open the browser console - ensure there are no errors; alerts are dependent on .js
The errors are :

  Failed to load resource: net::ERR_BLOCKED_BY_CLIENT lg.php:1

Failed to load resource: net::ERR_BLOCKED_BY_CLIENT show_ads.js:1

Unchecked runtime.lastError: The message port closed before a response was received.

Title: Re: Issues with alerts
Post by: Aleksi "Lex" Kilpinen on May 21, 2022, 09:02:50 AM
In your notification settings, you have selected "How frequently to tell me" as "never". Try changing that, and see if things look different?

Also, there are different levels of notification settings for topics that you can set for each topic separately.
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 09:18:13 AM
Quote from: Aleksi "Lex" Kilpinen on May 21, 2022, 09:02:50 AMIn your notification settings, you have selected "How frequently to tell me" as "never". Try changing that, and see if things look different?
I changed it to immediately.

Quote from: Aleksi "Lex" Kilpinen on May 21, 2022, 09:02:50 AMAlso, there are different levels of notification settings for topics that you can set for each topic separately.
Yes, that's what I explaned in my previous message, it was and still is set to "receive alerts".

I will let you know if the "never" change fixes the issue.
Title: Re: Issues with alerts
Post by: Aleksi "Lex" Kilpinen on May 21, 2022, 09:20:40 AM
Lets try.
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 09:40:26 AM
Ahhhhhh!!! I received an alert for your "lets try".

I will try that on my forum. Thanks Aleksi.
Title: Re: Issues with alerts
Post by: Aleksi "Lex" Kilpinen on May 21, 2022, 09:41:58 AM
You're welcome :)
Title: Re: Issues with alerts
Post by: FrizzleFried on May 21, 2022, 10:06:32 AM
Oh,  and to add to the pile...

Yesterday I posted a post that got 7 likes during the day (that is what is reported on the post).

Any idea why in my ALL ALERTS section I only show... 2?

Seems ... wrong to me...

Title: Re: Issues with alerts
Post by: Arantor on May 21, 2022, 10:11:26 AM
If you visited the topic in the meantime the alerts would have been marked as read because my little patch isn't installed here so visiting the topic marks them read automatically. Check your 'all alerts' page for them.
Title: Re: Issues with alerts
Post by: FrizzleFried on May 21, 2022, 10:22:47 AM
That is what I mean... my ALL ALERTS page has 2 entries ... total ... for likes on that post...

This is my ALL ALERTS page for yesterday.  There was one more that is not included on this image that fell below but had nothing to do with the post in question.  Note only TWO "likes" for that post.



Title: Re: Issues with alerts
Post by: FrizzleFried on May 21, 2022, 10:27:32 AM
FWIW... your "fix" for my forum "fixes" this issue as well.  Since I implemented that fix I have gotten exactly ZERO complaints on the matter.

Crazy,  huh?   That (fixed) behavior is EXACTLTY what my users were used to and expecting.

:)
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 10:58:32 AM
Quote from: chadon on May 21, 2022, 09:40:26 AMAhhhhhh!!! I received an alert for your "lets try".

I will try that on my forum. Thanks Aleksi.
I tried the same settings on my forum and I still don't receive any alert.
Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 02:01:58 PM
Quote from: chadon on May 21, 2022, 10:58:32 AM
Quote from: chadon on May 21, 2022, 09:40:26 AMAhhhhhh!!! I received an alert for your "lets try".

I will try that on my forum. Thanks Aleksi.
I tried the same settings on my forum and I still don't receive any alert.

Are you receiving no alerts at all?  Or only a subset of expected alerts?

As noted above, there are some measures to avoid alert spam.  E.g., it will try not to send dupes if you have unread alerts.  Also, it will try not to send alerts if it knows you have read the thread up to that point.  E.g., if you have a thread open, and are wondering why you're not getting alerts for updates to that thread, it's because you're already looking at it.  For a good test, you need to be browsing elsewhere.

Alerts are intended to bring your attention to updates in a thread you were interested in that you might have missed.  The alerts are not a log of all updates to that thread.  (The thread itself is the log of all updates to the thread...)
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 02:09:24 PM
Quote from: shawnb61 on May 21, 2022, 02:01:58 PMAre you receiving no alerts at all?
I deleted all read alerts after I updated from 2.1.1 to 2.1.2 and I didn't receive a single one since.
No other members of the forum have reported receiving alerts either. To my knowledge, they all have the same problem as me.

Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 02:15:44 PM
Quote from: chadon on May 21, 2022, 02:09:24 PM
Quote from: shawnb61 on May 21, 2022, 02:01:58 PMAre you receiving no alerts at all?
I deleted all read alerts after I updated from 2.1.1 to 2.1.2 and I didn't receive a single one since.
No other members of the forum have reported receiving alerts either. To my knowledge, they all have the same problem as me.

Were you receiving alerts before then?  When you say you deleted them, where/how did you delete them?
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 02:25:33 PM
Before the update, I didn't receive alerts for replies to subscribed topics but I did receive them for "likes" "quoted messages" and things like that.
I deleted them from this page :
/index.php?action=profile;area=showalerts
by using the "DELETE ALL READ ALERTS" button.
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 02:28:12 PM
Also, before the 2.1.2 update, I had complaints about alerts not working when users had too many of them and it worked again after they used the "DELETE ALL READ ALERTS" button.
Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 02:32:10 PM
Can you look in the DB and see if there are records in the smf_background_tasks table?  How many are there?

More questions:
 - Any errors in the error log?
 - Any errors in your apache log?
 - PHP version?
 - MySQL version?
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 02:36:18 PM
A lot. I have 64 pages of 25 rows each.
Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 02:40:10 PM
OK, so the plumbing is clogged somehow...  Them there are undelivered alerts.

I snuck this in earlier, you may have missed it...
Quote from: shawnb61 on May 21, 2022, 02:32:10 PMMore questions:
 - Any errors in the error log?
 - Any errors in your apache log?
 - PHP version?
 - MySQL version?
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 02:53:15 PM
Quote- Any errors in the error log?
7 errors since the last 24h but nothing rekated to that. They are mostly permission issues or bad passwords

Quote from: shawnb61 on May 21, 2022, 02:40:10 PM- Any errors in your apache log?
I'm not sure how to read them.
From the "errors" feature on cPanel, the "Latest web server error log messages" are from the 10th of May but there are a lot of them.

Should I paste them here ?
Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 02:54:54 PM
Quote from: chadon on May 21, 2022, 02:53:15 PM
Quote- Any errors in the error log?
7 errors since the last 24h but nothing rekated to that. They are mostly permission issues or bad passwords

Quote from: shawnb61 on May 21, 2022, 02:40:10 PM- Any errors in your apache log?
I'm not sure how to read them.
From the "errors" feature on cPanel, the "Latest web server error log messages" are from the 10th of May but there are a lot of them.

Should I paste them here ?

Yes.  Generally, you should try to 'anonymize' them, so we don't see forum internal paths, etc. 
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 02:56:14 PM
I forgot that:
Quote from: shawnb61 on May 21, 2022, 02:40:10 PM- PHP version?
PHP Version    7.4.29

Quote from: shawnb61 on May 21, 2022, 02:40:10 PM- MySQL version?
Version    mysqlnd 7.4.29
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 03:06:18 PM
I see on some of the errors that php 8 was used and that's because i did some tests that day to see if it would work better under php 8.

Quote[Tue May 10 21:22:06.416598 2022] [cgi:error] [pid 16015] [client 207.46.13.4:20864] AH01215: PHP Fatal error:  require_once(): Failed opening required '/home/xxxx/public_html/fr/Sources/PrettyUrls-Filters.php' (include_path='.:/opt/cpanel/ea-php74/root/usr/share/pear') in /home/xxxxx/public_html/fr/Sources/QueryString.php on line 769: /usr/local/cpanel/cgi-sys/ea-php74
[Tue May 10 14:01:22.896256 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215:   thrown in /home/xxxx/public_html/fr/Sources/Subs-Db-mysql.php on line 1027: /usr/local/cpanel/cgi-sys/ea-php80, referer: https://www.mustangv8.com/fr/index.php
[Tue May 10 14:01:22.895730 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215: #5 /home/xxxx/public_html/fr/Sources/Session.php(187): smf_db_insert('replace', 'smf_sessions', Array, Array, Array): /usr/local/cpanel/cgi-sys/ea-php80, referer: https://www.mustangv8.com/fr/index.php
[Tue May 10 14:01:22.895406 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215: #4 /home/xxxx/public_html/fr/Sources/Subs-Db-mysql.php(802): smf_db_query('', '\\n\\t\\t\\tREPLACE INT...', Array, Object(mysqli)): /usr/local/cpanel/cgi-sys/ea-php80, referer: https://www.mustangv8.com/fr/index.php
[Tue May 10 14:01:22.895040 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215: #3 /home/xxxx/public_html/fr/Sources/Subs-Db-mysql.php(494): smf_db_error('\\n\\t\\t\\tREPLACE INT...', Object(mysqli)): /usr/local/cpanel/cgi-sys/ea-php80, referer: https://www.mustangv8.com/fr/index.php
[Tue May 10 14:01:22.894709 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215: #2 /home/xxxx/public_html/fr/Sources/Subs-Db-mysql.php(590): log_error('Erreur de base ...', 'database', '/home/xxxx/p...', 187): /usr/local/cpanel/cgi-sys/ea-php80, referer: https://www.mustangv8.com/fr/index.php
[Tue May 10 14:01:22.894344 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215: #1 /home/xxxx/public_html/fr/Sources/Errors.php(129): smf_db_error_insert(Array): /usr/local/cpanel/cgi-sys/ea-php80, referer: https://www.mustangv8.com/fr/index.php
[Tue May 10 14:01:22.894110 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215: #0 /home/xxxx/public_html/fr/Sources/Subs-Db-mysql.php(1027): mysqli_stmt_bind_param(false, 'iissssssis', 17991, 1652184082, 'c2e69e2f', '?pretty;action=...', 'Erreur de base ...', '396c5cfc3fcbf1f...', 'database',
 
Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 03:19:42 PM
Close.  That looks like you have (or had) issues with Pretty URLs.

What do the LAST errors look like?  Do you see any entries that include cron.php?

Also...  What do the FIRST entries look like in smf_background tasks?  (You should be able to sort by id_task in phpmyadmin... We are looking for tasks with the lowest #s...)
Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 03:57:43 PM
If you haven't yet, you should fix the Pretty URLs issue.  I'd check in with the support thread over there. 

It is not likely to be related to your alerts issues, but, who knows...
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 04:40:07 PM
Quote from: shawnb61 on May 21, 2022, 03:19:42 PMWhat do the LAST errors look like?
Here is the last one recorded:
Quote[Tue May 10 21:22:06.416598 2022] [cgi:error] [pid 16015] [client 207.46.13.4:20864] AH01215: PHP Fatal error:  require_once(): Failed opening required '/home/xxxx/public_html/fr/Sources/PrettyUrls-Filters.php' (include_path='.:/opt/cpanel/ea-php74/root/usr/share/pear') in /home/xxxx/public_html/fr/Sources/QueryString.php on line 769: /usr/local/cpanel/cgi-sys/ea-php74

Quote from: shawnb61 on May 21, 2022, 03:19:42 PMDo you see any entries that include cron.php?
No, there is nothing about cron.php

QuoteAlso...  What do the FIRST entries look like in smf_background tasks?  (You should be able to sort by id_task in phpmyadmin... We are looking for tasks with the lowest #s...)
Here are the entries with the lowest "id_task"

capture.png

It looks like the 1st one is the only one with a "claimed_time" not at 0. Could it be the issue?
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 04:44:18 PM
Quote from: shawnb61 on May 21, 2022, 03:57:43 PMIf you haven't yet, you should fix the Pretty URLs issue.  I'd check in with the support thread over there. 

It is not likely to be related to your alerts issues, but, who knows...
I don't know how to fix the Pretty URLs issue but I just uninstalled the mod.
Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 04:52:36 PM
Ok, one step at a time... 

Let's see if that fixes things.  Observe a bit - make sure the errors went away.  Also check on your oldest background tasks - look for changes.

If not, I'd delete the oldest background task.  The "claim" time just means it's been trying to work on that one for the last 10 days...

Again, observe a bit, errors, oldest tasks, etc.
Title: Re: Issues with alerts
Post by: Arantor on May 21, 2022, 04:55:21 PM
That sounds like there's a super-hard fail somewhere in cron.php because the whole point of the claimed time is that if cron is invoked a second time within the claimed time period (5 minutes IIRC), that second invocation can go onto the next thing in the queue.

Claiming it takes it out the queue for consideration, not really the same as 'I've been working on this task since then'.
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 05:08:24 PM
Quote from: shawnb61 on May 21, 2022, 04:52:36 PMlook for changes. 
Yep! I now have users complaining about dead links.  :laugh:
Quote from: shawnb61 on May 21, 2022, 04:52:36 PMLet's see if that fixes things. 
No new alerts came.

Quote from: shawnb61 on May 21, 2022, 04:52:36 PMAlso check on your oldest background tasks - look for changes.
No change to the oldest one.
Quote from: shawnb61 on May 21, 2022, 04:52:36 PMIf not, I'd delete the oldest background task.
Quote from: Arantor on May 21, 2022, 04:55:21 PMThat sounds like there's a super-hard fail somewhere in cron.php because the whole point of the claimed time is that if cron is invoked a second time within the claimed time period (5 minutes IIRC), that second invocation can go onto the next thing in the queue.

Claiming it takes it out the queue for consideration, not really the same as 'I've been working on this task since then'.
Do I delete the oldest one or not?
Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 05:11:15 PM
I'd observe for a few more minutes.  Navigate around.

If no change, then yes, delete it, and see if thst changes anything.

Again, keep observing, navigate around, check errors, both smf & apache, watch the queue.
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 05:20:38 PM
Quote from: chadon on May 21, 2022, 02:36:18 PMA lot. I have 64 pages of 25 rows each.
I now have 65 pages. It's the only change I see.
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 05:23:39 PM
There is also a detail I forgot to tell you. After not getting any alert after the 2.1.2 update, I tried to uninstall all mods, delete all hooks and uploaded fresh Sources and Themes files and it didn't fix the alert issue.
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 05:30:23 PM
Quote from: shawnb61 on May 21, 2022, 05:11:15 PMIf no change, then yes, delete it, and see if thst changes anything.
I deleted it and I see no change. The new oldest task has a "claimed_time" still at 0.
Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 05:32:09 PM
Nothing new in smf or apache logs?

When you reloaded source, there is still a current cron.php out there, correct?
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 05:35:33 PM
Quote from: shawnb61 on May 21, 2022, 05:32:09 PMNothing new in smf or apache logs?

When you reloaded source, there is still a current cron.php out there, correct?
No nothing new.
I tried to run cron.php by typing its URL and it's still there.
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 05:37:13 PM
Quote from: shawnb61 on May 21, 2022, 05:32:09 PMWhen you reloaded source, there is still a current cron.php out there, correct?
you are talking about the cron.php file at the root directory and not in the Sources' folder, right?
Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 05:44:26 PM
Yes. 

If you open your browser console, do you see any errors or warnings?
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 05:49:24 PM
I see those:

Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 05:53:28 PM
Yikes... 

I would keep working those issues until they're all gone.  None of that looks familiar... 

The 9 errors are collapsed - can you expand them?  I'm trying to see if there is an error related to cron.php.
Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 06:00:20 PM
A quick search, & it appears like you have a facebook utility that is running an old version of jquery. 

Are you running custom jquery?  Do you know? 

Can you deinstall the facebook plugin? 
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 06:06:49 PM
Cookieconsent is from a mod.
Epn smart tools is an ebay affiliate script
The Facebook ones are from a Facebook page block displayed by Ezportal.
I think they are being blocked by Adguard Adblocker.



Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 06:08:10 PM
Quote from: shawnb61 on May 21, 2022, 06:00:20 PMAre you running custom jquery?  Do you know? 
I don't think so.
Quote from: shawnb61 on May 21, 2022, 06:00:20 PMCan you deinstall the facebook plugin? 
OK
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 06:13:48 PM
The Facebook plugin is gone but still no alerts.

Title: Re: Issues with alerts
Post by: Arantor on May 21, 2022, 06:14:14 PM
So I visited the site in the screenshots... figured I could just look at whether cron.php was being visited by the network tab (which it was) and then just looked at the output.

It says:
QuoteSMF file version (2.1.1) does not match SMF database version (2.1.2).
Run the SMF upgrader to fix this.
More information.

Seems to me that might be relevant preventing it from running the queue and why it's not touched it in 10 days.
Title: Re: Issues with alerts
Post by: shawnb61 on May 21, 2022, 06:20:32 PM
Is cron.php 2.1.1 or 2.1.2?  What happens if you refresh cron.php with the latest from 2.1.2?
Title: Re: Issues with alerts
Post by: chadon on May 21, 2022, 06:27:11 PM
Wow! You're good Arantor.

I uploaded a cron.php from 2.1.2 and guess what, alerts are now all coming.

The only thing I don't understand is why cron.php was never updated.

Thank you Arantor.
Title: Re: Issues with alerts
Post by: Arantor on May 21, 2022, 06:28:37 PM
Glad it's working :)
Title: Re: Issues with alerts
Post by: chadon on May 23, 2022, 08:05:05 AM
I have a new issue with alerts.

When i have new alerts, the "Alerts" tab on the top of the pages on my forum, shows nothing. I have to click on that tab then click on "All alerts" to view the new ones.
If I want to "delete all alerts", nothing happens as they are all marked as unread. I have first to select all, then delete all read alerts.

To make sure I am clear, I have the "Alert" tab showing no alert while I have the "show alerts" page showing 8 unread alerts since my last visit last night.

Title: Re: Issues with alerts
Post by: Kindred on May 23, 2022, 01:18:14 PM
it sounds like you have something majorly messing with your system.... either a bad mod or a bad theme...  because I can not recreate
Title: Re: Issues with alerts
Post by: chadon on May 23, 2022, 04:33:31 PM
Or it could be coming from my computer. My unread - all alerts on Simplemachines don't make much sense either.

Title: Re: Issues with alerts
Post by: chadon on May 23, 2022, 04:36:13 PM
Sorry, it does make sense. I have read the topics with Kindred's replies so they don't show in the unread alerts.

I wish it could work like that on my forum. I will try to disable mods, the theme is the default one. Thanks Kindred.