Simple Machines Community Forum

SMF Support => Language Specific Support => Suomenkielinen tuki (Finnish) => Topic started by: JuhaS14 on March 18, 2004, 03:01:14 AM

Title: PHP-versio!
Post by: JuhaS14 on March 18, 2004, 03:01:14 AM
Tarkistakaa että PHP-versionne on mielellään 4.3.4, tämä onnistuu tekemällä pikkuscripti:

<?php

phpinfo();

?>

Ja muistakaa, että se gdlib tulisi olla asennettuna... Säästää monelta ongelmalta...

Ainakin itsellä oli niin vanha (...mutta toimiva) versio PHP:stä, että ongelmia esiintyi vaikka gdlib olikin asennettuna...
Title: Re: PHP-versio!
Post by: Owdy on March 18, 2004, 04:36:10 AM
GDLIBbiä ei kai tarvitse kuin noihin avatar scripteihin?
Title: Re: PHP-versio!
Post by: JuhaS14 on March 18, 2004, 04:39:51 AM
GDLIBbiä ei kai tarvitse kuin noihin avatar scripteihin?

Tarttee käsittääkseni muuhunkin, esim. kuvien pienentämiseen keskustelualueella... Ainakin monesti tullut herja itselleni noista kuvista (vaikkei mitään pienennöksiä olekaan päällä) ja ne on kyllä ihan selkeesti gdlibin funtioita.
Title: Re: PHP-versio!
Post by: JuhaS14 on March 18, 2004, 09:18:50 AM
GDLIBbiä ei kai tarvitse kuin noihin avatar scripteihin?

Tarttee käsittääkseni muuhunkin, esim. kuvien pienentämiseen keskustelualueella... Ainakin monesti tullut herja itselleni noista kuvista (vaikkei mitään pienennöksiä olekaan päällä) ja ne on kyllä ihan selkeesti gdlibin funtioita.

Elikä ainakin kuvien uppaaminen tuntuu vaativan SMF:ssä ton GDlibin.
Title: Re: PHP-versio!
Post by: Villesa on March 18, 2004, 11:16:54 AM
Onko nämä kunnolla riittävät?

lainaus palvelun tarjoajan meilistä
"normaali php + gd2 -kirjasto käytännössä php -puolelta, ja mysql-tukea varten tarpeelliset asiat."
 
Ja http://sadevuo.net/phpinfo.php
Title: Re: PHP-versio!
Post by: JuhaS14 on March 18, 2004, 11:39:52 AM
On riittävät. PHP-versiokin on suhteellisen tuore vaikkei ihan viimeisin olekaan...
Title: Re: PHP-versio!
Post by: Villesa on March 18, 2004, 11:45:26 AM
Kiitoksia.
Title: Re: PHP-versio!
Post by: Owdy on March 18, 2004, 12:32:12 PM
GDLIBbiä ei kai tarvitse kuin noihin avatar scripteihin?

Tarttee käsittääkseni muuhunkin, esim. kuvien pienentämiseen keskustelualueella... Ainakin monesti tullut herja itselleni noista kuvista (vaikkei mitään pienennöksiä olekaan päällä) ja ne on kyllä ihan selkeesti gdlibin funtioita.

Elikä ainakin kuvien uppaaminen tuntuu vaativan SMF:ssä ton GDlibin.
Niin se taitaa olla, eli kaikkiin "kuvascripteihin". :D
Title: Re: PHP-versio!
Post by: Villesa on March 19, 2004, 01:12:58 PM
MySQL versio: 4.0.16-standard-log
Server versio: Apache/2.0.47 (Unix) PHP/4.3.3
GD versio: bundled (2.0.15 compatible)

Mitä tuo GD siis loppuenlopuksi tekee? Onko se "oikea" ohjelma vai jotain scriptiä?
Title: Re: PHP-versio!
Post by: kurotenshi on March 19, 2004, 02:02:03 PM
GD on kuvia varten oleva kirjasto.. Esim kuva galleriat käyttää sitä..
Title: Re: PHP-versio!
Post by: JuhaS14 on March 19, 2004, 03:24:20 PM
GD = PHP:n grafiikkakirjasto.
Title: Re: PHP-versio!
Post by: dazer on March 29, 2004, 09:53:49 AM
Versio info:
PHP versio: 4.3.5
MySQL versio: 4.0.18
Server versio: Apache/1.3.30-dev (Unix) PHP/4.3.5
GD versio: bundled (2.0.17 compatible)