• Welcome to Simple Machines Community Forum. Please login or sign up.

Μέχρι ποια έκδοση MySql τρέχει το SMF και το TP;

Started by leftezi, August 10, 2006, 08:24:14 AM

Previous topic - Next topic

leftezi

Μέχρι ποια έκδοση MySql τρέχει το MSF και το TP;
Στο server μου έχει MySQL 3.23.58
είναι ΟΚ;

Ρωτάω γιατί ενώ κάνω καθαρή εγκατάσταση εξ' αρχής, μόλις πάω να ποστάρω στο "Καλώς ορίσατε στο SMF!" Μου λέει ότι συνέβη κάποιο σφάλμα και αυτός ο πίνακας δεν υπάρχει!
Αν φτιάξω δικό μου πίνακα ή δικιά μου κατηγορία και πάω να ποστάρω βγάζει πάλι το ίδιο σφάλμα:

"Συνέβη ένα σφάλμα!
O πίνακας που επιλέξατε δεν υπάρχει."


Σβήνω τα πάντα (κατηγορίες - πίνακες), φτιάχνω καινούργια κατηγορία και πίνακα πάω να μπω και μου λέει:
You have an error in your SQL syntax near ' 1, 4.0)' at line 4
Αρχείο: /home/httpd/vhosts/travelforum.gr/httpdocs/Sources/MessageIndex.php
Γραμμή: 102


leftezi

Αυτό το "error in your SQL syntax near ' 1, 4.0)' at line 4" δεν ξέρω τι σημαίνει και πού είναι.

Η γραμμή 102 του MessageIndex.php πάντως γράφει:
VALUES ($modSettings[maxMsgID], $ID_MEMBER, $board)", __FILE__, __LINE__);

Καταλαβαίνει κανείς τι φταίει;

mforum

Minimum System Requirement

To run SMF, the webserver you're hosted on must meet a few simple requirements. These are not terribly high, and as such most hosts meet them.

    * Any webserver that properly supports PHP, such as Apache or Internet Information Services (IIS).
    * PHP 4.1.0 or higher.

        # MySQL 3.23.4 or higher.


Θα το βρεις εδώ => http://www.simplemachines.org/download/requirements.php

leftezi

Ευχαριστώ, mforum, δεν το είχα προσέξει γιατί πάταγα το "Downloads" της αρχικής σελίδας που σε πάει κατευθείαν στα αρχεία για κατέβασμα.

Άρα λοιπόν δε φταίει η έκδοση της MySql (3.23.58), ούτε του PHP (4.3.2).
Με τις τόσες εγκαταστάσεις που έχω κάνει ως τώρα, έχω μάθει τη διαδικασία σχεδόν απ' έξω. Ίσως έκανα κάποιο λάθος από τη βιασύνη μου. Με την πρώτη ευκαιρία θα δοκιμάσω ξανά από την αρχή, προσεκτικά κι άμα βγάλει πάλι τα ίδια σφάλματα θα ξαναενοχλήσω.

EDIT: Μέχρι τότε αν κάποιος ξέρει κάτι για τα παραπάνω σφάλματα ας το καταθέσει, μπορεί να γλιτώσω την επανεγκατάσταση. Δεν ξέρω και πώς να κάνω unzip στο server και με το FTP (αποσυμπιεσμένα) παίρνει αρκετή ώρα.
Το forum είναι το www.travelforum.gr, δοκιμάστε να μπείτε στο "Νέο Πίνακα".

Επ' ευκαιρίας και γι' αυτό αν έχετε κάποια απάντηση: Πώς κάνουμε unzip ένα αρχείο στο server; (από όσα μου είπαν οι υπεύθυνοι του server, υπάρχει αυτή η δυνατότητα)

mforum

Μήπως το εγκατέστησες σε μία παλιά βάση που είχε ήδη SMF και όχι σε καινούργια;
Για unzip δοκίμασε να τρεξεις το zip αφου το ανεβάσεις.

leftezi

Όχι. Όταν λέω καθαρή εγκατάσταση εννοώ όλα καινούργια (και η βάση) - εκ του μηδενός.

Quote from: mforum on August 12, 2006, 04:07:16 AM
Για unzip δοκίμασε να τρεξεις το zip αφου το ανεβάσεις.
Αυτό δεν ξέρω: πώς το τρέχουν. Στο filezilla που χρησιμοποιώ για FTP όταν κάνω διπλό κλικ σε κάτι, το κάνει download στο δίσκο, και δε βλέπω κάποια επιλογή για εκτέλεση - run ή κάτι τέτοιο με δεξί κλικ πάνω στο αρχείο!

mforum

επέλεξε το αρχείο και κοίτα στο menu στα tools μηπως εχει εκει τις εντολές, εγω χρησιμοποιώ το ws ftp pro, βγαζει τις εντολές με δεξί κλικ στο αρχείο. :)

leftezi

Το 'ψαξα, δεν έχει. Θα κατεβάσω κι εγώ το ws ftp pro

leftezi

Το εγκατέστησα - ποια εντολή είναι;
Το execute απλώς μου το αποσυμπιέζει στο δίσκο μου
Καποια από τις Operations > FTP Commands > αλλά ποια;;


ή μήπως του φταίει η κατάληξη (φορμά) "zip'
Μήπως θέλει κανένα "gz" ή κάτι άλλο;

mforum

είναι σίγουρο ότι ο σέρβερ έχει το unzip module ;
δοκίμασε από html  www.domain.com/fakelos/file.zip

leftezi

Όταν λές "Δοκίμασε από html" εννοείς μέσω browser;

www.travelforum.gr/text12.zip
Ανοίγει το 7zip που έχω εγκατεστημένο.

Όταν ρώτησα στο server για το αν γίνεται unzip επιτόπου μου είπαν:
"Το υποστηρίζει, αν δεν ξέρεις πώς να το κάνεις, πες μας να σου το κάνουμε εμείς"
Λες να με παραμυθιάζουν;

Έψαξα και στο cpanel (plesk) μήπως έχει καμιά επιλογή στον file manager αλλά δεν υπάρχει τίποτα.

mforum

Quote from: leftezi on August 12, 2006, 05:43:48 AM
www.travelforum.gr/text12.zip
Ανοίγει το 7zip που έχω εγκατεστημένο.


είναι φυσικό να το κατεβάζει ή να το ανοίγει στο pc σου  :D  βλακεία μου  ;)
για να αποσυμπιέσεις το αρχείο στον σέρβερ πρέπει να το κάνεις μέσα από ένα php script, σου συνειστώ τον παραδοσιακό τρόπο, unzip στον σκληρό σου και ανέβασε τον φάκελο, αν το safe mod του σέρβερ δεν σου δίνει full upload speed απο το ftp, δημιούργησε τον φάκελο και ανέβασε τα αποσυμπιεσμένα αρχεία μέσα σε αυτόν από τον διαχειριστή αρχείων του cpanel.  :)

leftezi

Πιο γρήγορα δε νομίζω να γίνεται.
Έχω ADSL 512/128 αλλά και πάλι παίρνει αρκετή ώρα.
Μου έβαλες ιδέες. Ψάχνω για το php script που ανέφερες αλλά πρέπει να δω και πώς το χρησιμοποιούν!

mforum

Πάνω από 12-13 kb/s δεν μπορεί να πιάσει η σύνδεση σου.  :)

leftezi

Γι' αυτό ψάχνομαι...
κάτι βρήκα εδώ:
Zipping and Unzipping Files with PHP
http://www.jimmyr.com/blog/Zipping_and_Unzipping_Files_PHP_166_2006.php
ίσως το δοκιμάσω.
.
.

Μπα... δύσκολα πράγματα για μένα
γυρίζω στην παραδοσιακή μέθοδο.

mforum

οτι μαθαίνει κάποιος καλό ειναι αλλά καλύτερα να γυρεύεις την δουλειά σου.  :)

leftezi

Τα έκανα όλα ξανά από την αρχή.
Πρόσεξα πολύ μην κάνω κανένα λάθος αν και καμιά φορά το μυαλό κολλάει, πιστεύω ότι τα έκανα όλα σωστά.
Καινούργια βάση με νέο όνομα (σβησιμο της παλιάς)
Κι όμως πάλι το ίδιο μήνυμα. Μόλις πάω να ποστάρω στον αρχικό πίνακα μου βγάζει:

"Συνέβη ένα σφάλμα!
O πίνακας που επιλέξατε δεν υπάρχει."

Τι μπορεί να φταίει;
Έχω κολλήσει και δεν μπορώ να προχωρήσω με τίποτα!

Help Please :'(

mforum

Αν τα έκανες όλα σωστα θα πρέπει να σου έβγαλε το μήνυμα SMF installed succesfully.
Αν βάλεις την γλώσσα στα Αγγλικά, πάλι το ίδιο σφάλμα έχεις;
Το πρόβλημα σου μου μοιάζει για εγκατάσταση σε ήδη υπάρχουσα παλιά βάση δεδομένων.

leftezi

Το σκέφτηκα κι εγώ.
Θα δοκιμάσω και μόνο αγγλικά.

Τη βάση την είχα σβήσει κι έφτιαξα καινούργια.

leftezi

Και σε πεντακάθαρη αγγλική εγκατάσταση, με καινούργια και μοναδική βάση πάλι το ίδιο:
Μόλις πάω να ποστάρω στο "Welcome to SMF!" μου βγάζει αυτό.

The board you specified doesn't exist

>:( >:( >:( >:( >:( >:(

Είναι η 4η προσπάθεια, άρα δεν έφταιγαν και οι προηγούμενες, κάτι άλΛο συμβαίνει.

Τι μπορεί να φταίει;

----------------------------------

Μόλις ξαναδοκίμασα να ποστάρω - δεν έκανα καμία απολύτως αλλαγή - όμως άλλαξε μήνυμα.
Αντί να μου βγάζει το παραπάνω, τώρα βγάζει μια λευκή σελίδα που γράφει:

You have an error in your SQL syntax near '.msg1' at line 12

Help!!

Advertisement: