• Welcome to Simple Machines Community Forum. Please login or sign up.
January 22, 2022, 01:15:11 AM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


Paid Subscriptions

Started by Grudge, August 12, 2006, 06:09:49 AM

Previous topic - Next topic

desistyle


allotments4all

Just to let people know I have fixed my issue.

It was caused by an extra comma in Profile.php,

The last entry in the

$sa_allowed = array(

had a comma at the end, which caused an a few of the items to not be displayed.

On another note I would like to have an icon on the page which takes users directly to the subscription area, does anyone know how to achieve this?

Thanks

Dan Fulton

qtime

Quote from: desistyle on August 23, 2006, 03:21:24 AM
all i see is this
I think you need to create a new membergroup, like donator or something like that.
set that membergroup with the right board permissions, you want to have them access to.
After you added a new group, you should see this in the list of primary membergroups.
If not, the mod is not working correct. And I don't know what else to do, maybe you can delete it and retry installing.

desistyle

Yeap i did all this i guess mod is not working with 1.1 rc3 c an someone please check into it

allotments4all

Quote from: desistyle on August 23, 2006, 01:54:51 PM
Yeap i did all this i guess mod is not working with 1.1 rc3 c an someone please check into it

I am using it with RC3, once I had found the extra comma (I think due to the ignore board mod) it works great.

When you create a new member group from the SMF admin area, make sure you do not base it on posts.

It does work!

Cheers

Dan

desistyle

Quote from: allotments4all on August 23, 2006, 02:54:05 PM
Quote from: desistyle on August 23, 2006, 01:54:51 PM
Yeap i did all this i guess mod is not working with 1.1 rc3 c an someone please check into it

I am using it with RC3, once I had found the extra comma (I think due to the ignore board mod) it works great.

When you create a new member group from the SMF admin area, make sure you do not base it on posts.

It does work!

Cheers

Dan

i did not based it on posts and can u plz tell me abt the extra comma how to fix that

NukeWorker.com

Many questions have been answered on this original post about the paid subscriptions mod:

http://www.simplemachines.org/community/index.php?topic=13737.0

digit

not to repeat myself ;) - but I am getting the error "unknown transaction type in ipn.php"

(it seems about 50% of the time)

How can I debug this?

Thanks in advance.
Happily using a heavily modified 1.1.16 version of SMF!

2748011 Posts in 320998 Topics by 50986 Members


SOLD my website - thanks it was a good run - they converted to vbadvanced. (and screwed it up good!)

Grudge

digit,

Is it only PayPal you are using? I cannot see how this would happen :'(

Could you edit ipn.php and where it says:

else
generateError($txt['paid_unknown_transaction_type']);


Change to:

else
{
generateError($txt['paid_unknown_transaction_type'] . "\n\n" . print_r($_POST, true));
}


And PM/email me the error messages?

Sorry - I didn't get around to updating the mod this weekend - got distracted by SMF "Development Edition" goodies ;)
I'm only a half geek really...

digit

Quote from: Grudge on August 28, 2006, 05:42:28 PM
digit,

Is it only PayPal you are using? I cannot see how this would happen :'(

Could you edit ipn.php and where it says:

else
generateError($txt['paid_unknown_transaction_type']);


Change to:

else
{
generateError($txt['paid_unknown_transaction_type'] . "\n\n" . print_r($_POST, true));
}


And PM/email me the error messages?

Sorry - I didn't get around to updating the mod this weekend - got distracted by SMF "Development Edition" goodies ;)

Yes, I'm only using PayPal, and I just replaced that text - now I need to wait for the next paid sub - should be within 12 hours or so - thanks!

('looking forward to the goodies! ;))
Happily using a heavily modified 1.1.16 version of SMF!

2748011 Posts in 320998 Topics by 50986 Members


SOLD my website - thanks it was a good run - they converted to vbadvanced. (and screwed it up good!)

desistyle

Quote from: NukeWorker.com on August 25, 2006, 07:54:18 AM
Many questions have been answered on this original post about the paid subscriptions mod:

http://www.simplemachines.org/community/index.php?topic=13737.0


OK i did it and i think it does work but the thing is no one sees that board and it dont say anywhere that subscribe to see that board or anything like that

silverwing


I set up smf 1.1rc3 and installed Paid Subscriptions 0.9.  No other mods are installed, no hacks to files or themes.

When I click on my profile, I get this error:
Fatal error: Cannot redeclare subscriptions() (previously declared in /path/to/public_html/community/Sources/Profile.php:2912) in /path/to/public_html/community/Sources/Profile.php on line 3084

I haven't looked at that line, but is this going to be an easy fix?  Should I reinstall something?  (It worked fine on my localhost machine at home; i'm not sure how differently it's configured compared to my webhost that I get the error on.)

~silverwing
hxxp:misguidedthoughts.com [nonactive]

JayBachatero

It seems like that section got installed twice.  Open Profile.php and delete the duplicate subscriptions function.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

silverwing

thanks.  (I'm not usually that dense, but smf is new to me.)

I deleted line 3084 to the end of the page and things seem to work fine.

~silverwing
hxxp:misguidedthoughts.com [nonactive]

JayBachatero

Ummm Make sure that you didn't delete any other function.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

desistyle

hi am trying to add a subscriber manually and its not adding it it says member not found do u know why its doing that ?

NukeWorker.com

Quote from: desistyle on August 30, 2006, 08:07:31 AM
hi am trying to add a subscriber manually and its not adding it it says member not found do u know why its doing that ?
Because you are using the wrong username.

You might be entering in the display name, or have an extra space at the end.

sesle

September 03, 2006, 04:51:36 AM #57 Last Edit: September 03, 2006, 05:01:17 AM by sesle
Can someone tell me an easy way to add more flexible prices.
Primarily I want people to be able to select:
3 Months, 6 Months, 12 Months or 24 Months

Either that or people can select the number of flexible months
they want to buy in an extra selection box.
I tried looking through the code myself but it's quite confusing.

I want to do this as alot of people dont like reoccuring payments.
I cant use fixed payments because if someone changes to an
increased topup period the subscriptions will overlap.


philster

Quote from: Gargoyle on August 19, 2006, 09:30:18 PM
O'kay I know I posted this once already but I thought it would make more sense to post it in here so everyone can benefit from it.. ;D

First I would like to thank Grudge for making a kick ass MOD like this!! Very cool!!

Second I used an exsisting membergroup for the paid subscription MOD. What I would like to do is set an expiration date on all of my users that currently have that membergroup assigned. How would I go about doing that ??

I see it has been done here with the Charter Members. I just need to know how ;D

Thanks agian!!

You later said you'd discovered how to do this - may I ask how?
This would save us several days of work moving our club membership subscriptions online.

Gargoyle

I ended up doing it all manually through the admin panel. I only had 19 people to move so it wasn't a difficult task.

Advertisement: