• Welcome to Simple Machines Community Forum. Please login or sign up.
November 30, 2021, 05:56:49 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Höchst seltsamer Problem...

Started by Medizinmann99, August 30, 2006, 02:49:09 PM

Previous topic - Next topic

xduugu

In diesem Fall würd ich mich nach nehm anderen Hoster umschauen ^^

Medizinmann99

Hm hast Du es selbst versucht? Erst möchte ich wissen ob das bei Dir genauso passiert, weil wenn es Dir auch passiert haben wir auch das ausgeschlossen daß es irgendwie aus irgendwelchen Gründen an meinem eigenen Computersystem liegt. Dann bleibt wohl wirklich nur noch Ohost.de übrig.

xduugu

Ja. Bei mir geht es auch nicht. d.h. du müsstest prescription immer abwandeln wenn du es schreibt.

pre-scription

Medizinmann99

Würde mich echt interessieren was das auslöst. Aber da der Fehler offensichtlich SMF extern liegt bleiben hier wohl nur wildeste Spekulationen (die wahrscheinlich in den meisten Fällen mindestens ebenso absurd sind wie der Fehler selbst).

Weißt Du irgendeinen guten Gratishoster abseits von Funpic und Ohost.de? Das wird wieder dauern da was einigermaßen erträgliches zu finden...zzz. :-)

Jorin

Quote from: xduugu on August 31, 2006, 07:35:26 AM
Ja. Bei mir geht es auch nicht.

Dito. War so frei, es auch mal zu testen in den beiden Foren. Gleiches, echt sehr merkwürdiges Verhalten. Denke aber auch, es kann eigentlich nur serverseitig ein Problem sein.

Medizinmann99

Hallo,

ich plane mein Forum jetzt bei www.pytal.de zu hosten.

Ich hab gerade dort alles angelegt usw. und mal testhalber ein SMF Forum 1.1. RC3 installiert.

Es ist hier:
http://meulengracht.pytalhost.com/index.php

Es kommt aber wie ihr oben sehen könnt die Fehlermeldung:
---------------
Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/srv/www/httpd/phost/m/com/pytalhost/meulengracht/web) is not within the allowed path(s): (/srv/www/httpd/phost/m/com/pytalhost/meulengracht/web/:/srv/www/httpd/phost/m/com/pytalhost/meulengracht/tmp/:/srv/www/httpd/phost/m/com/pytalhost/meulengracht/ses/) in /srv/www/httpd/phost/m/com/pytalhost/meulengracht/web/Settings.php on line 57
------------

Vermutlich pytal-seitig irgendeine Zugriffsbeschränkung auf irgendein Verzeichnis, soweit ich das mit meinen laienhaften Kenntnissen beurteilen kann.

Was ist das und was kann ich dagegen machen?

Liebe Grüße

Medizinmann99

Medizinmann99

Hm ok also diese o.a. Fehlermeldung kommt ständig beim Einloggen beim Posten etc. (obwohl er im Hintergrund des Entsprechende macht)....immerhin geht das hier:
http://meulengracht.pytalhost.com/index.php?topic=2.0

LOL :-D

Aber ich schätze bis ich herausgefunden habe warum dieser Fehler kommt und was man dagegen machen kann nützt es mir auch nichts daß ich das "magische Wort" jetzt ins Forum tippen kann hihi :-)

xduugu

Führ mal die repair_settings.php aus dem Downloadbereich (Tools) aus.

Medizinmann99

Das habe ich gerade versucht, hab alles auf recommended values gesetzt und alles durchgeklickt, dann speichern. Hat sich nichts geändert, daran liegt es also leider nicht.

xenovanis

"Insanity: doing the same thing over and over again and expecting different results."

Medizinmann99

Hello xenovanis,

I do not know what you are talking about. I did not install any mods the forum there is a clean basic installation of SMF 1.1. RC 3. I can only guess what causes this error message. I suppose the free hoster there restricts something which is needed to run the forum properly.

Christian Land

Das Problem der abgeschnittenen Postings könnte ein Problem mit der Einstellung "post-max-size" in der PHP.INI sein. Leg mal eine Datei an mit folgendem Inhalt:

<?php

echo 
'max. Grösse für POST-Daten: '.ini_get('post_max_size');

?>


die überträgst Du auf Deinen Webspace (z.B. als "test.php" oder was auch immer) und führst sie mal aus. Zu dem anderen Fehler (open_basedir restriction) findest Du mehr, wenn Du mal nach open_basedir hier im Forum suchst.

Medizinmann99

Stop! Ich hab das Problem gelöst :-)

Problem solved :-)

I had to modify the  following lines in server settings:
/srv/www/httpd/phost/m/com/pytalhost/meulengracht/web
/srv/www/httpd/phost/m/com/pytalhost/meulengracht/web/Sources

and replace them with:
/srv/www/httpd/phost/m/com/pytalhost/meulengracht/web/
/srv/www/httpd/phost/m/com/pytalhost/meulengracht/web/Sources/

So all I had to add was a / sign at the end of each of them.

Strange, huh? I found this solution in the www.pytal.de help board.

Danke alle für Eure Mühe!!!!!!!!!!!

Thanks all, ich werde weiter berichten wies mir ergeht mit diesem Board,

tschüss,

Medizinmann99

xduugu

mod_security ist ein Modul für den Webserver und das lief scheinbar auf ohost.de.

Medizinmann99

Aha, ok, jetzt versteh ich. Auf alle Fälle geht das magische Prescription dort immer noch nicht...

xenovanis

Quote from: Medizinmann99 on September 01, 2006, 06:53:01 AM
Aha, ok, jetzt versteh ich. Auf alle Fälle geht das magische Prescription dort immer noch nicht...

Auch nicht mit der mod_security fix?

Versuche mal diese Code zum .htaccess ein zu fügen:

<IfModule mod_security.c>
# Turn off mod_security filtering.  SMF is a big boy, it doesn't need its hands held.
SecFilterEngine Off

# The below probably isn't needed, but better safe than sorry.
SecFilterScanPOST Off
</IfModule>
"Insanity: doing the same thing over and over again and expecting different results."

Medizinmann99

Gut ich versuche das jetzt. Ich hoffe es gibt nur eine .htaccess und nicht hundert...mal guggn.

Medizinmann99

Auf die Schnelle finde ich nur eine .htaccess und zwar im Unterordner Attachments.

Das habe ich jetzt dort hinzugefügt. Die sieht jetzt insgesamt so aus:

<Files *>
   Order Deny,Allow
   Deny from all
   Allow from localhost
</Files>
<IfModule mod_security.c>
   # Turn off mod_security filtering.  SMF is a big boy, it doesn't need its hands held.
   SecFilterEngine Off

   # The below probably isn't needed, but better safe than sorry.
   SecFilterScanPOST Off
</IfModule>

Das ist ihm völlig wurscht, prescription geht immer noch nicht.

Medizinmann99

Auf der anderen Front bei Pytal.de habe ich im Moment folgendes Problem.

Importiere ich die Datenbank die das SMF Forum erstellt hat sagt mir MySQL:
---------
Fehler

SQL-Befehl:

CREATE TABLE `smf_log_online` (
SESSION varchar( 32 ) NOT NULL default '',
logTime timestamp default 'CURRENT_TIMESTAMP',
ID_MEMBER mediumint( 8 ) unsigned NOT NULL default 0,
ip int( 10 ) unsigned NOT NULL default 0,
url text NOT NULL default '',
PRIMARY KEY ( SESSION ) ,
KEY online( logTime, ID_MEMBER ) ,
KEY ID_MEMBER( ID_MEMBER )
) TYPE = MYISAM ;

MySQL meldet: Dokumentation
#1067 - Invalid default value for 'logTime'
---------

Da ich eher der Typ bin der Fehlern aus dem Weg geht anstatt mich monatelang mit SQL zu beschäftigen habe ich nun den logischsten Weg genommen und die Mysql Datenbank mittels dem PHPADMIN Tool von ohost.de exportiert da PHPADMIN mit PHPADMIN kompatibler sein sollte als mit dem SMF Forenbackupscript.

DAnn bin ich bei pytal.de wieder auf Import gegangen und jetzt kommt folgendes:
---------
--------
Fehler

SQL-Befehl:

-- phpMyAdmin SQL Dump
-- version 2.6.4-pl4
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Erstellungszeit: 01. September 2006 um 13:25
-- Server Version: 4.1.22
-- PHP-Version: 4.4.4
--
-- Datenbank: `meulengracht`
--
CREATE DATABASE `meulengracht` DEFAULT CHARACTER SET latin1 COLLATE latin1_german2_ci;

MySQL meldet: Dokumentation
#1044 - Access denied for user 'phost38822'@'%' to database 'meulengracht'
---------

Was auch logisch ist weil es existiert schon eine Datenbank phost38822. Wie kann ich das so machen daß es funktioniert?

Medizinmann99

Habe den Inhalt von phost38822 jetzt gelöscht, keine Änderung, nach wie vor dieselbe Fehlermeldung.

Nunmehr habe ich der Logik folgend diesen Part der zu importierenden Datenbank von so:

-- phpMyAdmin SQL Dump
-- version 2.6.4-pl4
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Erstellungszeit: 01. September 2006 um 13:57
-- Server Version: 4.1.22
-- PHP-Version: 4.4.4
--
-- Datenbank: `meulengracht`
--
CREATE DATABASE `meulengracht` DEFAULT CHARACTER SET latin1 COLLATE latin1_german2_ci;
USE meulengracht;

auf dies hier:

-- phpMyAdmin SQL Dump
-- version 2.6.4-pl4
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Erstellungszeit: 01. September 2006 um 13:54
-- Server Version: 4.1.22
-- PHP-Version: 4.4.4
--
-- Datenbank: `phost38822`
--
DEFAULT CHARACTER SET latin1 COLLATE latin1_german2_ci;
USE phost38822;

abgeändert. Also jetzt ohne eine Ahnung von dem SQL Scheiß zu haben, einfach so.

Jetzt sagt er mir das ZIP File das ich zum importieren verwende und in dem diese modifizierte DAtenbank steht sei verschlüsselt.

Tja - der übliche Schwachsinn. Nicht daß ich nicht damit gerechnet hätte. Ich zähl schon wieder die Stunden, wieviele Stunden ich heute wohl noch sitzen werde?

Advertisement: