News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

Advanced Visual Verification

Started by Harzem, September 18, 2006, 08:46:15 AM

Previous topic - Next topic

URPG

Why would you need this, if you installed 1.1.2? It's a standard feature...

Kindred

this one is more advanced than the one that is standard in 1.1.2
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

URPG

ah, ok. Guess the standard is fine, never had complaining users or bot's that came in...

cmonex

Quote from: URPG on June 02, 2007, 10:33:11 AM
Why would you need this, if you installed 1.1.2? It's a standard feature...

well because i was appalled to find i could not enable captcha's for guest posting out of the box. i want to enable guest posting, but if i dont have some verification system in place for them, then i would be flooded with spam.
i did install some other mod that prevents guests from posting links and it works but i feel this AVV mod would be more efficient.

can someone help, pretty please. thanks.

青山 素子

This mod isn't compatible with SMF 1.1.2 due to changes made in how the built-in captcha works.

I hate advertising on these topics, but you could look at Visual Verification Options if you want something compatible with SMF 1.1.2.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


URPG

Ah... i do allow guest posting without it. I just installed a mod preventing guests from posting links, never had a single spam post since then  8)

cmonex

Quote from: URPG on June 03, 2007, 06:15:13 AM
Ah... i do allow guest posting without it. I just installed a mod preventing guests from posting links, never had a single spam post since then  8)

thanks, i do have it installed, just wasn't sure if that was safe enough. you seem to confirm it is. can you tell me how you fixed the error report issue with it though? for me (when i tested it as a guest) it only said "error occurred: " but didn't say the reason (i.e. it won't let you post because of the link). or maybe it is intentional? thanks.

cmonex

#507
Quote from: Motoko-chan on June 03, 2007, 01:26:20 AM
This mod isn't compatible with SMF 1.1.2 due to changes made in how the built-in captcha works.

I hate advertising on these topics, but you could look at Visual Verification Options if you want something compatible with SMF 1.1.2.

no worries about advertising :)

i know the original mod is not compatible, but two hacks are available that make it compatible, it does work for others, sadly not for me, :(

edit: i checked out your mod. it looks nice, does it enable captcha for guest posting? i see it does it for opening a new thread, but does it, when someone just posts in an existing thread? thanks lots.

青山 素子

Personally, I'm not really into un-reviewed hacks to make things work, especially when something affects such a critical part of the system.

As to your question, you should really ask that in the topic for that mod, but yes, turning it on means any post by a guest will require a verification.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


cmonex

Quote from: Motoko-chan on June 03, 2007, 04:09:29 PM
Personally, I'm not really into un-reviewed hacks to make things work, especially when something affects such a critical part of the system.

As to your question, you should really ask that in the topic for that mod, but yes, turning it on means any post by a guest will require a verification.

cool, the description didnt sound like that, but now going to check it out :) thanks

URPG

No, actualy it's not intentional i guess... but no i did not solve anything *g* let it send the bot's into the void :)

mstahl

I keep getting this error trying to install the mod on 1.1RC3:

This mod doesn't seem to support your SMF version.

How do I get around this. I would upgrade to 1.1.2 but I need to stop some spamming now and upgrading involves a ton of work since I am using a joomla bridge.

Thanks!

Kindred

If you are using the joomla bridge form this site (v1.1.6 or 1.1.7) then upgrading SMF is no hassle, since the bridge does not affect any SMF files at all.
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

mstahl

Unfortunately I am not. I wish I could but i have a problem with SEF advance and it working with SMF. Our site has over 3500 articles that are indexed and it pains me to think of losing that by changing sef components. We might have to though. We are using Joomlahacks.

mstahl


青山 素子

#515
Quote from: mstahl on June 22, 2007, 02:09:24 PM
I don't see a joomla bridge in http://www.simplemachines.org/download/?bridges am I missing it?

It has been removed due to the recent action on the Joomla! team's part concerning the license of their software. They have basically stated that non-GPL modules are in violation of their license. We are working to see how best to resolve the situation, if we can.

This will be an interesting development to watch, as several core developers have quit because of the license change.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


mstahl

Shocker! :) That is another issue we are dealing with. So back to the main question...any idea why the captcha isn't installing on 1.1RC3?

Fiery

Quote from: mstahl on June 22, 2007, 02:18:49 PM
Shocker! :) That is another issue we are dealing with. So back to the main question...any idea why the captcha isn't installing on 1.1RC3?

Because it is only compatible with 1.1 not 1.1rc3

You could uncompress the file, modify package-info.xml to allow for installation and uninstallation of 1.1rc3 not just 1.1 then recompress it and try to install... but you are doing this at your own risk.  Make sure to backup

imako

Anyone tried it with 1.1.3? I have it fully working in 1.1.2 but is there some changes that screws this up? This is great mod to allow guest posting in my forum, otherwise i get tons of spam in my forum.

jnix

#519
(v 1.1.3)

I've just uninstalled this mod via package manager, but I still have the "Visual Verification" tab under Admin>Registration. Clicking on it gives me the "Unable to load the 'verification_settings' template" error. Any idea how I can remove this (I want to completely uninstall).

And, perhaps related to the above, on the Admin>Registration>Settings screen the dropdown re image complexity has no effect, even when I save changes (see attached image).

(I also had the Visual Verification Options mod installed, but now uninstalled, so apologies if its because of that and not this mod...)

And, finally, my registration page shows the image 5 times (see 2nd attachment)


Advertisement: