News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

YouTube BBC Tag

Started by Defiant, October 07, 2006, 10:30:15 AM

Previous topic - Next topic

Defiant

Alan S posted to say he had converted this mod to work with 1.1 RC3 but the link is dead

http://mods.simplemachines.org/index.php?mod=390

Can one of the mods please tell us if this has been converted because the thread hasn't been replied too

JayBachatero

The mod is still waiting for approval.  I'll look into it later.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Defiant


vbgamer45

The mod has already been approved.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Defiant

#4
Quote from: vbgamer45 on October 09, 2006, 08:36:07 AM
The mod has already been approved.

thanks vbgamer45 :)

EDIT: Where is it, I checked the site and couldn't see an addition and his link is dead http://mods.simplemachines.org/index.php?mod=457

Gary

This is just a quick thing, and I can make any garantees since I havent tested it. But it's bascially the same thing as Yakuza's mod, I just made it so that RC3 will pick up on it.

-AwwLilMaggie
Gary M. Gadsdon
Do NOT PM me unless I say so
War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

Defiant

Quote from: AwwLilMaggie on October 09, 2006, 09:03:04 AM
This is just a quick thing, and I can make any garantees since I havent tested it. But it's bascially the same thing as Yakuza's mod, I just made it so that RC3 will pick up on it.

-AwwLilMaggie

Thanks AwwLilMaggie

I tried but left it at this stage

QuoteApply Mod
Please remember to always make regular backups of your sources and database before installing mods, especially beta versions. 


!!Error in Package Installation

At least one error was encountered during a test installation of this package. It is strongly recommended that you do not continue with installation unless you know what you are doing, and have made a backup very recently. This error may be caused by a conflict between the package you're trying to install and another package you have already installed, an error in the package, a package which requires another package that you don't have installed yet, or a package designed for another version of SMF.
Installation Readme
This mod adds bbcode for YouTube Videos.


Install Actions
Installations actions for "YouTube BBCode by Yakuza":
Installing this package will perform the following actions:  Type Action Description
1. Execute Modification ./Sources/Subs.php Test failed
2. Execute Modification ./Themes/default/Post.template.php Test successful
3. Execute Modification ./Themes/default/languages/Modifications.english.php Test successful
4. Execute Modification ./Themes/default/languages/Modifications.italian.php Test successful
5. Extract File Themes/default/images/bbc/youtube.gif


I take it I was right to cancel the install ?

Gary

I thought that might happen. Happened to me.

Anyway, finish as normal, then in Subs.php find:


array(
'tag' => 'hr',
'type' => 'closed',
'content' => '<hr style="clear: both;" />',
'block_level' => true,
),


and add after:


array(
'tag' => 'youtube',
'type' => 'unparsed_commas_content',
'test' => '\d+,\d+\]',
'content' => '<object width="$2" height="$3"><param name="movie" value="http://www.youtube.com/v/$1" ></param><embed src="http://www.youtube.com/v/$1" type="application/x-shockwave-flash" width="$2" height="$3"></embed></object>',
'validate' => create_function('&$tag, &$data, $disabled', '
if (isset($disabled[\'url\']))
$tag[\'content\'] = \'$1\';'),
'disabled_content' => '<a href="$1" target="_blank">$1</a>',
),


then upload, and you're all set.

-AwwLilMaggie
Gary M. Gadsdon
Do NOT PM me unless I say so
War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

Defiant

Quote from: AwwLilMaggie on October 09, 2006, 10:16:00 AM
I thought that might happen. Happened to me.

Anyway, finish as normal, then in Subs.php find:


array(
'tag' => 'hr',
'type' => 'closed',
'content' => '<hr style="clear: both;" />',
'block_level' => true,
),

Can't find that in the file are you sure its RC3 ?

Gary

Well, technically, you can just put in after any of the arrays. You could put it after bold for example if you wanted to.

-AwwLilMaggie
Gary M. Gadsdon
Do NOT PM me unless I say so
War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

Defiant

Thanks for the help AwwLilMaggie much appreciated :)

Dem0n

For some reason, it doesn't play the video, it just shows a white image, in the form of the video layout.. but there is nothing, and if you right click you get the "about flash player 9" stuff.

I have the latest version of flash installed. Any ideas on how to fix this?

scheols



Want a Custom profile sig like this?(no SMF board has it join now)



Witte

#15
I've adjusted the mod to work with smf 1.1 final, you can download it here, instructions are on the page itself. ;D

[edit] fixed

scheols

Ill reupload soon. Thanks for telling me.


Want a Custom profile sig like this?(no SMF board has it join now)

h4ni

Quote from: Witte on December 05, 2006, 03:01:17 PM
I've adjusted the mod to work with smf 1.1 final, you can download it here, instructions are on the page itself. ;D
link dead  :(

TiBe

Quote from: Witte on December 05, 2006, 03:01:17 PM
I've adjusted the mod to work with smf 1.1 final..

Does it work on smf 1.1.1?? because i tried to install it but the next error appears:

QuoteInstall Actions
Installations actions for "YouTube BBCode by Shezz":
The package you are trying to download or install is either corrupt or not compatible with this version of SMF. 

Am i doing something wrong??

Advertisement: