News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

cbi v0.5 (Custom Board Icons)

Started by Bigguy, November 11, 2006, 11:59:46 AM

Previous topic - Next topic

Bigguy

I think you would have to change the code in SMF in order for .png's to be used and then change it in the mod.

allumius

#181
I have this problem
If a boards have not childboards inside, the icon work fine but if the boards have some childboards inside, the icon of board not work
Look this images please

In the first image you can see the board "cafeteria" and "Prensa" no problem And "deportes" icon not work



This second image is the child board of "Deportes" board


Bigguy

Did you press ctrl +f5 after you installed the mod. Try that and see what happens.

backend

Bigguy, thanks for this great mod. I have already installed it, although I haven't done the modifications. Just couple of questions please:

1-I will have to upload the new board-specific icons to Themes/default/icons/ right?
2-Once I have done the above, where do I go to configure each board to take on the new icon?
3-Don't we have two have two image states? one for On and one for OFF? how do we set that?

Thanks a lot,

Bigguy

Once you have it installed all that is needed (if you are using the default theme) is to create a different folder for each board; within that folder you would put your on.gif; off.gif.So your path would look like this:

/Themes/default/icons/1/off.gif

1 being the board id for the board you want to show those particular images for. In order to find the board id you can hover your mouse over the on.gif and down in the bottom left corner of the browser it will show a path:

action=unread;board=1.0

1.0 would be the board id. Hope that clears it up :)

backend

WOW that is pretty easy, thanks a lot man.

Can't wait to go home and apply it.


Bigguy

One little tip....If the icons don't seem to be showing after you do this...use ctrl + f5 and refresh the page right from the server. They should show then. ;) Have fun. :)

backend

It is working great BigGuy, thank you very much.

The onyl problem I am having, is with the graphics itself. I need to make sure the icons don't have a white background. Not sure how to do this.... Should I make the icon's background transparent?

Thanks a lot

backend

and where can we find free icons to use for our website?

Bigguy

I search google for "free .png icons"

http://www.google.ca/search?hl=en&q=free+.png+icons&btnG=Google+Search&meta=

and then change them to fit my needs and turn them to .gifs and use them. That's what I do anyway.

Garry1953

I like this mod, and will be using it on my forum.

Bigguy
Thanks for sharing it.


Bigguy


allumius

Quote from: Bigguy on January 23, 2008, 12:16:25 PM
Did you press ctrl +f5 after you installed the mod. Try that and see what happens.
Nothing  :'(

Bigguy

Do you have all the folders made and in the right places. ???

allumius

Quote from: Bigguy on January 24, 2008, 10:29:10 AM
Do you have all the folders made and in the right places. ???
Yes
The problem is if ALL post of "Deportes"'childboards are read, The icon called off.gif work fine in "Deportes" board, but if there are some post non read in childboards, the icon on.gof of "deportes" board not work

lvzifer

this mode is not working on my board .. even on default skin .. I am using default modern .. is there some modification in admin panel after instalation or ?? What I do wrong ..

et10yl

Hi, I've installed the mod successfully and created the correct folders across the 5 different themes I'm using. The custom icons are showing correctly in default, girlyman, but not in babylon, Ig-Oh, or classic yabb. I've tried in the themes that can't display the icons properly to change the paths. For example:

Themes/igoh114/images/icons/8
Themes/igoh114/images/icons/icons/8
Themes/igoh114/icons/8

But none of these configurations seem to be working. I'm wondering if there is something going on that is theme specific that allows the custom board icons to work on some custom themes and not on others?

Bigguy

If you have manually added the code to the required template files in each theme then there is no reason why it shouldn't work.

ValeriusCdlP

What changes are needed for running this mod v1.0 on smf 1.1.4 with dilbermc theme?

Bigguy

All the edits for the mod and where to put them should be in this thread somewhere. There are only 2 to do.

Advertisement: