News:

Wondering if this will always be free?  See why free is better.

Main Menu

cbi v0.5 (Custom Board Icons)

Started by Bigguy, November 11, 2006, 11:59:46 AM

Previous topic - Next topic

Bigguy

#260
Here it is. cbi has to be installed to use this but all it does is change the .gif extension to .png so you can use .png icons instead.

For the redirect boards if you have any this will add an image above the  one already there. I will incorporate these two mods and clean up the code when SMF 2.0 gets a little further down the road.

To uninstall...make sure the add-on is uninstalled first then you may uninstall the cbi mod.

HappyChinchilla

Hi,

I have a question about the "Custom Board Icons" mod. I am using it for my 1.1.5 forum.  Everything is working great, but I notice that the New Posts/No New Posts icon and text are still at the bottom before the Info Center. Is there a way to remove them?

Thanks in advance.

Bigguy


HappyChinchilla

Hi Bigguy,

Thanks for your quick response. I have attached a screenshot for you.


Bigguy

You could just change the icons on them to reflect your new icons. I used to have icons for there that I custom made. Each one was a collage of two or three icons for the new post /no new post icons you are referring to. I grey scaled one and viola...I had new icons. (Hope that made sense.)

HappyChinchilla

Bigguy, is there a way to remove the New Posts/No New Posts icon and text in the coding? Since each board has a different icon with this mod, it is kind of confusing to have those two New Posts/No New Posts icons at the bottom.

Thanks.

kai920

Quote from: HappyChinchilla on June 13, 2008, 12:28:15 AM
I am using it for my 1.1.5 forum.  Everything is working great, but I notice that the New Posts/No New Posts icon and text are still at the bottom before the Info Center. Is there a way to remove them?

Hi, did you do a manual installation?

HappyChinchilla

Hi kai920,

I did not install it manually. Are the icons going to disappear if I install the mod manually?

Thanks.

kai920

Well, I'm only asking because I got an error when trying to install thru package manager. I see a few other people using 1.1.5 have the same small issues with searching for code that does not match exactly the xml...

Bigguy

Hopefully I can get around to updating this later tonight. If not it will have to wait til Tuesday. Sorry for the delay folks. :)

kai920

Thanks bugguy, it'd be very much appreciated :)

fangweile

Hello there,

I have manually installed this mod in my dilber mc theme and it really display just fine.

However, when I visit my error log, there are lots of errors on it

Here is the error:

Quote8: Undefined index: is_redirect
File: /home/vol2/4sql.net/sq_697468/allkoreans.net/htdocs/Themes/default/BoardIndex.template.php (main sub template - eval?)
Line: 145

Should i delete the is_redirect line code in my boardindextemplate.  ??? ???

Thank in advance

HappyChinchilla


Bigguy

I have packaged a new version of cbi. This version is for 1.1.5 and will probably work on earlier versions as well. It replaces the .gif extensions with .png automatically so you don't have to do it.

cbi-1.0a

This version will not work on SMF 2.0

Bigguy

cbi version 1.5 for SMF 2.0 has now been updated to work with 2.0 Beta 3.1 Public and no addon is needed now. it will automatically change the .gif extensions to .png.

keyboard

bigguy !!!!

Many,many, many thanks for the upgrade to 1.1.5..... I will name my next child after you.......Works like charm...what a great mod  :D :D :D

kai920


Bigguy

Glad you guys are happy and like it. :)   A baby named bigguy might not be the best idea though keyboard; lmao. ;)

Davey D.

#278
Some help please. I am using the legacy Rocketheme SMFversatility2 theme and I tried several times replacing code without success (obviously).

This is my BoardIndex.template.php right around where I believe the code should go:

// If the board is new, show a strong indicator.
if ($board['new'])
echo '<img src="', $settings['images_url'], '/on.gif" alt="', $txt[333], '" title="', $txt[333], '" />';
// This board doesn't have new posts, but its children do.
elseif ($board['children_new'])
echo '<img src="', $settings['images_url'], '/on2.gif" alt="', $txt[333], '" title="', $txt[333], '" />';
// No new posts at all! The agony!!
else
echo '<img src="', $settings['images_url'], '/off.gif" alt="', $txt[334], '" title="', $txt[334], '" />';

echo '</a>
</td>
<td class="windowbg2">
<b><a href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b><br />
', $board['description'];


Here is my MessageIndex.template.php right around where I think the code should go:

// If the board is new, show a strong indicator.
if ($board['new'])
echo '<img src="', $settings['images_url'], '/on.gif" alt="', $txt[333], '" title="', $txt[333], '" />';
// This board doesn't have new posts, but its children do.
elseif ($board['children_new'])
echo '<img src="', $settings['images_url'], '/on2.gif" alt="', $txt[333], '" title="', $txt[333], '" />';
// No new posts at all! The agony!!
else
echo '<img src="', $settings['images_url'], '/off.gif" alt="', $txt[334], '" title="', $txt[334], '" />';

echo '</a>
</td>
<td class="windowbg2">
<b><a href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b><br />
', $board['description'];


I created this folder structure (testing on a local server):

c:\xampp\htdocs\smf\Themes\SMFversatility2\icons\1\

Inside I have 3 icons, "off.png" "on.png" and "on2.png"

I am assuming the 'board number' is the actual placement number, or order, the boards are in and not some code like Joomla uses for content ID. If so I could not find what each board's content ID is so I hope I was correct.

Forgot to indicate using SMF v1.1.5.

kai920

#279
Sorry just a quick question, what is on2 for? 

Nevermind, found out from here:

on.gif = new posts in parent board
on2.gif = new posts only in child board
off.gif = no new posts

Advertisement: