• Welcome to Simple Machines Community Forum. Please login or sign up.

Webinstall - A new way to get SMF!

Started by Thantos, November 29, 2006, 07:45:07 AM

Previous topic - Next topic

SleePy

Quote from: Thantos on December 02, 2006, 11:48:42 AM
Hmmm thought I had fixed that one.  Ok the link is fixed now.
In the web installer or the link itself? the link itself don't work.. Haven't tried the web installer yet..

--Edit--
Tried web installer
The topic or board you are looking for appears to be either missing or off limits to you.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

Gobo

December 02, 2006, 12:00:34 PM #21 Last Edit: December 02, 2006, 12:04:26 PM by akulion
im using dreamhost

initial running of the webinstall seemed to be fine however when it finished it took me to the folder I had specified

and all it contained were the Themes folder and inside were the themes babylon clasic and default and thats all

I ran it again - same results

any idea why?

PS: folder permissions were at 777 and everything is set as stated in 1st post - all details double checked but it only extracts the themes folder (i tried a 3rd time)

Thantos

Sleepy you'll need to grab a new copy of webinstall to see the fix.

akulion:  the files that were created, were they valid files or not?

SleePy

Quote from: Thantos on December 02, 2006, 12:05:19 PM
Sleepy you'll need to grab a new copy of webinstall to see the fix.

akulion:  the files that were created, were they valid files or not?

Thantos,
I just did and it still gives the old link..

webinstaller.php - File Info
Size: 68 KB
Created: Saturday, December 2, 2006 9:06 am
Modified: Saturday, December 2, 2006 9:06 am

gave you its file info so you know I downloaded it..
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

Thantos

Hmmm looks like FTP didn't upload it then.  Ok I reuploaded it and made sure it was showing the correct info

Bill Dodds

I received an odd error messsage as the forum was upgrading:

Upgrading...
Updating ban system... Unsuccessful!

This query:
SELECT mem.ID [nofollow]_MEMBER, mem.is [nofollow]_activated + 10 AS new_value
FROM (smf_ban_groups AS bg, smf_ban_items AS bi, smf_members AS mem)
WHERE bg.ID [nofollow]_BAN_GROUP = bi.ID [nofollow]_BAN_GROUP
AND bg.cannot_access = 1
AND (bg.expire_time IS NULL OR bg.expire_time > 1165079936)
AND (mem.ID_MEMBER = bi.ID [nofollow]_MEMBER OR mem.emailAddress LIKE bi.email_address)
AND mem.is [nofollow]_activated < 10;

Caused the error:
Table 'billsbur_smf1.smf_ban_groups' doesn't exist

I have not banned anyone that I can think of, is that causing this?

Thantos

Just as a note, the upgrading part isn't actually part of the webinstall.

From the error it looks like the table smf_ban_groups didn't get created.  Can you try running upgrade.php again and see if the table gets created.

Bill Dodds

Will do, and sorry I did not place this problem in the support forums instead of this release thread..  :-*

Gobo

Quote from: Thantos on December 02, 2006, 12:05:19 PM
Sleepy you'll need to grab a new copy of webinstall to see the fix.

akulion:  the files that were created, were they valid files or not?

the only folder that contained anything was the default folder - and that only contained images and nothing else - no php files or otherwise created except images in default theme folder

PS: i doing a full package install right now via FTP but ill keep an eye on the webinstaller

SleePy

And I know your busy  :D

But Just tried the webinstall.php again and just browsed the source instead of loading it onto my test site and it still shows the old link

http://docs.simplemachines.org/index.php?topic=896.0
SMF 1.1 Online Manual  /  Team Only  /
An Error Has Occurred!
The topic or board you are looking for appears to be either missing or off limits to you.

Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

Thantos

The file that you get from the download page is using the correct URL which goes to an available page.  Perhaps firefox is caching the file instead of downloading a new one.

SleePy

Ahh.. you were right.. I wasn't aware that Firefox cached downloads.. hmm.
Ok.. Guess my Inferior browser needs a bug report..  ;D Nothing should cache downloads..
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

copter


Adam S

Odd this is not working on Site 5 hosting, I have tried a plethora of different  CH Mod settings, when I go to the step where it downloads the files it brings me to a download page for the webinstall.php file.

djkimmel

I tried setting up Webinstall and can't get past the ftp connect step:
Unable to connect to FTP server with this combination of details.

All Access is LOGGED

I used ftp.greatlakesbass.com as my server with port 21.

I used the same username and password I always do when I ftp files to my web site. I tried the default setting in the mod 0664 and tried 755, but still don't get past this step.

The installed path was automatically detected as /forum which it is /www/forum.

Am I missing something obvious or do I have an external issue?Thanks.

Thantos

did it come back with any type of ftp error?

djkimmel

Just this:
"Unable to connect to FTP server with this combination of details.

All Access is LOGGED "

I can connect with my FTP client using the same settings.

MaximKat

tried to upgrade from 1.1rc3 to 1.1, but couldn't... :(
script said that it had downloaded files, extracted them and than just redirected me to the board list, version still 1.1rc3
no error messages or anything
Answers: $1, Short: $5, Correct: $25, dumb looks are still free.

Thantos

Quote from: djkimmel on December 02, 2006, 06:00:01 PM
Just this:
"Unable to connect to FTP server with this combination of details.

All Access is LOGGED "

I can connect with my FTP client using the same settings.

Webinstall expects a 200 response which means things are ok.  It appears that your server is giving another reponse prior to the 200 response.

djkimmel

That does not surprise me. I will have to look into it with Omnis.com later since I don't know enough about those kinds of things. Don't know if they could or would change it. I'll upgrade the 'old-fashioned' way. Thanks for the responses.

Don't know if this helps with anything - here's what I get when I use my FTP client:
Status:   Connecting to ftp.greatlakesbass.com ...
Status:   Connected with ftp.greatlakesbass.com. Waiting for welcome message...
Response:   220-      Omnis Network FTP Server
Response:              All Access is LOGGED
Response:    If you are not an Omnis Network Hosting Customer
Response:              DISCONNECT IMMEDIATELY
Response:   
Response:    If you are unsure what your FTP Username and/or
Response:    Password is, Please Login to the Account Management
Response:    Site at: https://manage.omnis.com and click on
Response:    Account Info under the Website Account Info heading
Response:   
Response:   220 ProFTPD 1.3.0 Server (Omnis Network Customer FTP Server) [216.239.138.7]
Command:   USER myusername
Response:   331 Password required for myusername.
Command:   PASS ********
Response:   230 User myusername logged in.
Command:   SYST
Response:   215 UNIX Type: L8
Command:   FEAT
Response:   211-Features:
Response:    MDTM
Response:    REST STREAM
Response:    SIZE
Response:   211 End
Status:   Connected
Status:   Retrieving directory listing...
Command:   PWD
Response:   257 "/" is current directory.
Command:   CWD /www/
Response:   250 CWD command successful
Command:   PWD
Response:   257 "/www" is current directory.
Command:   TYPE A
Response:   200 Type set to A
Command:   PASV
Response:   227 Entering Passive Mode (216,239,138,7,192,234).
Command:   LIST
Response:   150 Opening ASCII mode data connection for file list
Response:   226 Transfer complete.
Status:   Directory listing successful
Command:   PWD
Response:   257 "/www" is current directory.
Command:   TYPE A
Response:   200 Type set to A

Advertisement: