News:

SMF 2.1.4 has been released! Take it for a spin! Read more.

Main Menu

RISOLTO!!! => Problemi link PM e notifiche X-Mailer

Started by brutus, October 14, 2006, 01:06:43 PM

Previous topic - Next topic

brutus

Salve a tutti,

ho un piccolo problema nella sezione messaggi personali (PM) che mi sta facendo letteralmente impazzire!! Praticamente nella schermata di elenco dei messaggi, in basso a destra di ogni singolo messaggio ci sono i link per "Rimuovere il messaggio" o "Rispondere con citazione" che a me si vedono doppi e sfasati come in foto qui sotto:



Qualcuno sa come aiutarmi o perlomeno nel sorgente di quale file guardare? Sto spulciando tutto da giorni ma c'ho fatto capo! AIUTOOOOO!

In più ho un problema sia nella mail di verifica registrazione sia nella mail di notifica del mio forum: in pratica i link che mi posta l' X-Mailer di SMF sono sbagliati nei caratteri accentati e simboli.
Esempio di mail di notifica:

Quote
X-Mailer: SMF

Content-Type: text/plain; charset=ISO-8859-1

Content-Transfer-Encoding: quoted-printable
Message-Id: <[email protected]>

XXXXXX si =E8 iscritto come nuovo membro del tuo forum. Clicca sul Link in basso per visualizzare il suo profilo.



http://www.XXXXXXX.XX/forum/index.php=3Faction=3Dprofile;u=3D112



Saluti,

Lo Staff del Forum

Vi annuncio che ho correttamente installato i files di linguaggio in Italiano ISO-8859-1 per smf_1-1-rc3 scaricati da SMItaly, impostato il charset uguale nell' header del template e controllato il charset del MySQL; non capisco come mai il set di caratteri delle mail inviate dall' X-Mailer di SMF (che è anch'esso ISO-8859-1) sbagli la visualizzazione di quei caratteri.

:'( Grazie in anticipo

Darknico

so solo darti la soluzione al primo problema:
vedi doppio perche in uno di quelli ce un immagine ke nn trova e allora vedila scritta
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


brutus

Dopo svariati giorni di peregrinaggio in forum di tutte le lingue (italiano, inglese, tedesco e altre che nemmeno so cosa fossero!!!!) ho scoperto che SOLO nella versione 1.1 RC3 c'è un bug dell' X-MAILER durante l'invio delle email di moderazione (cioè registrazione e notifica PM e risposte) tramite il PHP(Mail) cioè l'invio col comando php della posta proveniente dal Forum (il metodo impostato di default): praticamente su alcune caselle di posta elettronica di alcuni provider (nel mio caso, e in moltissimi altri anche stranieri, GMAIL) il corpo del messaggio non visualizza correttamente i QUOTED TEXT (cioè caratteri speciali, simboli e lettere accentate) malgrado si tenti qualsiasi impostazione (anche corretta) del charset o cambiamento nei files sorgenti o elaborazione sulle tabelle del database SQL; il che comporta l'errata visualizzazione dei link alla board (PM, conferma registrazione ecc.)  nei messaggi email e il conseguente errato redirect al sito cliccandoci su. L'UNICA SOLUZIONE AL PROBLEMA per ora scoperta e funzionante CONSISTE NELL'IMPOSTARE IL METODO DI INVIO TRAMITE SMTP, cioè impostando un server di posta SMTP come delegato all'invio dei messaggi e delle email, e magicamente tutti i messaggi e i link in essi contenuti saranno visualizzati correttamente. Purtroppo non tutti hanno la possibilità di accedere ad un server di posta (perchè di proprietà) o di potersi appoggiare a quello di un conoscente (come ho fatto io appoggiandomi su quello dell'azienda in cui lavoro) quindi il problema rimane: penso sia di comune vantaggio (sia di noi utenti che dei programmatori e coders di SMF) rendere la piattaforma il + compatibile possibile e priva di bug onde avere un servizio sicuro, ben fatto e pienamente fruibile nonchè senza limitazioni per glòi utenti, obbiettivo primario di qualsiasi softaware OPENSOURCE. Invito quindi tutti a focalizzare la loro attenzione ANCHE su questo problema, secondo me non da poco.

Per quanto riguarda il problema delle scritte doppie nei link di moderazione dei messaggi privati nella board col template SMF ONE BLUE RC3, Darknico aveva pienamente ragione, mancavano le immagini della cartella /images/BUTTONS/ nella dir del template stesso: ho risolto copiando la cartella /buttons/ nella dir /images/ del template DEFAULT (che sono indicatissime in quanto molto piccole) nella dir /images/ del template SMF ONE BLUE RC3.

actros81

hxxp:www.saf1fansclub.it [nonactive]

   

Advertisement: