News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

SMF 1.1 Final

Started by Grudge, December 02, 2006, 10:04:44 AM

Previous topic - Next topic

acdouglas

Quote from: Thantos on December 02, 2006, 07:01:40 PM
@acdouglas can you do me a favor and look in your index.english.php file located in /Themes/default/languages and find
$forum_copyright =
and tell me what the full line is.
ie:
$forum_copyright = '<a href="http://www.simplemachines.org/" title="Simple Machines Forum" target="_blank">Powered by ' . $forum_version . '</a> |
<a href="http://www.simplemachines.org/about/copyright.php" title="Free Forum Software" target="_blank">SMF &copy; 2006, Simple Machines LLC</a>';


Also please make sure to test it with the default theme first.

I switched to the default theme on SMF 1.0.9 before the upgrade.

$forum_copyright in index.english.php reads:

$forum_copyright = '<a href="http://www.simplemachines.org/" title="Simple Machines Forum" target="_blank">Powered by ' . $forum_version . '</a> |
<a href="http://www.simplemachines.org/about/copyright.php" title="Free Forum Software" target="_blank">SMF &copy; 2006, Simple Machines LLC</a>';


Looks the same to me.

ACD

xtremecruiser

Quote from: Oldiesmann on December 02, 2006, 11:13:55 AM
While I am excited to see that 1.1 Final has been released, I am now dreading all the work I have ahead of me - between my own boards and all the boards I help out with, I've probably got close to a dozen boards to upgrade - some of which I never got around to upgrading when 1.1 RC3 was released...
I hear ya ;)
I have a test forum just waiting to be tested this weekend.

A big thanks goes out to everyone that helped with this project

Thantos

acdouglas: can you double check that your Subs.php file got updated correctly also.

Mikal D. Huber

Congratulations! I hope this addresses some of the posting glitches. I know this isn't the place to mention it, but has no one ever noticed that the mechanics for making a list create multiple LIST commands, which then have to be cleaned up? And the FLASH and IMAGE icons don't seem to work properly, neither does the  HYPERLINK, yet there is nothing about their use in the HELP. If they work at all, which is rare, all leave artifacts behind, which indicate they are improperly coded.  Minor quibbles, but I'm trying to create a monthly newsletter for my members, and would love to be able to include images and FLASH in it. Feel free to shift this message to a tech support forum, but please respond.

mikaldhuber@gmail.com

URPG

Yeha!

Now i just got to sit and wait for TP to be updated... and for the SEO guys to finally get working... and...

SleePy

Quote from: URPG on December 02, 2006, 08:06:24 PM
Yeha!

Now i just got to sit and wait for TP to be updated... and for the SEO guys to finally get working... and...

Tinyportal 0.9.6 will work on 1.1 Final.. Just need to play with it a little.. search around for emulating your version for installing mods.. I can't remember the exact url you need to use but its possible.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

MoreBloodWine

I am so happy this is finally out but I'm seriously considering not upgrading for the fact that while I am using 1.1 RC3 and a custom theme on three yes I said three forums... I just dont wana go in and have to reinstall 10+ mods on 3 forums which will take care of the default theme automatically on install but means I will have to hand code 3 forums for alot of mods on custom themes... one big one being the arcade mod that I use on all three forums... I'm sure others might be willing to "chip in" on this but I would seriously be willing to pay for this if a thing could be made for the package manager which means no mods would need to be removed / re-installed... I dont know about anyone else and what they could or couldnt donate for the task of making a package manager version for upgrading from 1.1 RC3 but if this task gets taken I will chip in the first $20.00...
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


SleePy

Quote from: MoreBloodWine on December 02, 2006, 08:15:58 PM
I am so happy this is finally out but I'm seriously considering not upgrading for the fact that while I am using 1.1 RC3 and a custom theme on three yes I said three forums... I just dont wana go in and have to reinstall 10+ mods on 3 forums which will take care of the default theme automatically on install but means I will have to hand code 3 forums for alot of mods on custom themes... one big one being the arcade mod that I use on all three forums... I'm sure others might be willing to "chip in" on this but I would seriously be willing to pay for this if a thing could be made for the package manager which means no mods would need to be removed / re-installed... I dont know about anyone else and what they could or couldnt donate for the task of making a package manager version for upgrading from 1.1 RC3 but if this task gets taken I will chip in the first $20.00...

You could just download both versions and do a file compare with a file comparison utility.. then make the changes on your site to be updated..
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

MoreBloodWine

#88
True but I'd be afraid to seriously screw something up which I'd most likely do wiht a task this large... but my donation still stands if any of the SMF guys wants to attempt what I mentioned in my last post...

Edit : Oh ya I'd definately fudge something up for sure...
Quote from: HarzeM on December 02, 2006, 08:19:12 PM
A file comparison between rc3 and final will give around a thousand of lines of difference.

Edit : Well my dream will probably go un-answered then but either way I seriously dont see me upgrading three forums then if my dream has no chance of coming true...
Quote from: HarzeM on December 02, 2006, 08:19:12 PM
The same applies for the package upgrader dream. I assure you, the changes are a lot.
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


Harzem

A file comparison between rc3 and final will give around a thousand of lines of difference.

The same applies for the package upgrader dream. I assure you, the changes are a lot.

nitins60

Quote from: HarzeM on December 02, 2006, 04:21:28 PM
Quote from: nitins60 on December 02, 2006, 03:41:46 PM
congrats. 5beers for each developer.
i just have gone through brief log between rc3 to final, didn't find many new options, which are promised in this release. I wonder, if they didn't!

No new options were promised for this release. This is a stability release, not a test drive for new features.

Quote from: nitins60 on December 02, 2006, 03:43:37 PM
One more challenging question to developers.
What's yr next SMF edition name? ;)

"Development edition", until it is released.
bit confused! It's not a SMF DEVELOPED EDITION, it's SMF v1.1 final? The next version is SMF developed edition? Am i correct? :)  Hope there won't be a long process of rc packages between 1.1final and development edition! ;)

latyshev

Could someone help me?

I have 1.0.9 right now. I uploaded webinstall.php and opened it in my browser. Then it asked for setting etc. I entered all the settings and pressed continue. It downloaded files then extracted. Then it says "blah blah click to continue". I click and my forum homepage opens.

What am i doing wrong?

SleePy

From what you said nothing sounds wrong.. Sounds like it went well..
Could you explain more?
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

nitins60

Quote from: latyshev on December 02, 2006, 08:31:41 PM
Could someone help me?

I have 1.0.9 right now. I uploaded webinstall.php and opened it in my browser. Then it asked for setting etc. I entered all the settings and pressed continue. It downloaded files then extracted. Then it says "blah blah click to continue". I click and my forum homepage opens.

What am i doing wrong?
it's better to do it manually. I tried using webinstall.php doesn't work! :'-)

latyshev

Quote from: SleePy on December 02, 2006, 08:33:59 PM
From what you said nothing sounds wrong.. Sounds like it went well..
Could you explain more?

The problem is that its still 1.0.9  :D  So, basically it returns to my homepage as it is now.

Quote from: nitins60 on December 02, 2006, 08:35:22 PM
it's better to do it manually. I tried using webinstall.php doesn't work! :'-)

How do i do it manually?

nitins60

Quote from: latyshev on December 02, 2006, 08:37:26 PM
Quote from: SleePy on December 02, 2006, 08:33:59 PM
From what you said nothing sounds wrong.. Sounds like it went well..
Could you explain more?

The problem is that its still 1.0.9  :D  So, basically it returns to my homepage as it is now.

Quote from: nitins60 on December 02, 2006, 08:35:22 PM
it's better to do it manually. I tried using webinstall.php doesn't work! :'-)

How do i do it manually?
simply download update package from downloads! Extract all files into thier respective folders. After completion of it, run update.php
don't forget to take backup, better to switch on yr forum maintainence, while updating

SleePy

missed that..

Can you confirm that the webinstaller didn't work?
Go to Admin then click on More detailed under version information... See what it is returning for those..
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

latyshev

Quote from: nitins60 on December 02, 2006, 08:43:41 PM
simply download update package from downloads! Extract all files into thier respective folders. After completion of it, run update.php
don't forget to take backup, better to switch on yr forum maintainence, while updating

aha, thanks!

Quote from: SleePy on December 02, 2006, 08:44:10 PM
missed that..

Can you confirm that the webinstaller didn't work?
Go to Admin then click on More detailed under version information... See what it is returning for those..

Yep, still shows 1.0.9 there.

acdouglas

Quote from: Thantos on December 02, 2006, 07:45:37 PM
acdouglas: can you double check that your Subs.php file got updated correctly also.

You mean updated to SMF 1.1?  Nothing was updated to 1.1. Webinstall.php returned me to my old 1.0.9 home page with that "missing copyright" message.

ACD

el-brujo

latyshev:

to upgrade 1.0.9 to 1.1 yo need to download the Large upgrade

http://www.simplemachines.org/download/index.php?thanks;filename=smf_1-1_upgrade.zip

Upload the files (Sources, Themes, etc), and run the upgrade.php

Advertisement: