• Welcome to Simple Machines Community Forum. Please login or sign up.
December 08, 2021, 09:12:09 PM

News:

Follow SMF on Twitter.


SMF 1.1.1 Released

Started by Grudge, December 16, 2006, 08:50:14 AM

Previous topic - Next topic

katzenellenbogen

I am one of these folks who have to manually make the "temp"-folder via FTP in packages-dir due to server config...

But this time I forgot to make the temp-dir.... Now I can neither uninstall 1.1.1, nor can I install it again.

When I try to re-install it, it behaves as it actually would install, but in "Check all files against current versions." and anywhere else V 1.1 remains :(

What to do?

Grudge

Quote from: CyberPhreak on December 18, 2006, 07:46:44 AM
Didn't go so easy for me, I got an error in Display.php. Any suggestions?
What does the error message say - and what are the lines of Display.php around where it says the error occured?

katzenellenbogen ,

I'm confused - what version number does it currently list at the bottom of the forum?
I'm only a half geek really...

katzenellenbogen

QuoteI'm confused - what version number does it currently list at the bottom of the forum?
I am confused too... It lists 1.1, and package-manager says the update has already been installed. But in fact this seems to be untrue.

gilipter

Quote from: katzenellenbogen on December 18, 2006, 09:55:27 AM
QuoteI'm confused - what version number does it currently list at the bottom of the forum?
I am confused too... It lists 1.1, and package-manager says the update has already been installed. But in fact this seems to be untrue.

I am having the same problem! It displays 1.1 at the bottom but the package is installed (it displays a green light next to the name in the packages) . I can't uninstall it coz it says There is no uninstaller. Also, when I check the Detailed Version Check, only the SMF Package displays 1.1. but all other files display the newest version. So, I really don't have a clue is it really updated.
Please advice,
Marjan
http://365.com.mk [nofollow]

Orange789

getting strange errors in my server erro log since upgrade.

It seems to be tagging the server IP address to the end of stuff:

Mon Dec 18 14:57:14 2006] [error] [client 62.253.32.5] Premature end of script headers: php-script, referer: http://www.domain.co.uk/forums/index.php?action=announce;sa=send

[Mon Dec 18 14:57:53 2006] [error] [client 87.242.154.247] File does not exist: /home/virtual/site38/fst/var/www/html/forums/209.208.*.*, referer: http://www.domain.co.uk/forums/index.php?PHPSESSID=a65a743db2606b7d83345a1e9918d340&board=1.0

[Mon Dec 18 14:58:46 2006] [error] [client 195.93.21.68] File does not exist: /home/virtual/site38/fst/var/www/html/forums/209.208.*.*, referer: http://www.domain.co.uk/forums/index.php?board=1.0

Whats that about then ?

Grudge

It seems to have failed to change index.php. You can run the package installe again to fix that. Simply go to "installed packages" - delete the patch package then redownload and install it. It will "fail" on all the steps that worked the first time but simply ignore that.
I'm only a half geek really...

Grudge

Orange789,

How did you upgrade - the patch? None of those errors make any sense to me - particularly as a result of the 1.1.1 patch.
I'm only a half geek really...

Naki-BoT

No errors on 1.1rc3 -> 1.1 -> 1.1.1 update

Thanks for upgrade.
:: hxxp:www.dot.pvpgn.pl [nonactive] :: hxxp:www.pvpgn.pl [nonactive] ::

katzenellenbogen

Quote from: Grudge on December 18, 2006, 10:14:56 AM
It seems to have failed to change index.php. You can run the package installe again to fix that. Simply go to "installed packages" - delete the patch package then redownload and install it. It will "fail" on all the steps that worked the first time but simply ignore that.
Sorry, won't help. I even tried to delete the upgrade-package in installed.list file and then tried to re-install again. It behaves as if everything went well (asks for ftp info, says successfull installation...), but in the end nothing happens (version counter remains 1.1).

The trick with manually making the temp-folder within Packages-dir and chmoding it to 777 didn't help either...

klumy


Orange789

Quote from: Grudge on December 18, 2006, 10:16:43 AM
Orange789,

How did you upgrade - the patch? None of those errors make any sense to me - particularly as a result of the 1.1.1 patch.

Through the package manager

I got an test failed error for changelog.txt but guessed that would not be a problem so continued.

Everything else seems fine.
Not getting errors with the forum ( other than cannot send annaouncemnts because of the premature end of script header error as above) just noticed that in my error log and found it rather strange!

Grudge

katzenellenbogen,

Are you sure index.php in the forum root directory is writable?

Orange,

The changelog failure is not an issue. The annoucements one is rather strange. Do you have any mods installed? I wonder if in your case it may be sensible to reupload a clean set of 1.1.1 files from the download page here ("Large Upgrade") to see if it clears it?
I'm only a half geek really...

katzenellenbogen

QuoteAre you sure index.php in the forum root directory is writable?

Yes, absolutely sure. Has always been chmodded to 777...

WXWP

ALL OK here... execept it killed some of my mods. Just have to wait for the authors to upgrade them again...
:-\
- John

Admin:SMF 1.1 RC3

DaBoROE09

easy to install. not all my themes are 1.1.1 but oh well

CJ111

Quote from: eldʌkaː on December 18, 2006, 08:55:46 AM
Quote from: CJ111 on December 18, 2006, 08:53:51 AM
The server gives me an error :

1. Execute Modification ./changelog.txt Test failed

What is wrong?  ::)
That's okay, you can install it anyway. If you get errors on the changelog it doesn't matter.

Check  ;), installed without problems. Thx! Just wanted to be sure before I f*cked up mij forum  ::)

gilipter

It was the problem with the cache folder. I deleted the cache from the php accelerator and now it displays 1.1.1 and eveything is updated as it should. This is the second problem I am having with the php caching. Anyone here knows a good guide where I can make the forum work ok with Eaccelerator. Also, the forum displays
SMF has not been able to detect a compatible accelerator on your server.
although there is one installed and it works ok.
Thanks.

Quote from: gilipter on December 18, 2006, 10:05:12 AM
Quote from: katzenellenbogen on December 18, 2006, 09:55:27 AM
QuoteI'm confused - what version number does it currently list at the bottom of the forum?
I am confused too... It lists 1.1, and package-manager says the update has already been installed. But in fact this seems to be untrue.

I am having the same problem! It displays 1.1 at the bottom but the package is installed (it displays a green light next to the name in the packages) . I can't uninstall it coz it says There is no uninstaller. Also, when I check the Detailed Version Check, only the SMF Package displays 1.1. but all other files display the newest version. So, I really don't have a clue is it really updated.
Please advice,
Marjan
http://365.com.mk [nofollow]

Wingnut31


Grudge

katzenellenbogen,

May I suggest you edit index.php directly then and after that it will all be OK. Literally open index.php and change the two occurances of 1.1 for 1.1.1.
I'm only a half geek really...

katzenellenbogen

Quote from: Grudge on December 18, 2006, 11:38:28 AM
katzenellenbogen,

May I suggest you edit index.php directly then and after that it will all be OK. Literally open index.php and change the two occurances of 1.1 for 1.1.1.
I don't think this is the problem (although I have done it now)

Version check gives me output:

SMF File   Your Version   Current Version
SMF Package   SMF 1.1.1   SMF 1.1.1
Sources   1.1   1.1.1
Admin.php   1.1   1.1
BoardIndex.php   1.1   1.1
Calendar.php   1.1   1.1
Display.php   1.1   1.1.1
DumpDatabase.php   1.1   1.1
Errors.php   1.1   1.1
Help.php   1.1   1.1
Karma.php   1.1   1.1
Load.php   1.1   1.1.1
LockTopic.php   1.1   1.1
LogInOut.php   1.1   1.1
ManageAttachments.php   1.1   1.1
ManageBans.php   1.1   1.1
ManageBoards.php   1.1   1.1
ManageCalendar.php   1.1   1.1
ManageErrors.php   1.1   1.1
ManageMembergroups.php   1.1   1.1
ManageMembers.php   1.1   1.1
ManageNews.php   1.1   1.1
ManagePermissions.php   1.1   1.1.1
ManagePosts.php   1.1   1.1
ManageRegistration.php   1.1   1.1
ManageSearch.php   1.1   1.1
ManageServer.php   1.1   1.1
ManageSmileys.php   1.1   1.1.1
Memberlist.php   1.1   1.1
MessageIndex.php   1.1   1.1
ModSettings.php   1.1   1.1
Modlog.php   1.1   1.1
MoveTopic.php   1.1   1.1
News.php   1.1   1.1
Notify.php   1.1   1.1
PackageGet.php   1.1   1.1
Packages.php   1.1   1.1
PersonalMessage.php   1.1   1.1
Poll.php   1.1   1.1
Post.php   1.1   1.1.1
Printpage.php   1.1   1.1
Profile.php   1.1   1.1
QueryString.php   1.1   1.1
Recent.php   1.1   1.1
Register.php   1.1   1.1
Reminder.php   1.1   1.1
RemoveTopic.php   1.1   1.1
RepairBoards.php   1.1   1.1
Reports.php   1.1   1.1
SSI.php   1.1   1.1
Search.php   1.1   1.1
Security.php   1.1   1.1
SendTopic.php   1.1   1.1
SplitTopics.php   1.1   1.1
Stats.php   1.1   1.1
Subs-Auth.php   1.1   1.1
Subs-Boards.php   1.1   1.1
Subs-Charset.php   1.1   1.1
Subs-Compat.php   1.1   1.1
Subs-Graphics.php   1.1   1.1
Subs-Members.php   1.1   1.1
Subs-Package.php   1.1   1.1
Subs-Post.php   1.1   1.1.1
Subs-Sound.php   1.1   1.1
Subs.php   1.1   1.1
Themes.php   1.1   1.1
ViewQuery.php   1.1   1.1
Viewkarma.php   1.1 RC3   ??
Who.php   1.1   1.1
Default Templates   1.1   1.1.1
Admin.template.php   1.1   1.1.1
BoardIndex.template.php   1.1   1.1
Calendar.template.php   1.1   1.1
Combat.template.php   1.1   1.1
DescriptionKarma.template.php   1.1 RC3   ??
Display.template.php   1.1   1.1
Errors.template.php   1.1   1.1
Help.template.php   1.1   1.1
Login.template.php   1.1   1.1
ManageAttachments.template.php   1.1   1.1
ManageBans.template.php   1.1   1.1
ManageBoards.template.php   1.1   1.1
ManageCalendar.template.php   1.1   1.1
ManageMembergroups.template.php   1.1   1.1
ManageMembers.template.php   1.1   1.1
ManageNews.template.php   1.1   1.1
ManagePermissions.template.php   1.1   1.1
ManageSearch.template.php   1.1   1.1
ManageSmileys.template.php   1.1   1.1
Memberlist.template.php   1.1   1.1
MessageIndex.template.php   1.1   1.1
Modlog.template.php   1.1   1.1
MoveTopic.template.php   1.1   1.1
Notify.template.php   1.1   1.1
Packages.template.php   1.1   1.1
PersonalMessage.template.php   1.1   1.1
Poll.template.php   1.1   1.1
Post.template.php   1.1   1.1
Printpage.template.php   1.1   1.1
Profile.template.php   1.1   1.1
Recent.template.php   1.1   1.1
Register.template.php   1.1   1.1
Reminder.template.php   1.1   1.1
Reports.template.php   1.1   1.1
Search.template.php   1.1   1.1.1
SendTopic.template.php   1.1   1.1
Settings.template.php   1.1   1.1
SplitTopics.template.php   1.1   1.1
Stats.template.php   1.1   1.1
Themes.template.php   1.1   1.1
Viewkarma.template.php   1.1 RC3   ??
Who.template.php   1.1   1.1
Wireless.template.php   1.1   1.1
Xml.template.php   1.1   1.1
index.template.php   1.1   1.1
Language Files   1.1   1.1


Maybe time to simply overwrite the files that are new in this release?

Advertisement: