Advertisement:

Author Topic: Joomla Bridge for SMF 1.1 final?  (Read 10892 times)

Offline Jo-bit

  • Semi-Newbie
  • *
  • Posts: 16
Joomla Bridge for SMF 1.1 final?
« on: December 02, 2006, 04:05:12 PM »
Hello!

Today I note SMF 1.1 final is released  :D
Many Thanks!

Now I try to bridged Joomla 1.0.11 with SMF 1.1 final, but I guess the file:
"Joomla Bridge 1.1.6 (A bridge to connect your Joomla installation to SMF 1.1.)"
in the download section is fault or an old file (1.1.4 as xml) ?

Could anyone confirm this?

Best Regards
« Last Edit: December 02, 2006, 05:27:31 PM by Orstio »

Orstio

  • Guest
Re: Joomla Bridge for SMF 1.1 final?
« Reply #1 on: December 02, 2006, 04:38:10 PM »
Something went wrong with the update, and some of the bridge downloads pointed to the wrong files. 

If you already had bridge 1.1.6 installed, you don't need to change it.  Bridge 1.1.6 was already compatible with SMF 1.1.

Offline Jo-bit

  • Semi-Newbie
  • *
  • Posts: 16
Re: Joomla Bridge for SMF 1.1 final?
« Reply #2 on: December 02, 2006, 05:00:28 PM »
Something went wrong with the update, and some of the bridge downloads pointed to the wrong files. 

If you already had bridge 1.1.6 installed, you don't need to change it.  Bridge 1.1.6 was already compatible with SMF 1.1.

Thanks for your fast answer Orstio!

However, I have a fault if I start SMF 1.1 in my Joomla template:
Notice: Undefined index: server in .../smf/Sources/Load.php on line 186

Any idea?

Orstio

  • Guest
Re: Joomla Bridge for SMF 1.1 final?
« Reply #3 on: December 02, 2006, 05:16:53 PM »
Can you change that line?

Code: [Select]
$space_chars = $utf8 ? (isset($context['server']['complex_preg_chars']) &&  $context['server']['complex_preg_chars'] ? '\x{C2A0}\x{E28080}-\x{E2808F}\x{E280AF}\x{E2809F}\x{E38080}\x{EFBBBF}' : sprintf('%c%c%c%c%c-%c%c%c%c%c%c%c%c%c%c%c%c%c%c%c', 0xC2, 0xA0, 0xE2, 0x80, 0x80, 0xE2, 0x80, 0x8F, 0xE2, 0x80, 0xAF, 0xE2, 0x80, 0x9F, 0xE3, 0x80, 0x80, 0xEF, 0xBB, 0xBF)) : '\xA0';

Offline Jo-bit

  • Semi-Newbie
  • *
  • Posts: 16
Re: Joomla Bridge for SMF 1.1 final?
« Reply #4 on: December 02, 2006, 05:26:58 PM »
CREATE  :D

Yes, now it works!

MANY THANKS!

Offline Ronny

  • Semi-Newbie
  • *
  • Posts: 55
Re: Joomla Bridge for SMF 1.1 final?
« Reply #5 on: December 03, 2006, 04:30:12 AM »
Thanks Orstio it fixed also my problem (utf-8) during the upgrade  ;D

Offline maxigs

  • Semi-Newbie
  • *
  • Posts: 60
Re: Joomla Bridge for SMF 1.1 final?
« Reply #6 on: December 03, 2006, 07:58:06 AM »
just tried the new forum out bridged in joomla and got this error showing up on top of the page on every forum-page (yet the rest of the forum seems to work fine)

Quote
Notice: Undefined index: server in /var/www/test1/smf/Sources/Load.php on line 186

the installation of the joomla with bridge was already present. just updated the forum

Offline imrich

  • Jr. Member
  • **
  • Posts: 390
  • Gender: Male
Re: Joomla Bridge for SMF 1.1 final?
« Reply #7 on: December 03, 2006, 08:11:30 AM »
Something went wrong with the update, and some of the bridge downloads pointed to the wrong files. 

If you already had bridge 1.1.6 installed, you don't need to change it.  Bridge 1.1.6 was already compatible with SMF 1.1.

I have to say that I updated my SMF to 1.1 final and my already installed bridge (1.1.6 for 1.1 RC3) seems to be working perfectly. I didn't change the bridge as I hadn't seen an anouncement here that there was a new one.

Is the 'updated' bridge downloads fixed yet? Or should we wait for an announcement here on this bridge forum?

Many thanks to those involved!

Orstio

  • Guest
Re: Joomla Bridge for SMF 1.1 final?
« Reply #8 on: December 03, 2006, 08:20:55 AM »
You don't need a different bridge for 1.1 Final.  Bridge 1.1.6 will work fine.

Offline pcjunkie

  • Semi-Newbie
  • *
  • Posts: 76
  • Junior Editor
Re: Joomla Bridge for SMF 1.1 final?
« Reply #9 on: December 09, 2006, 10:34:45 AM »
Thanks Orstio The sites looking a treat..

www.lms.org.au/start/

Offline TinkyWinky

  • Semi-Newbie
  • *
  • Posts: 14
  • Gender: Male
    • Novi Beograd
Re: Joomla Bridge for SMF 1.1 final?
« Reply #10 on: December 13, 2006, 12:11:23 PM »
Can you change that line?

Code: [Select]
$space_chars = $utf8 ? (isset($context['server']['complex_preg_chars']) &&  $context['server']['complex_preg_chars'] ? '\x{C2A0}\x{E28080}-\x{E2808F}\x{E280AF}\x{E2809F}\x{E38080}\x{EFBBBF}' : sprintf('%c%c%c%c%c-%c%c%c%c%c%c%c%c%c%c%c%c%c%c%c', 0xC2, 0xA0, 0xE2, 0x80, 0x80, 0xE2, 0x80, 0x8F, 0xE2, 0x80, 0xAF, 0xE2, 0x80, 0x9F, 0xE3, 0x80, 0x80, 0xEF, 0xBB, 0xBF)) : '\xA0';
I had same problem, it's solved now.
Thank you!!
[nofollow]

Offline TinkyWinky

  • Semi-Newbie
  • *
  • Posts: 14
  • Gender: Male
    • Novi Beograd
Re: Joomla Bridge for SMF 1.1 final?
« Reply #11 on: December 19, 2006, 06:27:39 AM »
I have just tried to update my forum from 1.1 to 1.1.1 and it seems like that new patch tried to change that line in Load.php so it reports error in testing installation. However, I installed patch, but I am not shure should I manualy change that line 186 in Load.php
[nofollow]

Offline baladeva

  • Jr. Member
  • **
  • Posts: 189
  • Gender: Male
  • ohm chanti
    • Homepage Hare Krishna Deutschland / Bhakti Group
Re: Joomla Bridge for SMF 1.1 final?
« Reply #12 on: December 19, 2006, 01:59:05 PM »
hello TinkyWinky,  and all others

i have the same problem now, when i try to ubgrade to 1.1.1 -  and i am not sure what to do,
but you have make the patch anyway, so now - do you have back the old problem - from the time bevore you did the modificaton, or all is running fine ?
« Last Edit: December 19, 2006, 03:16:21 PM by baladeva »

Offline TinkyWinky

  • Semi-Newbie
  • *
  • Posts: 14
  • Gender: Male
    • Novi Beograd
Re: Joomla Bridge for SMF 1.1 final?
« Reply #13 on: December 19, 2006, 06:29:08 PM »
There is no problem. I leave this line in Load.php:
Code: [Select]
$space_chars = $utf8 ? (isset($context['server']['complex_preg_chars']) &&  $context['server']['complex_preg_chars'] ? '\x{C2A0}\x{E28080}-\x{E2808F}\x{E280AF}\x{E2809F}\x{E38080}\x{EFBBBF}' : sprintf('%c%c%c%c%c-%c%c%c%c%c%c%c%c%c%c%c%c%c%c%c', 0xC2, 0xA0, 0xE2, 0x80, 0x80, 0xE2, 0x80, 0x8F, 0xE2, 0x80, 0xAF, 0xE2, 0x80, 0x9F, 0xE3, 0x80, 0x80, 0xEF, 0xBB, 0xBF)) : '\xA0';
[nofollow]

Offline baladeva

  • Jr. Member
  • **
  • Posts: 189
  • Gender: Male
  • ohm chanti
    • Homepage Hare Krishna Deutschland / Bhakti Group
Re: Joomla Bridge for SMF 1.1 final?
« Reply #14 on: December 25, 2006, 04:35:22 PM »
yes no problem with the 1.1.1 update, seems that all runs fine - and no problem with the Load.php