Advertisement:

Author Topic: Forum CRASHATO: HELP !!!  (Read 17844 times)

Offline francesco_ud

  • Jr. Member
  • **
  • Posts: 211
  • Gender: Male
    • Tuttoscooter.it
Re: Forum CRASHATO: HELP !!!
« Reply #20 on: January 22, 2007, 04:17:45 PM »
hai qualche dato all'interno del database? utenti registrati, messaggi?

se non hai nulla in quanto non hai mai utilizzato il forum elimina tutte le tabelle e poi reinstalla tutto il forum da zero.
Il mio sito dedicato agli Scooter

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #21 on: January 22, 2007, 05:22:15 PM »
hai qualche dato all'interno del database? utenti registrati, messaggi?

se non hai nulla in quanto non hai mai utilizzato il forum elimina tutte le tabelle e poi reinstalla tutto il forum da zero.

sì! è quello il problema.
ci sono dei dati che vorrei togliere, ma non so come.
il pannello di phoadmin è per me incomprensibile..
se ti serve ti faccio uno screenshot.

c'è un opzione, non in quel pannello, ma sempre dentro ad altervista tipo "cancella database" che ho fatto, ma non è stato resettato come speravo..

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #22 on: January 23, 2007, 04:08:03 AM »
ecco lo screenshot
come vedi, anche con l'opzione "cancella DB", non viene cancellato..



Edit:
forse ce l'ho fatta a cancellare le varie query rimaste..
« Last Edit: January 23, 2007, 04:10:24 AM by MarMa »

Offline francesco_ud

  • Jr. Member
  • **
  • Posts: 211
  • Gender: Male
    • Tuttoscooter.it
Re: Forum CRASHATO: HELP !!!
« Reply #23 on: January 23, 2007, 08:20:26 AM »
allora sulla sinistra della pagina trovi:

il nome del database (my_alcune_parole_che_non_capisco(35))

se ci clicchi sopra ti fa vedere la lista delle tabelle che ci sono in quel db.
fallo poi, a centro pagina ti verranno visualizzate le tabelle, i nomi sono uguali a quelli che trovi sotto il nome del db nella colonna sx.

se tu le selezioni tutte in basso trovi due cestini, uno chiaro ed uno rosso, quello rosso cancella tutte le tabelle, l'altro le svuota, mantenendole.

ora se non hai dati (dopo aver selezionato tutte le tabelle, spuntando la singola ceckbox di ogni tabella) premi il tasto con il cestino rosso, ti chiederà conferma digli di si e poi ti cancella tutto, fatto ciò puoi reinstallare da 0 il tuo forum
Il mio sito dedicato agli Scooter

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #24 on: January 24, 2007, 06:42:51 AM »
grazie
ieri col temporale m'era saltato fastweb..
stasera provo a reinstallare tutto..

sperem!

Offline francesco_ud

  • Jr. Member
  • **
  • Posts: 211
  • Gender: Male
    • Tuttoscooter.it
Re: Forum CRASHATO: HELP !!!
« Reply #25 on: January 24, 2007, 01:34:50 PM »
fammi sapere come procede la cosa! in caso chiedi pure!
Il mio sito dedicato agli Scooter

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #26 on: January 24, 2007, 02:08:57 PM »
fammi sapere come procede la cosa! in caso chiedi pure!

ho provato a ricaricare tutto, far partire l'installer ma ora mi dice

Quote
The installer was unable to access the "marcomangiarotti" database. With some hosts, you have to create the database in your administration panel before SMF can use it. Some also add prefixes - like your username - to your database names.

Click here to try this step again.

sob

eppure il DB, anche se vuoto, risulta attivo..
mado che depressione che mi sta venendo..

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #27 on: January 24, 2007, 02:24:35 PM »
Edit:
a ri-provo ad installare di nuovo tutto.
ma stavolta il "vecchio" forum+template che avevo prima..
« Last Edit: January 24, 2007, 02:51:24 PM by MarMa »

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #28 on: January 25, 2007, 02:36:36 PM »
ho installato la versione aggiornata 1.1.1.
ora, non mi carica più la pagina in italiano del classic theme.
non è che forse andava bene solo per la 1.0.6?

e nel pannello di manutenzione non ho più il comando "carica (vecchio) database " ?
come fo..?

ho paura di utilizzare l'opzione di altervista, magari mi "incasina" di nuovo tutto...
 :o

Offline francesco_ud

  • Jr. Member
  • **
  • Posts: 211
  • Gender: Male
    • Tuttoscooter.it
Re: Forum CRASHATO: HELP !!!
« Reply #29 on: January 26, 2007, 03:39:06 AM »
siamo a buon punto ora, anche se era meglio che tu installassi la versione 1.0.6 nuovamente, in quanto il db della versione 1.1.1 può essere diverso, quindi sarebbe stato meglio agire con l'upgrader, ma nulla è cmq impossibile


i file per l'italiano li trovi qui : http://www.smitalia.net  ;D

poi vedi se in locale riesci ad installare la versione 1.0.6 e uppare il db a convertirlo alla versione 1.1.1 e poi lo uppi nella versione 1.1.1 che hai in remoto.

ps non ho sotto mano la versione 1.1.1 quindi non riesco ad aiutarti troppo nelle funzioni, io uso una 1.0.9 attualmente.
Il mio sito dedicato agli Scooter

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #30 on: January 26, 2007, 05:09:39 AM »
siamo a buon punto ora, anche se era meglio che tu installassi la versione 1.0.6 nuovamente, in quanto il db della versione 1.1.1 può essere diverso, quindi sarebbe stato meglio agire con l'upgrader, ma nulla è cmq impossibile


i file per l'italiano li trovi qui : http://www.smitalia.net  ;D

poi vedi se in locale riesci ad installare la versione 1.0.6 e uppare il db a convertirlo alla versione 1.1.1 e poi lo uppi nella versione 1.1.1 che hai in remoto.

ps non ho sotto mano la versione 1.1.1 quindi non riesco ad aiutarti troppo nelle funzioni, io uso una 1.0.9 attualmente.


ok, allora proverò a cancellare di nuovo tutto e mettere la 1.0.6.
il fatto è che non mica ben capito come si l'upgrade.

da dopo il 4 mi ci metterò allora

grazie moltissime!

Offline francesco_ud

  • Jr. Member
  • **
  • Posts: 211
  • Gender: Male
    • Tuttoscooter.it
Re: Forum CRASHATO: HELP !!!
« Reply #31 on: January 26, 2007, 01:09:02 PM »
sostanzialmente upgradare permette di aggiornare i campi del database per renderli compatibili con una versione successiva. quindi se i campi dei database (che alla fine è composto da alcune tabelle) non coicidono, non ci può essere un corretto scambio di dati tra database e forum..
ora io ti consiglio di installare la 1.0.6, e di passare alla versione 1.1.1 tramite i file appositi, che saranno  composti dal pachetto upgrade, non update, in quanto passi salla versione 1.0 alla versione 1.1 (se dovevi passare dalla versione 1.0.8 alla 1.0.9 dovevi usare il pacchetto update, idem per passare dalla 1.1 rc2 alla 1.1 rc3).

appurato questo con calma installa da 0 la versione 1.0.6, importa il database, esegui tutti le operazioni di verifica dei dati, successivamente aggiorna alla versione 1.1.1 tramite l'apposito pacchetto (installa i files di linguaggio che trovi su smitalia) e poi testa se tutto funge correttamente.
ricorda fino a quando non sei sicuro di aver il forum al 100% non cancellare quel backup!
Il mio sito dedicato agli Scooter

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #32 on: January 26, 2007, 01:44:44 PM »
sostanzialmente upgradare permette di aggiornare i campi del database per renderli compatibili con una versione successiva. quindi se i campi dei database (che alla fine è composto da alcune tabelle) non coicidono, non ci può essere un corretto scambio di dati tra database e forum..
ora io ti consiglio di installare la 1.0.6, e di passare alla versione 1.1.1 tramite i file appositi, che saranno  composti dal pachetto upgrade, non update, in quanto passi salla versione 1.0 alla versione 1.1 (se dovevi passare dalla versione 1.0.8 alla 1.0.9 dovevi usare il pacchetto update, idem per passare dalla 1.1 rc2 alla 1.1 rc3).

appurato questo con calma installa da 0 la versione 1.0.6, importa il database, esegui tutti le operazioni di verifica dei dati, successivamente aggiorna alla versione 1.1.1 tramite l'apposito pacchetto (installa i files di linguaggio che trovi su smitalia) e poi testa se tutto funge correttamente.
ricorda fino a quando non sei sicuro di aver il forum al 100% non cancellare quel backup!

e chi lo cancella il backup !
scherzi..

cmq dal 4 febb mi ci metterò su.
la cosa è, che avevo prima provato a metter su la 1.0.6 ma anche lì non mi dava l'opzione carica DB..
e non capisco xkè!?

Faber73

  • Guest
Re: Forum CRASHATO: HELP !!!
« Reply #33 on: January 26, 2007, 05:58:46 PM »
Il DB và caricato da phpMyAdmin

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #34 on: February 22, 2007, 12:17:13 PM »
Il DB và caricato da phpMyAdmin

scusa, non sono pratica.
ovvero?

cmq ora provo a ricaricare la vecchia versione che avevo, poi ripristino (se dio vuole..) il vecchio DB e poi procedo con l'aggiornamento..?
è questa la procedura?

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #35 on: March 07, 2007, 12:14:09 PM »
mi da questo errore

Quote
The installer was unable to access the "marcomangiarotti" database. With some hosts, you have to create the database in your administration panel before SMF can use it. Some also add prefixes - like your username - to your database names.

Click here to try this step again.

eppure le volte passate ho sempre fatto allo stesso modo..
dal pannello di altervista, cancella DB, e poi ho proceduto dal file install..
ora però mi da questo errore e non riesco a capire come risolverlo.
 :o

Offline theshown

  • Semi-Newbie
  • *
  • Posts: 75
Re: Forum CRASHATO: HELP !!!
« Reply #36 on: March 08, 2007, 05:32:49 AM »
Su altervista i database non sono preceduti dal prefisso "my_" ? nel tuo caso dovrebbe essere "my_marcomangiarotti".
My Projects: SOLDAT Italia

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #37 on: March 08, 2007, 06:00:39 AM »
Su altervista i database non sono preceduti dal prefisso "my_" ? nel tuo caso dovrebbe essere "my_marcomangiarotti".

sì.
e lo metto da install.php.
però mi da quell'errore.

è normale che dal pannello di phpmyadmin mi dica "my_marcomangiarotti(0)"?
capisco che non ci sono tabelle (in effetti le ho cancellate tutte e dato pure cancella DB) però devo forse mica fare altro..?  

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #38 on: March 08, 2007, 06:32:33 AM »
ok, ora ho risolto la parte dell'installazione!
yuppi-do

ora vedo se riesco a caricare il backup..
 :o

Offline MarMa

  • Semi-Newbie
  • *
  • Posts: 33
Re: Forum CRASHATO: HELP !!!
« Reply #39 on: March 08, 2007, 07:17:38 AM »
ho tentato di importare da phpMyAdmin il vecchio DB..
mi da questo errore

Quote
Errore

Pare che ci sia un errore nella query SQL immessa. L'errore del server MySQL mostrato qui sotto, se c'è, può anche aiutare nella risoluzione del problema

ERROR: Stringa di Punctuation Sconosciuta @ 130
STR: ><
SQL:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html><head>
   <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
   <meta name="description" content="E' accaduto un errore!" />
   <meta name="keywords" content="PHP, MySQL, bulletin, board, free, open, source, smf, simple, machines, forum" />
   <script language="JavaScript" type="text/javascript" src="http://nomeforum.altervista.org/forum/Themes/default/script.js"></script>
   <script language="JavaScript" type="text/javascript"><!--
      var smf_theme_url = "http://nomeforum.altervista.org/forum/Themes/classic";


query SQL:


che vuol dire..?
 :o