Advertisement:

Author Topic: YouTube BBC Tag (XHTML Compliant)  (Read 210403 times)

Offline xylar

  • Newbie
  • *
  • Posts: 7
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #340 on: May 18, 2007, 01:47:14 PM »
use the mod i posted above, works for me :)

Offline Daniel Marquard

  • Jr. Member
  • **
  • Posts: 356
  • Gender: Male
    • Tristition
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #341 on: May 18, 2007, 10:04:15 PM »
but there is a lot of people which doesn't have newest versions of all major browsers......

As previously stated, the XHTML compliant code used to embed YouTube videos in posts will not be changed.  Sorry.

Offline Stuart

  • Full Member
  • ***
  • Posts: 421
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #342 on: May 19, 2007, 09:52:22 AM »
Thanks a million for this fantastic mod  :D

Offline glennk

  • Sr. Member
  • ****
  • Posts: 899
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #343 on: May 20, 2007, 11:45:15 AM »
I installed the package and all went well. I cant get it to work though for some reason.

Am I getting the tags wrong or something ?

Sample post at :

http://www.whitbyseaanglers.co.uk/forum/non-fishing-chat/you-tube-test/0/

If I try this it says I left the message box empty.

[youtube=425,350]qCRetU-shq0[/youtube]
« Last Edit: May 20, 2007, 11:51:40 AM by glennk »

Offline Tormod

  • Semi-Newbie
  • *
  • Posts: 37
  • Gender: Male
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #344 on: May 20, 2007, 03:20:33 PM »
I installed this mod too, but it,s only a white window showing.  :-\

Offline glennk

  • Sr. Member
  • ****
  • Posts: 899
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #345 on: May 20, 2007, 05:53:41 PM »
I  uninstalled then installed this

http://custom.simplemachines.org/mods/index.php?mod=720

 and got it working. However I keep getting this at the top of my forum

$txt['youtube'] = 'YouTube';

Why is this appearing ?

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,554
  • Gender: Male
    • Kindred-999 on GitHub
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #346 on: May 20, 2007, 06:01:39 PM »
well, you should ask about other mods in the thread for THOSE mods...

but that error is due to a problem with the install into the modifications.english.php file
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline glennk

  • Sr. Member
  • ****
  • Posts: 899
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #347 on: May 20, 2007, 06:21:49 PM »
Everyone in my forum is complaining  everything has gone big on th screen.

I've uninstalled again

Can you direct me to the right topic please.

Offline Farmacija

  • Full Member
  • ***
  • Posts: 611
  • Gender: Male
  • Farmacija forum www.farmaceuti.com
    • Pharmacy forum
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #348 on: May 21, 2007, 04:43:55 AM »
but there is a lot of people which doesn't have newest versions of all major browsers......

As previously stated, the XHTML compliant code used to embed YouTube videos in posts will not be changed.  Sorry.
fortunately, there is another mod :)

Offline robbievk

  • Semi-Newbie
  • *
  • Posts: 44
    • CheckWeb.nl
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #349 on: May 21, 2007, 09:26:12 AM »
fortunately, there is another mod :)
Which one?

I can't seem to find another for 1.1.2

Offline Daniel Marquard

  • Jr. Member
  • **
  • Posts: 356
  • Gender: Male
    • Tristition
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #350 on: May 21, 2007, 11:39:31 AM »
fortunately, there is another mod :)

Great news for webmasters that feel the need to broadcast their forum's XHTML invalidity.

Offline Tormod

  • Semi-Newbie
  • *
  • Posts: 37
  • Gender: Male
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #351 on: May 21, 2007, 04:19:05 PM »
I installed this mod too, but it,s only a white window showing.  :-\

Sorry, when I read inside this thread I can se I have to put only the last letters in the code from YouTube between the YouTube tags.

Now the mod work very well. :D

Offline robbievk

  • Semi-Newbie
  • *
  • Posts: 44
    • CheckWeb.nl
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #352 on: May 22, 2007, 03:25:22 AM »
in subs.php i changed:
Code: [Select]
'content' => '<object type="application/x-shockwave-flash" width="$2" height="$3" data="http://www.youtube.com/v/$1"><param name="movie" value="http://www.youtube.com/v/$1"></param><param name="wmode" value="transparent"></param></object>
to this:
Code: [Select]
'content' => '<object width="$2" height="$3"><param name="movie" value="http://www.youtube.com/v/$1"></param><embed src="http://www.youtube.com/v/$1" type="application/x-shockwave-flash" width="$2" height="$3"></embed></object>',
And now also FF 1.5 shows the video... did i screw up XHTML now?

Offline Daniel Marquard

  • Jr. Member
  • **
  • Posts: 356
  • Gender: Male
    • Tristition
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #353 on: May 22, 2007, 09:41:32 AM »
And now also FF 1.5 shows the video... did i screw up XHTML now?

If you're using the embed code that YouTube provides you, then yes, you've just broke your page's XHTML validity.

Offline xung

  • Newbie
  • *
  • Posts: 9
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #354 on: June 10, 2007, 09:57:41 AM »
Hi!

I've been using this great mod for some time, now. But recently some of my board user have been complaining. Some couldn't hit the play button of the video... (well, they hit the button, but nothing happens). And some don't see the video at all. All of the page loads, but not the videos.

All worked fine until some time ago, but now it won't work. Since I haven't make any change in my board, anyone knows if something changed at YouTube?

Thanks in advance,
-xung

Offline Nutronic

  • Semi-Newbie
  • *
  • Posts: 70
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #355 on: June 14, 2007, 01:30:05 PM »
Love it cheers

Offline Daniel Marquard

  • Jr. Member
  • **
  • Posts: 356
  • Gender: Male
    • Tristition
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #356 on: June 15, 2007, 11:01:53 PM »
Hi!

I've been using this great mod for some time, now. But recently some of my board user have been complaining. Some couldn't hit the play button of the video... (well, they hit the button, but nothing happens). And some don't see the video at all. All of the page loads, but not the videos.

All worked fine until some time ago, but now it won't work. Since I haven't make any change in my board, anyone knows if something changed at YouTube?

Thanks in advance,
-xung

Tell the members that can't click the play button to upgrade their outdated browser installations.  Explain to the members that can't see the videos at all how to use the mod; that between the tags goes the video embed ID, NOT the video page's URL.

Offline xung

  • Newbie
  • *
  • Posts: 9
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #357 on: June 15, 2007, 11:13:41 PM »
Hi!
Thanks for the answer. I'll tell those who can't click the play button to upgrade.
Then, the other ones (at least one I personaly know) uses Opera, and all worked fine until some weeks ago. (I mean, he could see videos with no problem).
This particular one has no problem with videos he uploaded (he hasn't really uploaded any, I think). He has problems with videos other users upload and that work fine with both IE and Firefox to other users (me, for instance) and don't work with him.
He said the whole page loaded but the video didn't. Instead he had a blank space....

I don't know if the recent "OnMouseOver" changes youtube made has anything to do with this particular issue.

But, thanks, anyway. I guess I'll have to tell all my users to get a decent browser. :D

Offline SactoEric

  • Semi-Newbie
  • *
  • Posts: 36
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #358 on: June 23, 2007, 10:01:41 PM »
Thank you for a great mod! I just got this installed on SacForums.com :)

Offline John S

  • Jr. Member
  • **
  • Posts: 381
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #359 on: June 24, 2007, 06:39:12 PM »
hi, awesome mod!

is there a way to remove the link to the youtube website when clicked on?