Advertisement:

Author Topic: YouTube BBC Tag (XHTML Compliant)  (Read 210599 times)

Offline raaja

  • Semi-Newbie
  • *
  • Posts: 52
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #80 on: January 20, 2007, 07:06:38 PM »

I cant find these file.... Subs.php and Post.template.php  ........itz confusing...

can anyone tell me, the file in which folder??

Offline 127.0.0.1

  • Jr. Member
  • **
  • Posts: 265
  • Gender: Male
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #81 on: January 20, 2007, 08:13:03 PM »
Why is it the only tag that has to work like that? Posting just an IMG tag in the message body will work, why won't it work for the youtube tag? I've been into the Subs.php file trying to figure it out.

Got me there   ???   Something with the mod I guess.  Usually people on my forum will make a short intro before using the the code, e.g. Here's a funny bicycle accident, then use the mod to insert the YouTube value.

This is very strange,  because I did not modify any code, and yet am no longer receiving the empty message body error notification. I forget if I changed something in the admin console, perhaps that could be it. Could anyone shed some insight into this issue? Because apparently I wasn't the only one who had this problem though it seems to have gone away, for now.

Offline RoarinRow

  • Full Member
  • ***
  • Posts: 662
  • Gender: Male
  • Ride my AV!
    • Avalanche Style
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #82 on: January 20, 2007, 08:13:46 PM »

I cant find these file.... Subs.php and Post.template.php  ........itz confusing...

can anyone tell me, the file in which folder??

'subs.php' in in forum/Sources
'post.template.php' is in forum/themes/default

SMF 2.0
TP 1.0 RC1.1
Wordpress 3.1.3

Offline raaja

  • Semi-Newbie
  • *
  • Posts: 52
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #83 on: January 20, 2007, 09:14:32 PM »
Thansk RoarinRow.. itz working fine nw... but there is another prob for me....

I cant find the youtube.gif image in my default theme image directory...



guide me...

thanks in advance...
« Last Edit: January 20, 2007, 09:17:45 PM by raaja »

Offline mark7144

  • Sophist Member
  • *****
  • Posts: 1,174
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #84 on: January 20, 2007, 09:19:59 PM »
Thansk RoarinRow.. itz working fine nw... but there is another prob for me....

I cant find the youtube.gif image in my default theme image directory...



guide me...

thanks in advance...
Right click the 'X' > propeties... find out where it is trying to load the image from... then go into that folder via FTP and just drag over the image from the YouTube mod zip to that folder in your forum.

Offline mark7144

  • Sophist Member
  • *****
  • Posts: 1,174
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #85 on: January 20, 2007, 09:21:02 PM »
I can post just a YouTube video on its own without an empty message warning. However if I try and edit the post via AJAX it won't let me without me putting text in the post yet if I modify the post the non-AJAX way, it is then fine.

Can anyone tell me what I should do?

Offline raaja

  • Semi-Newbie
  • *
  • Posts: 52
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #86 on: January 20, 2007, 11:45:25 PM »
Thansk RoarinRow.. itz working fine nw... but there is another prob for me....

I cant find the youtube.gif image in my default theme image directory...



guide me...

thanks in advance...
Right click the 'X' > propeties... find out where it is trying to load the image from... then go into that folder via FTP and just drag over the image from the YouTube mod zip to that folder in your forum.

Great... Thanks alot... I fix it.. :)

Offline Daniel Marquard

  • Jr. Member
  • **
  • Posts: 356
  • Gender: Male
    • Tristition
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #87 on: January 21, 2007, 02:16:59 AM »
I can post just a YouTube video on its own without an empty message warning. However if I try and edit the post via AJAX it won't let me without me putting text in the post yet if I modify the post the non-AJAX way, it is then fine.

Can anyone tell me what I should do?

I'm guessing that that's a bug with SMF, not the mod itself.

Offline Fizzgig

  • Semi-Newbie
  • *
  • Posts: 41
  • Gender: Female
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #88 on: January 21, 2007, 10:16:32 AM »
Hello, I've just installed this mod on my test forum (1.1.1 with WoW dk theme) and I can get the button to show and that's about it. The code isn't working and I'm not sure what else I should edit.
I used the code as you said to (only using the end of URL).

Any help appreciated.

-Fizz

Edit:
Got it to work, yay!
I just manually edited the subs file. In fact, I had to manuallly edit everything including uploading the image(which didn't exist anywhere in my forum files)...nothing was modified with the install at all.


« Last Edit: January 21, 2007, 10:36:36 AM by Fizzgig »

Offline Daniel Marquard

  • Jr. Member
  • **
  • Posts: 356
  • Gender: Male
    • Tristition
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #89 on: January 21, 2007, 06:08:41 PM »
Hello, I've just installed this mod on my test forum (1.1.1 with WoW dk theme) and I can get the button to show and that's about it. The code isn't working and I'm not sure what else I should edit.
I used the code as you said to (only using the end of URL).

Any help appreciated.

-Fizz

Edit:
Got it to work, yay!
I just manually edited the subs file. In fact, I had to manuallly edit everything including uploading the image(which didn't exist anywhere in my forum files)...nothing was modified with the install at all.

Please post the code you're using.  Also, copy the image over from the default theme's images folder to your custom theme's images folder.

Offline 4fit?

  • Jr. Member
  • **
  • Posts: 162
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #90 on: January 22, 2007, 08:09:07 AM »
Thanks but I did manage to get it working after-all :)

I do have one small issue, though and I can't seem to find where to fix it.
I get this error:

8: Undefined index: gallery_text_oldpicture
File: /home/****************/public_html/Themes/default/languages/Gallery.english.php (eval?)
Line: 621

In the forum error log. It seems to come up everytime someone accesses the gallery pages.
 :-\
I would recommend contacting the gallery author, vbgamer45.

Offline Fizzgig

  • Semi-Newbie
  • *
  • Posts: 41
  • Gender: Female
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #91 on: January 22, 2007, 09:15:28 AM »
Heh. Yeah sorry I posted that in the wrong forum.

Must...get...sleep...

Offline Daniel Marquard

  • Jr. Member
  • **
  • Posts: 356
  • Gender: Male
    • Tristition
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #92 on: January 22, 2007, 01:00:55 PM »
Thanks but I did manage to get it working after-all :)

I do have one small issue, though and I can't seem to find where to fix it.
I get this error:

8: Undefined index: gallery_text_oldpicture
File: /home/****************/public_html/Themes/default/languages/Gallery.english.php (eval?)
Line: 621

In the forum error log. It seems to come up everytime someone accesses the gallery pages.
 :-\
I would recommend contacting the gallery author, vbgamer45.

Heh. Yeah sorry I posted that in the wrong forum.

Must...get...sleep...

How did you manage to do that?  :P

Offline catfished

  • Sr. Member
  • ****
  • Posts: 877
  • Gender: Male
  • pǝsnɟuoɔ ןןıʇs puɐ ʇɹıp uɐɥʇ ɹǝpןo
    • CatfishED.com
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #93 on: January 24, 2007, 07:30:09 PM »
After reading this entire thread, I find that this mod will not work unless I manually edit a bunch of code. That makes it useless for me since I'm not a coder. At least now I can stop pulling my hair out trying to find out what I did wrong. I hope that eventually it's fixed so that we can actually install it with the package manager. ::)
You use and like this forum software? Then show your appreciation and support by becoming a Charter Member.



CatfishEd.com

Offline 4fit?

  • Jr. Member
  • **
  • Posts: 162
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #94 on: January 24, 2007, 08:25:00 PM »
After reading this entire thread, I find that this mod will not work unless I manually edit a bunch of code. That makes it useless for me since I'm not a coder. At least now I can stop pulling my hair out trying to find out what I did wrong. I hope that eventually it's fixed so that we can actually install it with the package manager. ::)
I installed it with the package manager without any problems whatsoever!!!

Offline catfished

  • Sr. Member
  • ****
  • Posts: 877
  • Gender: Male
  • pǝsnɟuoɔ ןןıʇs puɐ ʇɹıp uɐɥʇ ɹǝpןo
    • CatfishED.com
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #95 on: January 24, 2007, 10:20:35 PM »
I installed it with the package manager without any problems whatsoever!!!

Thanks for the reply, I'm glad it works for some people.

I'm using version 1.1.1 with the default theme and the only mods I have are:
1.    SMF 1.1.1 Update Package 1.1.1      
2.    MessagePreviewOnHover    1.4    
3.    YouTube BBC Tag (XHTML Compliant) 1.0    
4.    Users Online Today Mod    1.3.1

I've installed it, tried to uninstall it but it gives errors and says it still wants to install it even though it's already installed. I deleted it, re downloaded it and re installed it with the same results. When I try to use it, it just shows the [youtube] tags. I don't know what else I can do!

Edit: Here's the error message when I try to uninstall it:

Error in Package Installation
At least one error was encountered during a test installation of this package. It is strongly recommended that you do not continue with installation unless you know what you are doing, and have made a backup very recently. This error may be caused by a conflict between the package you're trying to install and another package you have already installed, an error in the package, a package which requires another package that you don't have installed yet, or a package designed for another version of SMF.
Installation Readme
You are about to uninstall the "YouTube BBC Tag ((XHTML Compliant)" mod from your SMF forum. Chances are you're doing this because it either didn't work for you, caused problems on your forum, or another related issue. If this is the case, please feel free to ask for help on the Simple Machines community forum.

Uninstall Actions
Uninstall Actions "YouTube BBC Tag (XHTML Compliant)":
Installing this package will perform the following actions:
   Type    Action    Description
1.    Execute Modification    ./Sources/Subs.php    Test failed
2.    Execute Modification    ./Themes/default/Post.template.php    Test failed
3.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test failed
« Last Edit: January 24, 2007, 10:24:08 PM by catfished »
You use and like this forum software? Then show your appreciation and support by becoming a Charter Member.



CatfishEd.com

Offline Daniel Marquard

  • Jr. Member
  • **
  • Posts: 356
  • Gender: Male
    • Tristition
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #96 on: January 24, 2007, 11:12:25 PM »
I hope that eventually it's fixed so that we can actually install it with the package manager. ::)

Fixed?  What's there to fix?  Seeing as it works for 99.9% of all SMF users running 1.1.1, I'd venture to say that it's a problem with your forum, not with my mod.

Offline catfished

  • Sr. Member
  • ****
  • Posts: 877
  • Gender: Male
  • pǝsnɟuoɔ ןןıʇs puɐ ʇɹıp uɐɥʇ ɹǝpןo
    • CatfishED.com
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #97 on: January 24, 2007, 11:57:41 PM »

Fixed?  What's there to fix?  Seeing as it works for 99.9% of all SMF users running 1.1.1, I'd venture to say that it's a problem with your forum, not with my mod.
I read this whole thread and I'm not the only one having this problem. There are several people that have posted the same problem that I'm having, at least two of them chose to install manually because they could not get it to install with the package manager. I have tried it on 2 different forums (both 1.1.1 with default (core) theme] with the exact same results! So even though I have always been able to install mods with the package manager, it's my forums problems that I can't install this one!!!!!!
You use and like this forum software? Then show your appreciation and support by becoming a Charter Member.



CatfishEd.com

Offline Daniel Marquard

  • Jr. Member
  • **
  • Posts: 356
  • Gender: Male
    • Tristition
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #98 on: January 25, 2007, 01:09:52 AM »
I read this whole thread and I'm not the only one having this problem. There are several people that have posted the same problem that I'm having, at least two of them chose to install manually because they could not get it to install with the package manager. I have tried it on 2 different forums (both 1.1.1 with default (core) theme] with the exact same results! So even though I have always been able to install mods with the package manager, it's my forums problems that I can't install this one!!!!!!

Did you upload the package or simply install it via the package manager with the mod browser?

Offline catfished

  • Sr. Member
  • ****
  • Posts: 877
  • Gender: Male
  • pǝsnɟuoɔ ןןıʇs puɐ ʇɹıp uɐɥʇ ɹǝpןo
    • CatfishED.com
Re: YouTube BBC Tag (XHTML Compliant)
« Reply #99 on: January 25, 2007, 10:30:03 AM »
Did you upload the package or simply install it via the package manager with the mod browser?

I uploaded the package from the SMF Mods page. I deleted the file from my computer the first time and uploaded it again just in case the original one had gotten corrupted.

I also tried to figure out how to do it manually but I'm not sure I did it right. If you could give me a list of files to FTP and what files/folders to send them to, that might solve my problem.

I also tried installing it in a third forum I have, also 1.1.1 default (core) theme, with the exact same results. In all three cases I can't even uninstall the mod, it gives this error:
Quote
Error in Package Installation
At least one error was encountered during a test installation of this package. It is strongly recommended that you do not continue with installation unless you know what you are doing, and have made a backup very recently. This error may be caused by a conflict between the package you're trying to install and another package you have already installed, an error in the package, a package which requires another package that you don't have installed yet, or a package designed for another version of SMF.
Installation Readme
You are about to uninstall the "YouTube BBC Tag ((XHTML Compliant)" mod from your SMF forum. Chances are you're doing this because it either didn't work for you, caused problems on your forum, or another related issue. If this is the case, please feel free to ask for help on the Simple Machines community forum.

Uninstall Actions
Uninstall Actions "YouTube BBC Tag (XHTML Compliant)":
Installing this package will perform the following actions:
   Type    Action    Description
1.    Execute Modification    ./Sources/Subs.php    Test failed
2.    Execute Modification    ./Themes/default/Post.template.php    Test failed
3.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test failed
You use and like this forum software? Then show your appreciation and support by becoming a Charter Member.



CatfishEd.com