• Welcome to Simple Machines Community Forum. Please login or sign up.

RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

vbgamer45

Haven't been able to figure out how to get that to work yet.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Angelotus

vbgamer, have you got an answer to my question that I asked in this message: http://www.simplemachines.org/community/index.php?topic=141776.msg1706722#msg1706722

It still doesn't work on my site!

BTW, great there will be a 2.0 version as well, hope that works...

itisme1760

I have this working, and it fetches automatically from the rss feeds only if I visit the URL link.

I have cPanel, and I want to enable a CronJob.  What would I put in for the command?

I have it currently at this now, but it doesn't work.

/usr/local/bin/php -q  /home/laatedaa/public_html/forums/cronrss.php

Is there something wrong?  I'm sure my path is correct.

skidpics

I installed this yesteday and worked fine via the fake cron job a few times, not, I get nothing anymore.  I reinstalled as a test site, and I still cannot get anything to work.  Any suggestions where to look?   It pulled the feeds once, why not again??

itisme1760

Nevermind, got my cron job to work, one thing though....

It duplicates certain posts.  How can I prevent this from happening?

skidpics

Quote from: itisme1760 on October 07, 2008, 12:48:17 AM
Nevermind, got my cron job to work, one thing though....

It duplicates certain posts.  How can I prevent this from happening?

what di dyou do to get it to work?

DareDevil1990

ya i am also unable to install it as  cron job.....

skidpics

I just can't figure out why it worked the first few times (fake Cron) and all of the sudden, nothing more..

I get this in an email:  forum/cronrss.php: Permission denied

itisme1760

To those above who have cPanel and want to install it as a cronjob, this is what worked for me.

/usr/local/bin/php -q  /home/laatedaa/public_html/forums/cronrss.php

of course, change your path to whatever applies to your forums.  Now the easiest way to find your path is to go to the forum admin panel, server settings, forum path.

Whala, hope this helps.

But anyone know how to fix the duplicate postings?

c3lt1957

October 09, 2008, 03:31:06 AM #1049 Last Edit: December 15, 2008, 02:28:36 AM by c3lt1957
vbgamer45,

Great mod thanks, it makes a slow boring board far busier !!!

I do have a slight problem though, my website is a combination of both html pages & of course my SM forum 1.1.6 Now if I put the Url for any particular RSS feed through a Feed Reader that I have and then copy and paste the resulting code direct into a html page then it displays with all images ect and looks really good.
But if I put the same Url into the Feed Poster all I get is a couple of lines of text as shown below;

Satellites to Predict Disease Outbreaks
         

Scientists hope to use satellite data to predict cholera and other disease outbreaks.
         

http://dsc.discovery.com/news/2008/10/08/cholera-satellite.html [nofollow]


Any ideas as to why it doesn't display as well on the forum as it does on a html page....??? To be honest I would of expected it to happen the other way around because I had a hell of a job getting the PHP code to display within a html page,  so as the forum is PHP why then does it not display properly !!!  :(

Regards

c3lt1957
[nofollow]           

c3lt1957

October 09, 2008, 04:14:15 AM #1050 Last Edit: December 15, 2008, 02:27:49 AM by c3lt1957
Oh sorry I almost forgot,

to those guys having probs with your cron jobs ! Access your Cpanel and scroll to the bottom of the page where you should find "cron jobs" If not there then request your hosting company to enable it for you.
Add what is in blue below to your cmd line, obviously adjusted with your own details. You will also need to set the timings for updates, but that is fairly straight forward ie I set mine to every 4 hrs, * (=everyday), *(=every week), *(=every month). You will see the relevant boxes for this when you access it through Cpanel.

/usr/local/bin/php -q /home/*******/public_html/forum/cronrss.php >/dev/null 2>&1

Replace the asterix with your details as supplied by your hosting company, "public_html" is my root folder so you may have to change that also if your root folder is different ? After talking to my hosting company it would seem that cron is often disabled by default, so please ensure that yours is enabled. Oh & one last bit of info, the >/dev/null 2>&1 on the end will stop it emailing you everytime it updates...?

I was having great difficulty getting this mod to work, but this is what I did to cure it ! Hope you find it useful guys.

Regards

c3lt1957
[nofollow]

Sincere

When the feed poster would be available for smf2.0 ??
Do you need a special mod for your smf forums? contact me for a quote.

nepharius

October 10, 2008, 01:04:07 PM #1052 Last Edit: October 11, 2008, 04:02:34 PM by nepharius
UPDATE: Now I get the emails saying Feed Poster configuration, but nothing is updating on my forums still.  I had put in the wrong path downbelow so that is how I fixed that but now nothing is getting posted in my forums, someone please help.

Current CronJob:
/usr/local/bin/php -q  /home2/neph/public_html/forums/cronrss.php


Nothing is updating, please help.
Everything is enabled - cronjob and all the php functions needed

CronJob:
/usr/local/bin/php -q  /home/neph/public_html/forums/cronrss.php

Feeds: Validated
hxxp:www.logicalfear.com/rss-articles/ [nonactive]
hxxp:nephariusepidemics.com/feeds/rss.xml?alt=rss [nonactive]

When I run manually:
hxxp:nephariusepidemics.com/forums/cronrss.php [nonactive]

I get the page that says: Feed Poster configuration
And nothing updates on my forums.

I get the email from cronjobs saying:
Could not open input file: /home/neph/public_html/forums/cronrss.php

ice_9

Here is a question from the other end of the spectrum.

Friend of mine is running a forum with this mod. I have a personal blog site.  My friend is using my RSS feed to post on his website. Says he has it set to check my feed every 720 minutes. Instead, whenever I post on my blog site, it immediately posts twice on his site.

Two problems:
He is jacking up my limited bandwidth by reading my RSS feed every second of every day.  I need him to only hit the site every 720 minutes. What does he need to change or check to make that happen?

Also, how do you fix the double posting?

I will have him check on the requirements on the first page to run the mod. Any suggestions?

itisme1760

Quote from: nepharius on October 10, 2008, 01:04:07 PM
UPDATE: Now I get the emails sayin,g Feed Poster configuration, but nothing is updating on my forums still.  I had put in the wrong path downbelow so that is how I fixed that but not nowthing is getting posted in my forums, someone please help.


Nothing is updating, please help.

Everything is enabled - cronjob and all the php functions needed

CronJob:
/usr/local/bin/php -q  /home/neph/public_html/forums/cronrss.php

Feeds: Validated
http://www.logicalfear.com/rss-articles/ [nofollow]
http://nephariusepidemics.com/feeds/rss.xml?alt=rss [nofollow]

When I run manually:
http://nephariusepidemics.com/forums/cronrss.php [nofollow]

I get the page that says: Feed Poster configuration
And nothing updates on my forums.

I get the email from cronjobs saying:
Could not open input file: /home/nephariu/public_html/forums/cronrss.php

Are you sure it is the right path / permissions?

nepharius

Oh man at all my typos on that update lol.

Well yeah I fixed the path instead of home it was home2, I have the cronrss.php as 755 for permissions.

Maybe I should try different feeds like from a news site?   
What does -q mean?  I just used the code from here as it and I dont know what -q is.

itisme1760

-q means that it allows the script to utilize the php functionality.

nepharius

October 12, 2008, 01:14:15 AM #1057 Last Edit: October 12, 2008, 02:33:29 AM by nepharius
I added a cnn rss feed and its still not working

The Saviour

This mod used to work...and no longer does.

I have SMF 1.1.6 installed and have used the Package Manager to install this mod successfully.

The fopen, fsockopen and curl php scripts that need to be used for this to work are only available to those whose servers run PHP 5.1 and above.  I am using 5.1.

I have "All" selected in the settings of this mod for the feed from SnapFiles I'd like to use...yet the mod does not parse the feed.

This mod has since been uninstalled and reinstalled several times with no issues on the install.  It just doesn't work.

I have removed the tables...reinstalled...optimized...checked for errors...and still no go.

Unfortunately, there seems to be a problem with this new version...unless I'm totally missing something here.

When I run the cronrss.php file...NOTHING.

Anyone have any clue about what's going on with this mod?

Thanks for the help...

The Saviour

Good luck finding free help here...

You're probably better off paying someone...

I really don't mean to sound rude...and I know we all have our own lives to lead...but where's the support?

I have another thread where I asked for help...got a couple of replies...then they leave you hanging...

I guess I'd be better off going back to vBulletin...so what if I have to pay for the license...at least the support is better there than it is here.

~Signed...

One dissatisfied customer

P.S.  What do you expect for nothing?

That ought to get me some support, huh?  LMAO! ;D

Advertisement: