• Welcome to Simple Machines Community Forum. Please login or sign up.
September 18, 2021, 04:53:14 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

tsmalmbe

OK, which functions manipulate the strings? where should I start looking for the problem? You don't have anything like a sequence-diagram, which would make it a lot easier to "see" what's going on?
..:: http://www.kontrollrummet.com - Studio och musik ::.. RSS?

3nd3r

To add  more light to my problem (hope help others too), I see this on error log:

.../index.php?action=feedsadmin;sa=admin

Can't load language file 'FeedPoster.spanish'.

vbgamer45

I will tell you will need to look at htmlspecialchars function i use that to strip invalid input on any entered information.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Niteblade

Quote from: nite0859 on March 13, 2007, 02:15:43 AM
I'm attempting to grab the news from a local television station so that my users can comment on the news inside my forum.

The RSS Feed is this :: http://www.kwes.com/Global/category.asp?C=83261&clienttype=rss

However, the RSS Feed Poster Mod does not / cannot / will not recognize the feed in order to grab the feed in order to post the feed. I know the mod works perfectly for the RSS from my directory.. here's the thread on my forum that I use to grab feed from SMFoogle.com :: http://forum.midessa.net/the-smfoogle-network-site-showcase-b77.0/ ..

Is the feed screwed?

Nevermind. I figured this one out.

Problems getting a feed to read ?
Input the problem feed into :: RSSMix. And combine it with your own cocktail of unique feed(s) while you're at it.

Ths mod couldn't read the direct feed from :: http://www.kwes.com/Global/category.asp?C=83261&clienttype=rss . However, when this particular feed was put into RssMix, it can now be read.

Demo: http://forum.midessa.net/local-news-headlines-b86.0/
affiliate blog

cybertelecom

hi,

I've install this mod, no problem with the installation, but after I add rss feeder, my site is hang. I cannot open my site at all, even index.

what should I do ???

this is my site
http://www.foruminsiyur.com


cybertelecom

got the problem, fake cronjob

I open the index.php, delete the mod manually, go to admin, un use fakecronjob, reinstall the mod manually.

great mod !
thanks

Gourgi

First of all thanks to VB for another useful mod !
You rock man ;)

i tried several feeds and they all worked well.
It even displays greek characters without problem (i don't know if they are UTF-8 or not)

The only problem with this mod is that fakecron hangs my forum also , i 'll try real cron instead!

(ouf ! i already read the previous 24 pages !! )

Thanks again VB.
I'm looking forward to an inspired update :)
Όσο ζώ, μαθαίνω ...

NativePages

Question:  Over the last week, I had numerous "spam" posts (porno links), despite having the wiki_blacklist set up, etc.  The reason I'm posting here is because all of the spam posts but one were in the top 2-4 posts of newsfeed posts (the 1 was a weak attempt at a spam on Ultimate Shoutbox that didn't succeed), which leads me to believe that something in my newsfeeds is attracting the little beasts.

In response to each post, I've done the gamut:
Check the whois and ban the appropriate IP/IP range
Add the link site domains to the blacklist txt file manually
Add the faked user names to the "reserved names" list

The bots switched IP ranges almost as fast as I banned them. I finally had to go into newsfeeds and literally set all of them to locked topic.  The bots kept trying for another 24 hours, then finally gave up (knock on wood). 

I'm just wondering if it IS something in the newsfeeds that's attracting them or allowing them to slip past all the other security devices.

NP
http://www.nativepages.com/tnindian
I came, I saw, I installed, I asked a million questions, but eventually I got it!

kivelo

Quote from: Buster.de on March 12, 2007, 08:23:07 AM
Attached Subs-RSS.php works for me...

Hi there, first of all thank you for taking the time to do this, and to vbgamer for an excellent mod. I was having formatting errors with apostrophes and quotes until I uploaded the modified subs-rss file.

But now I am having another issue, and that is the following error messages being generated in the logs for all users:

8: Undefined index: description
File: .../public_html/smf/Sources/Subs-RSS.php
Line: 417


Instead of "description", it also says "title" and "link". And this one:

8: Undefined offset: 0
File: .../public_html/smf/Sources/Subs-RSS.php
Line: 409


Anyone know how I can fix this or what it means? I'm not even sure if users are seeing it as no one has complained yet.

Thanks!

vbgamer45

User's wont see that erorr that error is a tricky one not sure how to fix it sometimes it occurs.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

subfighter

It would be nice option to add to display the the RSS Feed News Page. In an IFRAME directly in the page as it causes much more traffic for your site.. I just currently are converting my PHPBB forum over and looking for the features i had on my old board... I had a similiar mod but it embedded the RSS Feed Page Into the Forum Page so people could discuss and talk about it...

Here is a link to my current board and how it looks.
http://www.subfighter.com/ftopict-50151.html [nofollow]

This would be a nice option have available..

regards
rick

voelspriet

Fresh install on a fresh server results in:


Fatal error: packageinstall() [function.require]: Failed opening required '/home/vista/domains/webnwalkvista.com/public_html/forum/Packages/temp/./FeedPostersql.php' (include_path='.:/usr/local/lib/php') in /home/vista/domains/webnwalkvista.com/public_html/forum/Sources/Packages.php on line 552

Suggestions?

Metalstein

X-Powered-By: PHP/4.4.4
Set-Cookie: PHPSESSID=f73226b01655d591d2bc59dd850c1f56; path=/
- Hide quoted text -
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Pragma: no-cache
Cache-Control: private
Content-type: text/html

Feed Poster Configuration


Getting that every 5 minutes(thats my cron job time limit). It's emailing that to me. Also, even though I've got the feed to use a name that exists, it still posts under guest.

Using SMF 1.1.2

tsmalmbe

Quote from: Metalstein on March 22, 2007, 05:18:10 PM
Getting that every 5 minutes(thats my cron job time limit). It's emailing that to me.

"It" being cron? That's proof cron is working correctly. If you wish to modify cron behaviour, just google or use "man cron".
..:: http://www.kontrollrummet.com - Studio och musik ::.. RSS?

Metalstein

it's working fine? alright thank you.

Matthew Schenker

THIS MODIFICATION HAS CRASHED MY ENTIRE SITE!

I installed this modification, and asked it to run a cron job.  My forum locked up and now is totally inaccessible.  Luckily, I am running it on a test forum.  But my test forum is now down.

Can someone tell me how to recover from this?

Enigma

Quote from: Matthew Schenker on March 24, 2007, 05:58:15 PM
THIS MODIFICATION HAS CRASHED MY ENTIRE SITE!

I installed this modification, and asked it to run a cron job.  My forum locked up and now is totally inaccessible.  Luckily, I am running it on a test forum.  But my test forum is now down.

Can someone tell me how to recover from this?

What do your error logs say?

Freddy888

Just for the record I got this running on 1.1.2 alongside TinyPortal 0.98.

I didn't know about Cron jobs before, but I get the idea.  Is there something I am supposed to do with the cronrss.php , like does it have to be in a certain place.  Or do I have to enable it in some way?

Reason I ask is I want to use a few bots to post news, but obviosly running a fake cron slows down the forum a bit when it checks the rss every page.

Please can someone give me an idea of what to do regarding the real cron job.

Thanks.

Great Mod :)

Matthew Schenker

March 25, 2007, 09:51:04 AM #358 Last Edit: March 25, 2007, 09:53:21 AM by Matthew Schenker
QuoteWhat do your error logs say?

Oh my, I'm glad you asked!!!!

My error logs are filled with the following message, reported every minute for the past 24 hours:
File does not exist: /home/festool/public_html/404.shtml

Or some other varieties of "File does not exist."

My site is still down.

vbgamer45

Remove this from index.php

// RSS Feed Poster run fake cron job
if (!empty($modSettings['rss_fakecron']))
{
require_once($sourcedir . '/Subs-RSS.php');
UpdateRSSFeedBots();
}


And turn off any corn jobs.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Advertisement: