• Welcome to Simple Machines Community Forum. Please login or sign up.
September 22, 2021, 04:46:07 AM

News:

Check out the SMF Function DB!


RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

Lemming

Hm  :o Yesterday, I had problems with the url. I got error mails that the file was not found. And when I used the url in my browser, I got some errors. Then, I activated the cron job with the '/home/www/...' url - error mails. Today, I activated the cron job again with the direct url - no problems :D I also get no errors anymore in my browser.
Maybe because I use no "http://www." anymore  (in the cron tab url)?

L.G.S

Got the exact same thing even after trying that ^^

/bin/sh: ruthlessintent.com/board/cronrss.php: No such file or directory
FREE and LIVE World Cup + Premier League football streams:

www.gamesandgoals.com


husam

CAN SOMEONE TELL ME WHAT THE HELL IS THIS ERROR?

http://img517.imageshack.us/img517/5990/untitledpy7.png

it doesn't work!

L.G.S

looks like the database part of the install didnt do it
FREE and LIVE World Cup + Premier League football streams:

www.gamesandgoals.com


husam


jorgejorge

I have the 4 documents in my computer, what I have to do to set up it in my forum??

Thank you.


Pratt

Quote from: MegaTinkerCoder on April 19, 2007, 08:20:29 PMI wish the feeder posted the whole rss feed instead of a snippet, but I haven't had time to investigate that myself.
Any Luck with that? ive been playing around with my Subs-RSS.php, but im still getting a little snippet of the Feed, mostly with Feedburner. While lookin to the rss feed directly in Feedburner i can se the whole Message, but when i bring the same feed to my forum, i still get just a little snippet...

meepo88

OK...for those of you out there confused about cron--

this command was the ONLY one that would work on
my hosting company...

lynx --dump hxxp:www.YOURDOMAIN/YOURFORUMDIRECTORY/cronrss.php [nonactive]

Hope this helps people in the future.

;)

distortedice

Works perfect, installed it and it worked straight outta the box. About 3 mins to get it up and running and posting. No complaints here :) Now to see how long it takes for my users to figure out they're talking to a robot ;)

distortedice

A day has gone by and my users are happily talking to a robot  ;D teeheehee  ;)

Sarge

June 01, 2007, 01:25:38 PM #451 Last Edit: June 01, 2007, 01:34:32 PM by Sarge
If this mod doesn't work and in Admin > Forum Error Log you get an error similar to this:

fopen() [<a href='function.fopen'>function.fopen</a>]: URL file-access is disabled in the server configuration
File: [path]/Sources/Subs-RSS.php
Line: 25

you could use this function (requires the CURL library, which is reported to be more reliable and to give higher performance -- see the link below):


/*
   * @return string
   * @param string $url
   * @desc Return string content from a remote file
   * @author Luiz Miguel Axcar (lmaxcar@yahoo.com.br)
*/

function get_content($url)
{
    $ch = curl_init();

    curl_setopt ($ch, CURLOPT_URL, $url);
    curl_setopt ($ch, CURLOPT_HEADER, 0);

    ob_start();

    curl_exec ($ch);
    curl_close ($ch);
    $string = ob_get_contents();

    ob_end_clean();
   
    return $string;   
}


This and several other solutions were posted as comments in http://us.php.net/function.fopen, where a way to check for failure to fopen() is also posted.

Or you could use something like this:


$file = "http://somelocation.com/somefile.xml";
$ch = curl_init($file);
$fp = @fopen("temp.xml", "w");
curl_setopt($ch, CURLOPT_FILE, $fp);
curl_setopt($ch, CURLOPT_HEADER, 0);
curl_exec($ch);
curl_close($ch);
fclose($fp);
$file = "temp.xml";
$fp = fopen($file, "r");


Note: ensure that you have write access - so curl can write to temp.xml.

The mod author might want to include the above code in the mod.

    Please do not PM me with support requests unless I invite you to.

http://www.zeriyt.com/   ~   http://www.galeriashqiptare.net/


Quote
<H> I had zero posts when I started posting

vbgamer45

I have actually three wasy first it tries fopen next fsockopen and last curl.

Curl is untested since I do not have that module installed
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

last19

mysite hosted by godaddy and they said our hosting have Curl support. But it gives error "Unable to download the feed."

They are the links about curl
http://help.godaddy.com/article.php?article_id=288
http://help.godaddy.com/article.php?article_id=285
http://help.godaddy.com/article.php?article_id=286


Sarge

Quote from: last19 on June 02, 2007, 02:58:49 PM
But it gives error "Unable to download the feed."

Did you try the mod or the sample code from GoDaddy? The sample code connects to the Paypal site, which I believe had some problems during the last few days.

    Please do not PM me with support requests unless I invite you to.

http://www.zeriyt.com/   ~   http://www.galeriashqiptare.net/


Quote
<H> I had zero posts when I started posting

last19

i tried the mod. i didnt try anything from godaddy because i dont understand what they wanna say :=)

distortedice

I've had a hunt through this forum, but I can't see any way to make the bot post in only one topic. I don't really want a brand new topic for each posting, just a new post within the same topic. Hopefully someone can help :)

And thanks for the cool MOD :) Only one of my users seems to have picked up on the fact that it's a bot and that was coz it posted five brand new topics within about two seconds!

Ryan,

last19

Anybody have any ideas for Godaddy?

Polymath

June 10, 2007, 12:25:29 AM #458 Last Edit: June 10, 2007, 12:46:06 AM by Polymath
OK. Hi all.

I have installed this on my test site as a trial. Everything points to it looking operational..but....

I added the Simple Machines feed. http://www.simplemachines.org/community/index.php?action=.xml

It says enabled.

I done a cron job at my host (Lunar) set it for 5 minutes to see if it works.

Anyway...I am getting nothing.

I have no errors

What maybe wrong?

When I go to http://www.yourforums.com/cronrss.php I get

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@yourforums.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request
.

What do I need to know to fix that. Permissions on cronrss.php are 666

Or what do you need to know to help me.
* I don't suffer from insanity; I enjoy every minute of it. *
F.I.G.J.A.M

Polymath

June 10, 2007, 12:58:49 AM #459 Last Edit: June 10, 2007, 01:20:57 AM by Polymath
Ok. I finally got an email from the cron job.

/bin/sh: http://www.gstestsite.ezmnetwork.com/cronrss.php: No such file or directory

But it is there. Whats up with that?

EDIT: changed permissions from 666 to 755. Maybe that helps because its now showing Feed Poster Configuration

What am I supposed to see if I go to http://www.gstestsite.ezmnetwork.com/cronrss.php
* I don't suffer from insanity; I enjoy every minute of it. *
F.I.G.J.A.M

Advertisement: