• Welcome to Simple Machines Community Forum. Please login or sign up.
September 18, 2021, 04:03:15 PM

News:

Join the Facebook Fan Page.


RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

vipmoney

Hi Irmie,

Quote from: imrie on August 21, 2007, 05:32:50 PM
This is not working at all.

It wont do 2 feeds and it has now stopped doing the one feed. How so i correct this?

Forum: mysimtractor.com/forum

Details:

fsockopen: disabled
fopen: enabled
CURL: enabled

I have 10 feeds working ok, so it should work.

Quote from: imrie link=topic=141776.msg1211324#msg1quote author=imrie link=topic=141776.msg1211401#msg1211401 date=1187776786]
Just noticed that even if it is in the form "Member" it will change to Member,  This is still not working. In the download there are .xml files but they are not on the server, is this a problem?
211324 date=1187772021]
In the config does the poster name have to be like this:

"Member" or Member

Thanks,
[/quote]

It works both ways, you can just write the name, or you use the search function.

Quote from: imrie on August 22, 2007, 05:59:46 AM
Just noticed that even if it is in the form "Member" it will change to Member,  This is still not working. In the download there are .xml files but they are not on the server, is this a problem?

The problem is probably with your feed... try adding it to feedburner.com, use the optimize options in there, and try adding the new feedburner feed instead, I've corrected some feeds this way.
VipMoney

imrie

August 23, 2007, 05:06:51 PM #521 Last Edit: August 23, 2007, 05:18:50 PM by imrie
But they are not my feeds, am i allowed to add them to feedburner?

I get the same error with the feedburner:

"http:///forum/index.php?action=feedsadmin;sa=addfeed2 

8: Undefined offset: 23
File: /home/fhlinux164/m//user/htdocs/forum/Sources/Subs-RSS.php
Line: 130 "


Thanks,

vipmoney

Yes, you are allowed ;)

Hum.... can you post the feed here?
VipMoney

imrie

http://newsrss.bbc.co.uk/rss/newsonline_uk_edition/uk/rss.xml

http://newsrss.bbc.co.uk/rss/newsonline_uk_edition/front_page/rss.xml

http://newsrss.bbc.co.uk/rss/newsonline_uk_edition/technology/rss.xml

http://newsrss.bbc.co.uk/rss/newsonline_uk_edition/scotland/rss.xml

http://www.eldis.org/newsfeeds/rss/2/agriculture.xml

http://newsrss.bbc.co.uk/rss/newsonline_uk_edition/uk/rss.xml

http://digg.com/rss/index.xml

http://www.economist.com/rss/news_analysis_and_views_rss.xml 

The digg one gets this error:


2: fopen(http://digg.com/rss/index.xml) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: HTTP request failed!
File: /home/fhlinux164/m//user/htdocs/forum/Sources/Subs-RSS.php
Line: 25

the rest get this:

"http:///forum/index.php?action=feedsadmin;sa=addfeed2 

8: Undefined offset: 23
File: /home/fhlinux164/m//user/htdocs/forum/Sources/Subs-RSS.php
Line: 130 "





http://feeds.feedburner.com/Mysimtractorcom


slackerpunk

just a quick question which is better to use real cron or fake cron jobs using php in terms of cpu usage? does a real cron eat less resources?


vbgamer45

Quote from: slackerpunk on August 27, 2007, 09:20:40 AM
just a quick question which is better to use real cron or fake cron jobs using php in terms of cpu usage? does a real cron eat less resources?


Real cron job is better for performance.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

slackerpunk

when you say perfomance you mean it would use less resources right?

vbgamer45

Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

slackerpunk

i forgot to ask when I use real cron which will be followed the time I set in my cron job or the one I set on the settings?

vbgamer45

The cron job is time that it is checked. The one in the settings is time for each feed. The cron sends a request to the script if the feed has past it time it tries to download more feed items.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

imrie

vbgamer, im still getting all these errors, what can i do?

vbgamer45

Try to get fsockopen enabled that is the only officaly supported method at this time.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

imrie

the host said no. But it was working before, i dont know why it just stopped; i had uninstalled it and reinstalled it and now it does not work.

BioCarbon13

where
Quote from: vbgamer45 on January 11, 2007, 07:46:04 PM
Link to Mod

Using the following file
hxxp:www.yourforums.com/cronrss.php [nonactive]


I'm sorry for a naive question, but where can I find cronrss.php file?

Dozzer

August 30, 2007, 12:52:24 PM #534 Last Edit: August 30, 2007, 01:01:08 PM by Dozzer
Excellent mod btw.. well cool...

But on smf I get the following error when running the cronrss.php

http://whatson.110mb.com/forum/cronrss.php

QuoteWarning: fopen() [function.fopen]: URL file-access is disabled in the server configuration in /www/110mb.com/w/h/a/t/s/o/n/_/whatson/htdocs/forum/Sources/Subs-RSS.php on line 314

Warning: fopen(http://groups.google.com/group/Google-Maps-EZ/feed/rss_v2_0_topics.xml) [function.fopen]: failed to open stream: no suitable wrapper could be found in /www/110mb.com/w/h/a/t/s/o/n/_/whatson/htdocs/forum/Sources/Subs-RSS.php on line 314
Feed Poster Configuration


Line 314:  $fp2 = fopen($url, "r");

Any ideas ?

It's working AFAIK on the "fake" chron job.. but my SMF error log is filling up rapidly!

How do I fix this.. ?
btw.. fopen url disabled, fsockopen enabled and CURL installed and tested.
Be a Sorted Student...
www.sortedstudents.co.uk

czechmate

I am fairly sure I've read every post in this thread, and yet somehow the answer isn't clear to me...

I'm installing this very useful mod on my site's forums, but have trouble at the point of install.  Here's what happens:

1 - I upload the package via the built-in packages manager.  Seems fine...
2 - Click on "APPLY MOD" from list of available packages.
3 - Get following box:

QuoteInstalling this package will perform the following actions:
   Type    Action    Description
1.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test successful
2.    Execute Modification    ./index.php    Test successful
3.    Execute Modification    ./Sources/Subs.php    Test successful
4.    Extract File    ./Sources/FeedPoster.php    
5.    Extract File    ./Sources/Subs-RSS.php    
6.    Extract File    ./cronrss.php    
7.    Extract File    ./Themes/default/FeedPoster.template.php    
8.    Extract File    ./Themes/default/languages/FeedPoster.english.php    
9.    Extract File    ./Themes/default/languages/FeedPoster.english-utf8.php    
10.    Execute Code    FeedPostersql.php

4 - It asks me if I want to install it anyway, so I go ahead and install it.
5 - Redirected to Forum Index
6 - No link for Feed Poster Configuration exists...

I'm on SMF 1.1.3
I've installed this successfully on other sites

Is there any permissions issues with this mod?  What should my files be set to?  R/W  or 755?

Thanks for any assistance in this matter...  If any other information is required, I'll be happy to post it.

Dozzer

Quote from: Dozzer on August 30, 2007, 12:52:24 PM
Excellent mod btw.. well cool...

But on smf I get the following error when running the cronrss.php

http://whatson.110mb.com/forum/cronrss.php

QuoteWarning: fopen() [function.fopen]: URL file-access is disabled in the server configuration in /www/110mb.com/w/h/a/t/s/o/n/_/whatson/htdocs/forum/Sources/Subs-RSS.php on line 314

Warning: fopen(http://groups.google.com/group/Google-Maps-EZ/feed/rss_v2_0_topics.xml) [function.fopen]: failed to open stream: no suitable wrapper could be found in /www/110mb.com/w/h/a/t/s/o/n/_/whatson/htdocs/forum/Sources/Subs-RSS.php on line 314
Feed Poster Configuration


Line 314:  $fp2 = fopen($url, "r");

Any ideas ?

It's working AFAIK on the "fake" chron job.. but my SMF error log is filling up rapidly!

How do I fix this.. ?
btw.. fopen url disabled, fsockopen enabled and CURL installed and tested.

Ok sorted the error.. by commenting out the fopen sections "//"

But, I'm still getting an error on the forum log as follows:

8: Undefined offset: 1
File: /www/110mb.com/w/h/a/t/s/o/n/_/whatson/htdocs/forum/Sources/Subs-RSS.php
Line: 354

Line 354 area:

352    // Get rid of the stupid header information! Wish the function did it for me.
353      $rss2 = explode("\\r\\", $rssdata);
354      $finalrss = $rss2[1];

It appears not to be working..   

Anyone got any ideas on this ?
Be a Sorted Student...
www.sortedstudents.co.uk

Neelay

Hi. I wanted to know if there is a way to remove the <p> tags from the rss post. I've two feeds which has this, and with html off or on, this text is entered "<font size="2"><strong>SHAHNAZ HUSAIN</strong></font>" with <p> tags. I also tried to censor <p>, or the full text above, but the censor word list doesn't accept this, and doesn't censor this. Thanks in adv

imrie

Quote from: Dozzer on August 30, 2007, 05:17:45 PM
Quote from: Dozzer on August 30, 2007, 12:52:24 PM
Excellent mod btw.. well cool...

But on smf I get the following error when running the cronrss.php

http://whatson.110mb.com/forum/cronrss.php

QuoteWarning: fopen() [function.fopen]: URL file-access is disabled in the server configuration in /www/110mb.com/w/h/a/t/s/o/n/_/whatson/htdocs/forum/Sources/Subs-RSS.php on line 314

Warning: fopen(http://groups.google.com/group/Google-Maps-EZ/feed/rss_v2_0_topics.xml) [function.fopen]: failed to open stream: no suitable wrapper could be found in /www/110mb.com/w/h/a/t/s/o/n/_/whatson/htdocs/forum/Sources/Subs-RSS.php on line 314
Feed Poster Configuration


Line 314:  $fp2 = fopen($url, "r");

Any ideas ?

It's working AFAIK on the "fake" chron job.. but my SMF error log is filling up rapidly!

How do I fix this.. ?
btw.. fopen url disabled, fsockopen enabled and CURL installed and tested.

Ok sorted the error.. by commenting out the fopen sections "//"

But, I'm still getting an error on the forum log as follows:

8: Undefined offset: 1
File: /www/110mb.com/w/h/a/t/s/o/n/_/whatson/htdocs/forum/Sources/Subs-RSS.php
Line: 354

Line 354 area:

352    // Get rid of the stupid header information! Wish the function did it for me.
353      $rss2 = explode("\\r\\", $rssdata);
354      $finalrss = $rss2[1];

It appears not to be working..  

Anyone got any ideas on this ?

Exact problem as me, both the same errors.

Dozzer

September 01, 2007, 05:50:21 AM #539 Last Edit: September 01, 2007, 11:03:04 AM by Dozzer
Regarding the error:

: Undefined offset: 1
File: /www/110mb.com/w/h/a/t/s/o/n/_/whatson/htdocs/forum/Sources/Subs-RSS.php
Line: 354


It appears that the array created by&nbsp; &nbsp; $rss2 = explode("\\r\\", $rssdata);

$rss2[1] appears to be blank - empty., thereby giving the undefinded offset ( [1] )

Echoing the output of&nbsp; $rss2[0] produces a large string of xml... yet $rss2[1] appears blank.

Anyone got any ideas on how to get this working ?

My RSS feed is:&nbsp;

http://groups.google.com/group/Google-Maps-EZ/feed/rss_v2_0_topics.xml

Here is the problem code area: lines 352 to 356

Quote// Get rid of the stupid header information! Wish the function did it for me.
   $rss2 = explode("\\r\\", $rssdata);
   $finalrss = $rss2[1];

    return&nbsp; $finalrss;

$finalrss is a blank string...

If I comment out the "explode" bits above.. should it work ok ?
Be a Sorted Student...
www.sortedstudents.co.uk

Advertisement: