• Welcome to Simple Machines Community Forum. Please login or sign up.
September 22, 2021, 02:01:56 PM

News:

Wondering if this will always be free?  See why free is better.


RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

TrueSatan

Please note we reply to forum postings on this forum. Your hosting may not be set up in a way such that this mod can work, fsock may not be enabled for instance. The mod may not be set up properly on your forum or the feed you are trying to use may not be a valid one (either not existing or containing invalid characters that make it unusable)...there are a number of possibilities.

Kolhapur

Hello TrueSatan,

          Which link is required in smf forum feed poster configuration.

TrueSatan

 To be honest my own hosting doesn't allow fsock open so I can't install and use this mod to debug things for you...that said the feed links you would use would be .rdf, .xml, .rss in type. You would need to find a suitable feed and it would be as well if you used a validator to check it. As an example the feed offered by SMF at the bottom of this page is shown as xml http://www.simplemachines.org/community/index.php?action=.xml

Kolhapur

Hello Sir,

   I tried for .xml link for this purpose I used     http://www.rediff.com/rss/perfinrss.xml [nofollow] this url but it's not working.There is not any error also.

TrueSatan

Have you checked you hosting to see that fsock is enabled...if it isn't the mod won't work. BTW rediff.com is on some of the lists of malware or ad serving sites I use so I am unwilling to check that link. It may be that your host has it blocked too.

Kolhapur

Hello my host is showing fsock enable then what to do now.Which link is required ....what is the problem.

Kolhapur

Hello VBGAMER,

           Your package not working on my host so which link is required to pass the in add feed section. I tried well but this package not responding.So pls replay with a proper solution.

Kolhapur

Hello VBGamer sir,


                  u there??????????????

taurean


Hi,

1.My web site feeds are showing live links ( i have hidden mp3 urls in my site). even when i connect thru the feeds i am able to see the posts & urls for download without logging into the forum.

2. How to hide the author of the post from the feed.

thanks in advance
Eager to Learn SMF

thapame

How can I cut off/ignore any html tags/code for all or specific member on SMF 1.1.4 with this mod.
i mean html tags like <td></td><a></a><img> etc

please let me know what should I do as while using this mod some of the post get posted with all the html code stuffs.

allumius

October 02, 2007, 01:23:27 PM #570 Last Edit: October 03, 2007, 05:46:03 AM by allumius
Sorry for my english

I'm using 1.1.3

Using Real Cron jobs no post and if i try http://losamigotes.homelinux.org/forum/cronrss.php
QuoteFeed Poster Configuration
nothing more

If i use fake cron jobs, I have three problems:

1º i have Update every x minutes 100
But every 5-10 min. a feedpost is write in the forum

2º i have post duplicated (see imagen)

3º in to the feedpost i have bizarre text. example:
QuoteMerck cerrará el Laboratorio de Investigación


La decisión deja a España sin uno de los pocos centros no dependientes de los fondos públicos que se dedicaba a la investigación básica.&nbsp;




rockinaway

I got a problem. HTML is showing, and not getting converted to BBCode.. e.g: http://adminfuel.com/drupalsecurity_updates_and_bugfixes_available_drupal_52_and_477_released-t772.0.html

Any way to do this?
Have I helped you? Then please join AdminFuel - The forum for forum administrators.

If you need help managing your forum, or maybe launching it, then visit us and view the quality articles, downloads and posts.

Kolhapur

Hello Sir,

I used the cron job component is working but i am getting the following error

: Lost connection to MySQL server during query
/home/content/q/v/e/qveda/html/forum/Sources/Load.php
1165


So what to do now.

Kolhapur

Hello Sir,

Some time it gives "this service is temparary unavaliable." or "connection problem" as like errors getting by giving .xml link and cron job.So what to do now.

TrueSatan

This looks to be a problem that isn't due to the mod so short of changing your hosting I don't think there's much else that you can do. Unfortunately, and for whatever reason, your host doesn't appear to be able to reliably complete the query sent to it from the mod but given that it can do the task at other times you can be reasonably certain that it is a problem with the hosting not the mod.

tsmalmbe

Another solution to the problem with non-US characters. The other solutions here have not worked for me (for instance, iconv does not exist in my php). Anyway, here goes something that has been tested with swedish and finnish characters ("nordic" that is).

Subs-RSS.php

// Create the Post
$msg_title = htmlspecialchars(($feed['html'] ? $context['feeditems'][$i]['title'] : strip_tags($context['feeditems'][$i]['title'])), ENT_QUOTES);
$msg_title = mb_convert_encoding($msg_title, "UTF-8", mb_detect_encoding ($msg_title, 'UTF-8, ISO-8859-1, ASCII'));
$msg_body =  htmlspecialchars(($feed['html'] ? $context['feeditems'][$i]['description'] . "\n\n" . $context['feeditems'][$i]['link']  : strip_tags($context['feeditems'][$i]['description'] .  "\n\n" . $context['feeditems'][$i]['link'])), ENT_QUOTES);
$msg_body = mb_convert_encoding($msg_body, "UTF-8", mb_detect_encoding ($msg_body, 'UTF-8, ISO-8859-1, ASCII'));


What does it do? It tries to detect what encoding the incoming text has, and then converts it to UTF-8. If your forum is running on some other encoding, then just change the destination encoding scheme in the code above (second parameter in mb_convert_encoding). This works with mixed feeds that are ISO-8859-1 and UTF-8 - all result in proper characters in UTF-8. If you have an exotic character-set, just add it to the list in the mb_detect_encoding-function.

Hope this solves something for someone.
..:: http://www.kontrollrummet.com - Studio och musik ::.. RSS?

rockinaway

I get 3 pages worth of errors in the error lock with problems with the fopen on line 314 in Subs-RSS... what could be the problem?
Have I helped you? Then please join AdminFuel - The forum for forum administrators.

If you need help managing your forum, or maybe launching it, then visit us and view the quality articles, downloads and posts.

TrueSatan

Server misconfiguration. When I've seen such errors that has been the reason for them.

rockinaway

My host provides cURL which is already used in the top half of the file. I used this to stop all errors shown in error log..
Have I helped you? Then please join AdminFuel - The forum for forum administrators.

If you need help managing your forum, or maybe launching it, then visit us and view the quality articles, downloads and posts.

westis

It seems like the mod truncates the text from the blog and only posts the beginning of the text in the forum. How can I have the entire blog post be posted in the forum?

Btw, the feed doesn't truncate, it shows the entire blog post.

Thanks!

Advertisement: