• Welcome to Simple Machines Community Forum. Please login or sign up.
September 18, 2021, 04:46:31 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

Garou

December 13, 2008, 04:42:22 PM #1200 Last Edit: December 13, 2008, 10:55:24 PM by Garou
What you described sounds similar to some of the issues people were having with the fake cron. If your using a cronjob make sure fake cron isn't enabled.

Outside of that I have to agree with Smoky that its most likely in the feed itself.


On a side note...
Those that were wondering what the differences are between the newest upload and the last...
I compared the two files with WinMerge and they are completely identical. So all the problems we had before we should be having now. Sorry all. :(

TheDisturbedOne

Quote from: Zepia1 on December 13, 2008, 03:06:40 AM
I installed this the other day and everything went smooth, posts started showing but then it just stopped posting, i haven't changed a thing, any help?
Same here.  How often should I run the crons?  I have the crons set to 1 hour and the feeds are different (ranging from one hours to 6 hours).  It posted twice (2 different feeds) then didn't post again.  I checked and theres still stuff showing on the RSS feed.

Smoky "Rider" Blue

a slow feed will slow your poster..

alos you can set it as high as you want.. one hour to 8, hours either way..

but you must remember, you are at the rss feeds mercy..  ;)
**Take the time to remember friendships and family.. Sometimes it's all we have, and missed very much**

TheDisturbedOne

Well everything shows up on the feed, but it doesn't get posted.  This has to do with my crons right?

Smoky "Rider" Blue

mmkay..

so the feeds you have, you verified each one and they are producing feeds correct?

then check your cron, is it the fake or in the cpanel area?

if its the cpanel, do you have  the timing, dates and months set to at least once a day??

can you take a image of the cron job you have set up in the cpanel?

if this helps, here is a snapshot of mine.. let me know.. ;)
**Take the time to remember friendships and family.. Sometimes it's all we have, and missed very much**

MamaFriend

December 15, 2008, 10:18:26 AM #1205 Last Edit: December 15, 2008, 10:36:10 AM by MamaFriend
Hi.  I'm in the same boat.  I started a new forum (mamafriend was my first forum for my wife).

The new forum is FantasyFullback.com

Anyhow,  I installed the mod to the default theme using 1.17, and used the fake cron jobs.  It went perfect, posted away. 

I then went to add more feeds, and didn't like how the HTML was posting, so I edited a few options, added a ton more feeds, and NOTHING.  I got no new posts.

Someone mentioned a problem with the fake cron jobs?  I have cpanel hosting, and can set up a real cron job, how do I do so?  Do I just enter the cron job url plus timing settings, or is there a specific code string plus the url that I need to enter....?

I apologize, I'm getting better at this as I go, but I'm still figuring things out.  I've been an HTML coder and mostly graphic design forever, so PHP is newer to me.

Any help would be awesome.  I'm assuming the fake cron option is just wacky, and I need to set up a real cron on cPanel.

Thanks.

EDIT:  Oh, one more thing, not a big deal, just ultra annoying:

Using the default theme, the link to the RSS feed options didn't show up, there is a space for it, just no clickable link, so I had to bookmark the URL to access it each time, quite annoying.  I read over the install files and didn't see where in the code it should have been placed?  Any help would be awesome, thank you.

c3lt1957

December 15, 2008, 11:31:30 AM #1206 Last Edit: December 15, 2008, 11:34:25 AM by c3lt1957
Hi,

This is what I did to get it working mate !

Access your Cpanel and scroll to the bottom of the page where you should find "cron jobs" If not there then request your hosting company to enable it for you.
Add what is in blue below to your cmd line, obviously adjusted with your own details. You will also need to set the timings for updates, but that is fairly straight forward ie I set mine to every 4 hrs, * (=everyday), *(=every week), *(=every month). You will see the relevant boxes for this when you access it through Cpanel.

/usr/local/bin/php -q /home/*******/public_html/forum/cronrss.php >/dev/null 2>&1
Replace the asterix with your details as supplied by your hosting company, "public_html" is my root folder so you may have to change that also if your root folder is different ? After talking to my hosting company it would seem that cron is often disabled by default, so please ensure that yours is enabled. Oh & one last bit of info, the >/dev/null 2>&1 on the end will stop it emailing you everytime it updates...?

I was having great difficulty getting this mod to work, but this is what I did to cure it ! Hope you find it useful

Regards Taffy  ;D
[nofollow]

MamaFriend

Thanks for the quick reply.  I will update and try it.  I will let you know.  Thanks!

MamaFriend

Maybe I'm jumping the gun, as I know sometimes there is a delay, but the first time I set things up it was an instant bot post...

However, I set up the Cron jobs, and looking into my file location, this is the path I used:

/public_html/forum/cronrss.php >/dev/null 2>&1

Nothing happened immediately.  I don't believe I need a more direct address...

Also, in the RSS Feed admin, it shows me this as the Cron Job URL:  http://********.com/forum/cronrss.php, can't I just add that directly? (obviously with the ***** replaced)...

And, what feed download method should I use?  I have it set to ALL.  I'm sure my cron job is enabled, as this Mod worked initially, and I was able to edit cron job...

Thanks


c3lt1957

Ok as I said earlier, this is the command line entry that I used;

/usr/local/bin/php -q /home/*******/public_html/forum/cronrss.php >/dev/null 2>&1
So I would suggest you copy and paste the whole lot & then just remove the asterix & replace with your details. Oh and if you remove /dev/null 2>&1 from the end of the command line, it will email you whenever it triggers. This will either confirm it has carried out the command or it will indicate an error !

Yes for download mine is also set to "all".

Also all the feeds I use have a default 4 hour refresh rate, so this is why I used the 4 hour timings when setting up my cron job.

Finally if my memory isn't playing tricks on me, once setup correctly, if you paste the following into your browser then it should trigger your cron job straight away;

http://www.your-domain.com/forum/cronrss.php [nofollow]

You should then recieve an email saying either it completed the task or there was an error.
Thats about the best I can do on a belly full of Philippino Rhum sorry  ;D

Hope you get it sorted !

[nofollow]



Smoky "Rider" Blue

it just takes a bit of searching thru this thread to find out what exactly to do..

hope you get this sorted MamaFriend, and if not, i would ask your host if the f-sock is open.. as some hosts prefer that it isnt..

also you are dependant on the feeds for your poster..  ;)
**Take the time to remember friendships and family.. Sometimes it's all we have, and missed very much**

MamaFriend

December 15, 2008, 01:47:00 PM #1211 Last Edit: December 15, 2008, 02:02:11 PM by MamaFriend
Thanks.

When I try to point my browser to http://www.your-domain.com/forum/cronrss.php [nofollow] I get an error.

Would I put the direct url into /usr/local/bin/php -q /home/*******/public_html/forum/cronrss.php >/dev/null 2>&1? 

For example, /usr/local/bin/php -q /home/www.fantasyfullback.com/public_html/forum/cronrss.php >/dev/null 2>&1

Or no?  I'm sorry this isn't clicking for me. 

I would just wait it out but when I try http://www.your-domain.com/forum/cronrss.php [nofollow] I get an error, and this is sort of a test...so odds are it isn't working?

Whats odd is that it worked initially?

Also, I have a minutes option, I'm guessing I set that to zero?

Oh, I'm getting a 500 Internal server error and additionally a 404 Not found error

MamaFriend

It was easier than expected, set file permissions to 755, duh.

Thank you everyone for your help!

Much appreciated :)

Smoky "Rider" Blue

glad it worked out for you MamaFriend..

some servers use the 755 and others use 777..

just depends i suggest if anyone has issues to try it all out..

and remember when you are finished and have everything working right, do a full backup of the site...  ;)
**Take the time to remember friendships and family.. Sometimes it's all we have, and missed very much**

TheDisturbedOne

Quote from: SmokyBlue on December 14, 2008, 05:33:01 PM
mmkay..

so the feeds you have, you verified each one and they are producing feeds correct?

then check your cron, is it the fake or in the cpanel area?

if its the cpanel, do you have  the timing, dates and months set to at least once a day??

can you take a image of the cron job you have set up in the cpanel?

if this helps, here is a snapshot of mine.. let me know.. ;)
I have one in cpanel
http://img355.imageshack.us/img355/4007/cronmz9.png

Smoky "Rider" Blue

try this:

http://www.simplemachines.org/community/index.php?topic=141776.msg1810667#msg1810667

as there are a few ways for this to work, if you read thru this thread, they have already been discussed.. ;)
**Take the time to remember friendships and family.. Sometimes it's all we have, and missed very much**

TheDisturbedOne

So
wget -t 4 --delete-after http://www.yoursite.com/forum/cronrss.php
Would be the command to run?

Smoky "Rider" Blue

 :-[ ?? ::)




wget -t 4 --delete-after http://www."place your web sites address here".com/forum/cronrss.php



this is what i have in mine, exactly how i put where the link to my file is.. if this does not work, then you can search the rest of the thread for the other version..

* SmokyBlue wondering why vb isnt answering some of these..  :P
**Take the time to remember friendships and family.. Sometimes it's all we have, and missed very much**

Garou

TheDisturbedOne,

I just tried to run the cronrss.php on your site and it looks like they don't have fsockopen set up on the server listed in your sig. Try setting your Feed download method for curl. Setting it for "All" should skip through to each method if it doesn't work but for some reason it looks like its not.

* Garou gives Smoky a wolfish grin.  ;)


Smoky "Rider" Blue

and if it wont go, you need to talk to your host about it..

if they wont open anything for you, then its time you found a new host..

after all, hhow are you going to run the treasury mod or anything requiring the f sock open??  :P

* SmokyBlue winks back at Garou ;)
**Take the time to remember friendships and family.. Sometimes it's all we have, and missed very much**

Advertisement: