• Welcome to Simple Machines Community Forum. Please login or sign up.
September 18, 2021, 04:24:05 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

nolageek

I noticed that DaBoROE09, is that expected?

DaBoROE09

i thought he fixed that problem.

nolageek

I haven't gotten anything else either.

sipko

Thanks for creating this awesome and most useful mod!

Jump1979man

Quote from: DaBoROE09 on January 13, 2007, 03:53:12 PM
jump try to use fake cron jobs


tried fake cron jobs and that doesnt work either.

DaBoROE09

Jump1979man, then you do not have that function enabled.  i believe from my talks with vbgamer that that function does have to be enabled to work at all.

Edited
The shortest amount of time for the RSS to update is 30 minutes.

thanks

sipko

Using the fake cron jobs made my forum load too slowly. So, I put the http://www.myforums.com/cronrss.php file in and set the permissions to 755. Now it works perfectly with the forum loading as fast as usual.

sipko

Quote from: sipko on January 14, 2007, 02:50:15 PM
Using the fake cron jobs made my forum load too slowly. So, I put the http://www.myforums.com/cronrss.php file in and set the permissions to 755. Now it works perfectly with the forum loading as fast as usual.

Correction. Now it's not working. At first it did, but now it's not. I double checked the feeds to make sure the problem wasn't the feed and it wasn't.

sipko

January 14, 2007, 04:50:53 PM #108 Last Edit: January 14, 2007, 04:54:29 PM by sipko
Got it to work again by putting the feed in the mod and reloading the http://www.myforums.com/cronrss.php and got this message:

Feed Poster Configuration

I'm not sure if that one load makes it work thereafter, but if you load the url in your browser than it works with the cronrss.php file. And, as I experienced, the fake cron job slowed down my forum to a snail's pace.

vbgamer45

Released an Update.
Fixed only downloading 1 feed item now downloads current number feeds.

Added support for FOpen for feeds as well as cURL - cURL is untested though.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

beast24

Hmm.....

Well this seems like a great mod. I just installed it onto my forum and everything works fine.  One thing I don't like though, is that the news items show up as just one huge chunk of information.  It's all just one paragraph which really looks ugly when viewing the post...

Any way to fix this?  Or atleast limit the amount of words posted?

Nice mod :)

vbgamer45

Might be able to limit the words, formatting maybe impove it.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

beast24

Limiting the words should be pretty alright.  To our own preference that is :P  Basically because it still has a link-back to where it's from anyways.

nolageek

I can't get this to work at all.  I'm trying with both a flickr.com feed and a blogspot feed.  Immediately after installing it I get an empty post, then nothing after that.   I have each set to pull 3 entries, update every 30 minutes, Feed enabled, HTML enabled, Topic unlocked.

The Feed URLS are as follows:

http://howtotieatievideo.blogspot.com/rss.xml
http://api.flickr.com/services/feeds/photos_public.gne?id=10372098@N00&format=rss_200

I've tried it with and without fake cron job turned on.  Both times ran cronrss.php manually from the address bar after over 30 minutes.  Still, after that initial blank post... nothing.

Honestly, I don't know if my server has fsockopen enabled - but I believe so.

Any ideas?  I'm using bounceweb as a host, SMF 1.1.1

ankitcs

Quote from: nolageek on January 15, 2007, 02:34:57 AM
I can't get this to work at all.  I'm trying with both a flickr.com feed and a blogspot feed.  Immediately after installing it I get an empty post, then nothing after that.   I have each set to pull 3 entries, update every 30 minutes, Feed enabled, HTML enabled, Topic unlocked.

The Feed URLS are as follows:

http://howtotieatievideo.blogspot.com/rss.xml
http://api.flickr.com/services/feeds/photos_public.gne?id=10372098@N00&format=rss_200

I've tried it with and without fake cron job turned on.  Both times ran cronrss.php manually from the address bar after over 30 minutes.  Still, after that initial blank post... nothing.

Honestly, I don't know if my server has fsockopen enabled - but I believe so.

Any ideas?  I'm using bounceweb as a host, SMF 1.1.1

same prob here.I am trying Blogspot feeds and its givin same prob.

rsdworker

i have problem installing this mod via admin panel = package area

The package you are trying to download or install is either corrupt or not compatible with this version of SMF.

i am running SMF 1.1.1

please give a help - thanks

RvG

Quote from: ankitcs on January 15, 2007, 05:15:02 AM
Quote from: nolageek on January 15, 2007, 02:34:57 AM
I can't get this to work at all.  I'm trying with both a flickr.com feed and a blogspot feed.  Immediately after installing it I get an empty post, then nothing after that.   I have each set to pull 3 entries, update every 30 minutes, Feed enabled, HTML enabled, Topic unlocked.

The Feed URLS are as follows:

http://howtotieatievideo.blogspot.com/rss.xml
http://api.flickr.com/services/feeds/photos_public.gne?id=10372098@N00&format=rss_200

I've tried it with and without fake cron job turned on.  Both times ran cronrss.php manually from the address bar after over 30 minutes.  Still, after that initial blank post... nothing.

Honestly, I don't know if my server has fsockopen enabled - but I believe so.

Any ideas?  I'm using bounceweb as a host, SMF 1.1.1

same prob here.I am trying Blogspot feeds and its givin same prob.

ADD ME :(

vbgamer45

January 15, 2007, 12:17:36 PM #117 Last Edit: January 15, 2007, 12:21:39 PM by vbgamer45
Which version are you using? Are you using the latest one posted 1.0.2?
Feeds with & in the url may cause problems.


Feeds that I use and work for me:
http://digg.com/rss/index.xml
http://news.com.com/2547-1_3-0-20.xml
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

vbgamer45

Does not work for blogspot feeds. http://howtotieatievideo.blogspot.com/rss.xml

Since they are ATOM based.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

buhaychat.com

Installed fine, but I keep getting .. "Unable to download the feed. "

Does that mean the php sockets isn't enabled on my host?

Advertisement: