• Welcome to Simple Machines Community Forum. Please login or sign up.

RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

nolageek

Mine is only posting it once...  that's an odd error.

buhaychat.com

Quote from: vbgamer45 on January 15, 2007, 03:04:32 PM
Quote from: buhaychat.com on January 15, 2007, 02:27:13 PM
Installed fine, but I keep getting .. "Unable to download the feed. "

Does that mean the php sockets isn't enabled on my host?


Yes. Are you running the newest version? Has support for two other methods to download feeds if your host supports it.

Yup downloaded the latest version... what are the other 2 methods?

nolageek

Ok, turning off HTML just has the link displays, I thought that would happen:

men in shirt and tie posted a photo:

http://www.flickr.com/photos/meninshirtandtie/356763969/



I've noticed that other feeds break when there are images in the post.  Anyone have any experience in fixing this?

Jump1979man

Quote from: sanax on January 16, 2007, 02:32:50 AM
A last question from me. Is it possible to have the mod posts the topic only once and not twice as it is at the moment?

I have posted about this once already and it hasnt been answered.

vbgamer45

Quote from: Jump1979man on January 16, 2007, 11:17:32 AM
Quote from: sanax on January 16, 2007, 02:32:50 AM
A last question from me. Is it possible to have the mod posts the topic only once and not twice as it is at the moment?

I have posted about this once already and it hasnt been answered.
It should not post a duplicate post as long as the title and the description of the post are different. I can't recreate that yet.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

nolageek

vbgamer45:  is there anyway that you can get it to strip attributes of tags, or certain tags out?  Like, divs, attributes of img, etc... like, replace <img src="http://blah.com/img.gif" width="100" alt="blah.com" />  with just <img src="http://blah.com/img.gif" />

also, p tags seem to not get processed. 

for example:

http://meninshirtandtie.com/forum/index.php/topic,42.0.html


If I go in and take out all the img style width etc.. the image shows up.

http://meninshirtandtie.com/forum/index.php/topic,43.0.html


Not even sure this is something that can be done. I have a rss parser plugin for wordpress that doesn't have them problem, so not sure if it's on the mods end or the feed's end.

Jump1979man

Quote from: vbgamer45 on January 16, 2007, 11:21:16 AM
Quote from: Jump1979man on January 16, 2007, 11:17:32 AM
Quote from: sanax on January 16, 2007, 02:32:50 AM
A last question from me. Is it possible to have the mod posts the topic only once and not twice as it is at the moment?

I have posted about this once already and it hasnt been answered.
It should not post a duplicate post as long as the title and the description of the post are different. I can't recreate that yet.

I understand that it shouldnt but it in fact is posting duplicate.....

MegaTinkerCoder

anyway to get rid of the &quot; from the feeds and convert them to " or just put them in quote sections i.e. [ quote ][ /quote ]
In the middle of difficulty lies opportunity.

Albert Einstein

sanax

It's not the entire post which is duplicated but just the title or subject line.

sanax

I attached two images to explain what I mean by duplicated titles. The first image shows the frontpage blocks and the second the actual posts in the forum itself. I'm using snork's MessagePreview in Line mod in the forum and it just look a bit weird to see the title being duplicated...


GC

Quote from: sanax on January 16, 2007, 02:50:56 PM
I attached two images to explain what I mean by duplicated titles. The first image shows the frontpage blocks and the second the actual posts in the forum itself. I'm using snork's MessagePreview in Line mod in the forum and it just look a bit weird to see the title being duplicated...



I dont see any duplication here, however it could be that your RSS feed could be duplicated :P

Also, I read that you cannot have a feed without the rss.xml? Thats not true. I have an rss feed coming through http://us.playstation.com/news/rss/games. Not sure if thats the exact url, but it doesnt use the last / or any .xml. I did a server scan on it, and no .xml files exsisted eather.

vbgamer45

You can use any feed url but having odd characters like ; or & may cause problems.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

GC

Quote from: vbgamer45 on January 16, 2007, 05:35:46 PM
You can use any feed url but having odd characters like ; or & may cause problems.

Nope, the ; and & dont cause errors for me.

majo

i was one of the first downloaders and testers for this one i like the 1.x version the only thing that bothered me that i wasnt able to delete anything but i manage to disable it :)

also the html tags needs to be updated if people wants to see in html

like the version 1,x2 :)


sanax

Quote from: GC on January 16, 2007, 05:19:53 PM
Quote from: sanax on January 16, 2007, 02:50:56 PM
I attached two images to explain what I mean by duplicated titles. The first image shows the frontpage blocks and the second the actual posts in the forum itself. I'm using snork's MessagePreview in Line mod in the forum and it just look a bit weird to see the title being duplicated...



I dont see any duplication here, however it could be that your RSS feed could be duplicated :P

Also, I read that you cannot have a feed without the rss.xml? Thats not true. I have an rss feed coming through http://us.playstation.com/news/rss/games. Not sure if thats the exact url, but it doesnt use the last / or any .xml. I did a server scan on it, and no .xml files exsisted eather.

You don't see any duplication?? lol

The TITLE of each post is duplicated!

nolageek

I see what you mean, it does it on mine too, but it doesn't bother me.  The title of the feed is going on the inside of the feed (as it should) and the script puts the title of the feel as the title of the post... it's got to title the post something. :)  So, it's not duplicated per se.

nolageek

January 17, 2007, 03:52:19 AM #156 Last Edit: January 17, 2007, 04:35:23 AM by nolageek
Uhg.  I have yet to get a feed come through that doesn't have all sorts of formatting screwing it up.  Can the mod be made to clean up the posts before it posts them? Big offenders for me, maybe not others, are paragraph tags showing up and image formatting (width/height.)  AM I doing something wrong?  Is anyone else having this problem?

http://meninshirtandtie.com/forum/index.php/topic,54.0.html

http://meninshirtandtie.com/forum/index.php/topic,52.0.html

Flickr feed: http://meninshirtandtie.com/forum/index.php/topic,45.0.html

See?  If I turn html off, then it doesn't show up - but then everything is all one ugly paragraph and images don't show. (which, some of these feeds are nothing but images!)

Afraid I'm going to have to disable the feeds until I figure out what Im doing wrong...  too many coming through that I have to edit. :(

sanax

For some reason my cron job isn't updating the feeds. I tried the fake cron job but it slows the forum down. According to my host the command line must be like this:

Quote/usr/bin/php http://www.mydomain.net/cronrss.php

and according a tutorial I found on Google it must be like this:

Quotehttp://www.mydomain.net/cronrss.php

None of the above works though. Do I miss something?

BlueRidgeFireRescue

nolageek

what form feed are you using

nolageek

rss 2.0   both are being run through feedburner.

Advertisement: