Customizing SMF > Modifications and Packages

Pretty URLs

<< < (1567/1571) > >>

Totosfo:
Hello all,

I'm getting the same error:


--- Code: ---http://forum.usa-reise.de/index.php?topic=30407.60

8: Undefined index: pretty_enable_filters

Datei: /pages/d7/54/d0014341/home/htdocs/usa-reise.de/smf/smf-v2a/Sources/Display.php
Zeile: 74
--- End code ---

It's the same for MessageIndex, etc. Apart from that, PrettyURLs is working so far for me.

Line 78 in Display.php is the line where the curly brackets open:


--- Code: --- $filterData = unserialize($modSettings['pretty_filters']);
if ($filterData['topics']['enabled'])
{
$url = 'topic=' . $topic . '.' . (isset($_REQUEST['start']) ? $_REQUEST['start'] : '0') . (isset($_REQUEST['prev_next']) ? ';prev_next=' . $_REQUEST['prev_next'] : '') . (isset($_REQUEST['topicseen']) ? ';topicseen' : '') . (isset($_REQUEST['all']) ? ';all' : '') . (isset($_REQUEST['viewResults']) ? ';viewResults' : '');
header('HTTP/1.1 301 Moved Permanently');
redirectexit($url, false);
}
--- End code ---

Any help is appreciated, my error log is growing with every visit… - thank you in advance!

Regards, Thomas

vbgamer45:
Run pretty urls maintenance task in the admin area for pretty urls

Totosfo:
Thank you very much, this indeed did the trick.

I am curious now - before I dig into the script and have a look at the db - what did it change?

Going to truncate the huuuuuuuge log now.

Regards,

Thomas

vbgamer45:
It looks like the array wasnt populated correctly.

Totosfo:
Thanks again.


--- Code: ---170313 records affected. (The query took 3.0448 seconds.)
--- End code ---

Let's hope that the log stays neat and small now.

Cheers,

Thomas

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version