News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Editor de texto WYSIWYG (tipo Word) para SMF 1.1.2

Started by Ramón Cutanda, February 08, 2007, 10:53:16 AM

Previous topic - Next topic

Pillus

Otro problema GRAVE que me ha dado el mod que instalé hace tiempo...Los mensajes privados NO FUNCIONAN CON EL EDITOR!!

Hay alguna manera de arreglarlo ? Alguna manera de desactivar para que en los mensajes privados se utilize el editor default?

Gracias y espero una respuesta compañeros :(



MKPortal ( ultima version ) -> www.tucuaderno.es
SMF 1.1.2 -> www.tucuaderno.es/foro

maximo

#21
Lo he instalado correctamente en mi 1.1 Rc3 theme TpDilber.Pero,me sale un error al enviar un mensaje.Me dice:

"El cuerpo del mensaje se dejó vacio."

Y no es verdad.

¿Sabeis por que puede ocurrir eso?.¿Me he podido dejar algun archivo sin modificar?¿Tengo que activar algo,en el Panel de administracio?.He modificado a mano los archivos,los del theme default y los de mi theme.Y yo creo que he modificado todo correctamente.

Me urge un poco de prisa por que tengo el foro en Modo mantenimiento y hasta que no lo solucione no lo podre abrir,acaso que vuelva a modificar todo a mano.No me va el administrador de paquetes desde que me cambie de Server.

Alguna ayuda porfavor.  

Ramón Cutanda

Si no recuerdo mal ese error es debido a la plantilla que utilizas. Compruébalo usando la plantilla default. Si el problema es la plantilla tendrás que modificarla a mano. Si te fías mándame un privado con los datos de acceso a tu FTP y te lo miro "in situ" porque no tengo tiempo de estar instalando y haciendo pruebas en mi instalación. Luego publicaría aquí la solución (si la encuentro) para otros usuarios con ese problema

Quote from: Pillus on March 26, 2007, 09:21:14 AM
Otro problema GRAVE que me ha dado el mod que instalé hace tiempo...Los mensajes privados NO FUNCIONAN CON EL EDITOR!!

Hay alguna manera de arreglarlo ? Alguna manera de desactivar para que en los mensajes privados se utilize el editor default?


Ídem de lo mismo

Un saludo

maximo

Instalado.Exacto se ve que es el theme.Lo he puesto con el default y funciona correctamente.

Es una leche que solo me funcione de momento con el default.He tenido que cambiar el theme de mi foro,por que el editor es importante en mi foro.

Es un genial editor.Los privados parecen que si funcionan,se ve que a los correos (yahoo,hotmail..etc) los mensajes privados segun me han dicho,llegan con simbolos <div> etc... (codigo html a la vista) pero eso no es muy importante.

Despues un pequeño fallo que he visto que no reconoce si pulsas un salto de linea con la barra espaciadora entre texto que has escrto tu e imagenes pegadas con copy & paste.Sale en la respuesta fnal,todo pegado,sin el espacio.Y por lo demas genial.Y lo poco que he comprobado despues del edtor funciona genial.

Segun he leido por ahi,espero que no haya problemas de seguridad ante hackers.

Muchas gracias al creador y a Videoed.Para mi hasta ahora el mejor Mod que he utlizado.

amenadiel

Sólo a modo de testimonio, lo probé con el Joomla bridge y no funciona. Si entro al subdirectorio del foro, todo bien, lo que me demuestra que el paquete se instaló impecablemente, pero desde joomla no muestra el editor wysiwyg, se salta desde el message icon a la opción de usar rich text editor.

maximo

Hola videoed tengo un problemilla con el editor.No se si me podrias ayudar.

Aqui esta el mensaje.

http://www.simplemachines.org/community/index.php?topic=163054.0

Gracias  

indos

¡Un error ha ocurrido!
El paquete que intentaste subir no es un paquete válido o está corrupto.

que podra ser?
SMF 1.1.4
------------------
<<<< Se vende 1500 visitas por dia (Ver mas info en el sitio)

maximo

Quote from: indos on April 06, 2007, 09:29:14 PM
¡Un error ha ocurrido!
El paquete que intentaste subir no es un paquete válido o está corrupto.

que podra ser?

Eso supongo que es por que no esta creado para tu version.No se cual es tu version,pero para adaptar el Mod a tu version habia creo que modificar el XML antes de subirlo por el Manejador.Echale un vistazo a los post oficiales que lo explicaba muy bien.

Si no es por eso...ya no se que puede ser.

indos

Yo en mi firma tengo la 1.1 pero en realidad ya lo actualize y es la 1.1.2 la ultima de todas, y en el priemr post dice que esta hecho para esa version.
Tambien intente subirlo directamente al directorio "package" desde el ftp, pero cuando lo busco en examinar paquetes no aparece.

SMF 1.1.4
------------------
<<<< Se vende 1500 visitas por dia (Ver mas info en el sitio)

indos

SMF 1.1.4
------------------
<<<< Se vende 1500 visitas por dia (Ver mas info en el sitio)

maximo

Yo es que no se muy bien como podria ayudarte.Si tu version es la 1.1.2 y te has bajado los archivos que corresponden con esa version,pues no te deberia dar ningun problema.

Lo que puedes hacer tambien es modificar los archivos a mano.Subes primero los archivos segun te explica el tutorial aqui en el foro y despues abres el hoteditor creo que era y vas modificando lo que te dice.En 15 minutos instalado.

Respalda antes por lo menos los archivos que modifiques.Por si te da algun error de plantilla o algo.
Creo entendido que no toca nada este mod de la B.D.Pero si quieres respaldarla tambien...

Suerte.

Ramón Cutanda

Yo insisto en que no puedo dar ayuda a "ciegas" y que sigo sin tener tiempo para andar instalando y probando cosas. Si me facilitáis acceso a una instalación puedo mirarlo. Es todo cuanto puedo hacer, lo siento.

Pillus




MKPortal ( ultima version ) -> www.tucuaderno.es
SMF 1.1.2 -> www.tucuaderno.es/foro

indos

Yo no te doy ni empedo un usuario y contraseña, prefiero romperme los cachos yo a correr tal riesgo
SMF 1.1.4
------------------
<<<< Se vende 1500 visitas por dia (Ver mas info en el sitio)

indos

Ya lo tengo instalado, como podria ponerlo por defecto que aparezca con el quickreply?
SMF 1.1.4
------------------
<<<< Se vende 1500 visitas por dia (Ver mas info en el sitio)

bigo

yo estoy espeerando la ultima version del smf que promete un editor de este tipo!!!
Devuelta pero sin pagina :P

Mis Mod:
multiples bbcode - Nuevo  MessagePreview - firma por defecto

Ramón Cutanda


asus


Andres3d

Hola a todos, tengo instalado el hoteditor, junto con joomla y el bridge. Tengo problema es creo que es el bridge quien modifica las URL del foro, me las coloca así.
hxxp:www.se-planet.com/foro/index.php/topic,283.msg819.html#new [nonactive]
Cuando en realidad debería colocarlas así.
hxxp:www.se-planet.com/foro/index.php?topic=283.msg819.html#new [nonactive]

La diferencia es que la URL de arriba dice /topic, y la de abajo ?topic= dando por resultado que en la URL de arriba no me sale la respuesta rápida, nada más los botones y en la de abajo si me sale todo.

Entre en el display.template.php del foro y busque las siguientes lineas para colocar el editor rápido por defecto del foro y no el hoteditor.

<!--//HotEditor MOD - Quick Reply -->
<textarea style="visibility:hidden;position:absolute;top:-20;left:-20;width:1px;height:1px" cols="75" rows="7" id="message" name="message" tabindex="1"></textarea>
<style type="text/css">@import url(richedit/styles/office2007/style.css);</style>
<script language="JavaScript" type="text/javascript" src="richedit/editor.js?version=4.2"></script>
<script language="JavaScript" type="text/javascript">
var getdata =document.getElementById("message").value;
Instantiate("min","editor", getdata , "100%", "150px");
function get_hoteditor_data(){
if (HTML_ON == "no"){
alert ("Please uncheck the HTML checkbox");
return false;
}
else{
setCodeOutput();
var bbcode_output=document.getElementById("hoteditor_bbcode_ouput_editor").value;//Output to BBCode
document.getElementById("message").value = bbcode_output;
}
}
</script><br />
<!--//HotEditor MOD Quick Reply -->


Reemplace todo eso por este.

<textarea cols="75" rows="7" style="width: 95%; height: 100px;" name="message" tabindex="1"></textarea><br />

Osea por el código original del display template y ahí si me sale el cuadro de respuesta rápida aun con loas dos URL's de arriba.

Os dejo dos imagenes, una es con la URL de arriba y la otra la de abajo.





Gracias y saludos!!!

bigo

me gustaria saber si es posible introducir un boton en este editor, para poder colocar uno paar el hide y otros bbcodes que tengo en mi foro

me gustaria tambien saber si se lepueden agregar mas fuentes a este editor, oara que la escritura sea mas dinamica
Devuelta pero sin pagina :P

Mis Mod:
multiples bbcode - Nuevo  MessagePreview - firma por defecto

Advertisement: