Advertisement:

Author Topic: YaBB 2.1 -> SMF 1.1.2  (Read 7800 times)

Offline mrhope

  • Semi-Newbie
  • *
  • Posts: 94
    • Computer Hope
YaBB 2.1 -> SMF 1.1.2
« on: March 25, 2007, 12:45:04 PM »
Attempting to convert a YaBB 2.1 (latest cvs) to SMF 1.1.2 and encountering the below issue.

Board details:
---------------
28,000+ members
197,560 Posts
32,826 Topics
0 mods

Checklist:
---------------
- Tried running the version posted on the website but gets stuck (10+ hours) at: step=1&substep=0&cstep=11&start=0
- The below error is running the latest files posted by JayBachatero on the first post of the above YaBB sticky post.
- Believe I've done everything also suggested by JayBachatero.
- Have installed a fresh copy of SMF before running the conversion after the first failed. Including deleting all MySQL tables.
- Running YaBB forums in maintenance during conversion.

Error:

Code: [Select]
Converting topics (part 2)... Unsuccessful!
This query:
UPDATE `smf`.smf_log_topics
SET ID_TOPIC = 1
WHERE tempID = 1078854085;
Caused the error:
Unknown column 'tempID' in 'where clause'

If I run this again it does often get further but then gets stuck at.

step=1&substep=0&cstep=11&start=0

With MySQL just doing the below two things over and over with no progress.

ALTER TABLE `smf`.smf_messages\n  ORDER BY poster...
ALTER TABLE `smf`.smf_messages\n  CHANGE COLUMN ID_...

Below information is using the latest version I found posted for another user under the sticky post. Seemed this was a more recent post because the post had a later date stamp.

I then try manually entering substep=1, which usually gets it going but then encounter the below situation, which appears to stick

Code: [Select]
Converting posts (part 3)...     
Notice: Undefined variable: actualPosts in /home/users/c/comphope/public_html/forum/yabb21_to_smf.php on line 1291
out of 197688 have been assigned to the correct member. Incomplete.

With MySQL showing: NULL as the info being entered into the NULL db? The command is sleep but it's doing this in between the sleeps. I continue to hit refresh and this is all I see appearing and disappearing.

I've ran the conversion several dozen times, spending a good 24+ hours trying to get this to go through with random results and sometimes different errors, however the above situation seems to happen the most often. I can skip steps 11 and 12 and get it to complete, however I have no posts even when it shows the proper count of posts when viewing the board it shows nothing.
« Last Edit: March 26, 2007, 03:47:46 PM by mrhope »

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: YaBB 2.1 -> SMF 1.1.2
« Reply #1 on: March 26, 2007, 07:16:55 PM »
Maybe something changed in the YaBB 2.1 CVS files.  I'll have to spend more time with this converter and nail these bugs :(.  I'll look into these bugs when I get a chance.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline mrhope

  • Semi-Newbie
  • *
  • Posts: 94
    • Computer Hope
Re: YaBB 2.1 -> SMF 1.1.2
« Reply #2 on: March 26, 2007, 07:32:13 PM »
Ok thanks for the reply, in the mean time I'm still continuing to figure this out as well. I understand from all your previous posts that I've read and been monitoring that you're busy in school and in the real life. ;)

I did notice during the last most successful conversion that even though there was no posts displayed I could view members past posts through the profile. However, there were no members with recent posts they all seemed to stop back around 2005. The only thing I could think of that happened around then was possibly that is when I updated to YaBB 2.1 from the previous version. But it appears other users had no little or no issues upgrading from 2.1 to SMF.

Offline mrhope

  • Semi-Newbie
  • *
  • Posts: 94
    • Computer Hope
Re: YaBB 2.1 -> SMF 1.1.2
« Reply #3 on: March 26, 2007, 11:01:16 PM »
Well I actually managed to get it to go (kind of). After doing the last conversion I noticed that all the users were being shown as one of the post independent member groups (not to be confused with the post dependent groups) so I removed all post independent groups and did a lot of tweaking with the URL bar changing the substep and cstep often.

Unfortunately however all past posts show as Guest, is this one of the steps I skipped that caused this to occur?

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: YaBB 2.1 -> SMF 1.1.2
« Reply #4 on: March 26, 2007, 11:31:31 PM »
You probably missed that step where it assigns the post to the user.  It says something like x of y posts have been assigned to users.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: YaBB 2.1 -> SMF 1.1.2
« Reply #5 on: March 27, 2007, 12:21:42 AM »
Umm there is no var names $actualPosts in my version.  Try this file.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline mrhope

  • Semi-Newbie
  • *
  • Posts: 94
    • Computer Hope
Re: YaBB 2.1 -> SMF 1.1.2
« Reply #6 on: March 27, 2007, 12:40:59 AM »
You're quick, deleted my post and you've already replied. ;) I'll give that one a shot now. Thanks again.

Offline mrhope

  • Semi-Newbie
  • *
  • Posts: 94
    • Computer Hope
Re: YaBB 2.1 -> SMF 1.1.2
« Reply #7 on: March 27, 2007, 05:38:32 PM »
After running this file the first time It stopped at the below error message and I was unable to get it to continue.

on step=1&substep=0&cstep=13&start=0

Converting attachments (if the mod is installed)... Unsuccessful!
This query:

    SELECT ID_MSG, temp_filename
    FROM `smf`.smf_messages
    WHERE temp_filename != ''
    LIMIT 0, 100;

Caused the error:

    Unknown column 'temp_filename' in 'field list'

I decided it would be a good idea to try it again. I did get the above error however after increasing the cstep to the next level I was abel to get it to continue. I unfortunately then did also get the below message. I increased the cstep again to get around it and did manage to successfully complete the conversion and also did not encounter the guest issue I was encountering earlier. There are still a few little quirks but nothing that's not managable.

step=1&substep=73320&cstep=18&start=0


Converting poll votes... Unsuccessful!
This query:

    ALTER TABLE `smf`.smf_poll_choices
    ADD PRIMARY KEY (ID_POLL, ID_CHOICE);

Caused the error:

    Duplicate entry '16777215-0' for key 1

Thanks again for your assistance with this issue.

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: YaBB 2.1 -> SMF 1.1.2
« Reply #8 on: March 28, 2007, 12:14:59 AM »
Do you have the attachments mod installed?  I'll look into the poll issue.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline mrhope

  • Semi-Newbie
  • *
  • Posts: 94
    • Computer Hope
Re: YaBB 2.1 -> SMF 1.1.2
« Reply #9 on: March 28, 2007, 02:07:24 AM »
If you're referring to a YaBB attachments mod. No, I didn't install any YaBB mods during the 2.1 installation of YaBB. A long time ago in 1.0 or 1.1 I did however install some forum cleanup mods, but nothing else.

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: YaBB 2.1 -> SMF 1.1.2
« Reply #10 on: March 29, 2007, 01:02:19 PM »
If you're referring to a YaBB attachments mod. No, I didn't install any YaBB mods during the 2.1 installation of YaBB. A long time ago in 1.0 or 1.1 I did however install some forum cleanup mods, but nothing else.
Umm seems like I'm going to have to take a look into that then.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert