Advertisement:

Author Topic: Demande diverse  (Read 24848 times)

Offline Petitcurieux

  • Semi-Newbie
  • *
  • Posts: 32
  • Gender: Male
Re: Demande diverse
« Reply #20 on: September 09, 2004, 01:53:21 PM »
Alors là, chapeau bas pour avoir pris la peine de me répondre de façon aussi complète :)
J'ai découvert ce système de forum depuis très peu de temps (offre gratuite de mon hébergeur) et franchement, toutes mes félicitations à ceux qui travaillent pour l'améliorer au fil du temps.
J'aurai sans doute d'autres questions à poser, mais en attendant, je remercie tout particulièrement Ap2 et Percherie pour l'aide précieuse qu'ils m'ont apportée :)

Offline Petitcurieux

  • Semi-Newbie
  • *
  • Posts: 32
  • Gender: Male
Re: Demande diverse
« Reply #21 on: September 09, 2004, 04:09:18 PM »
Je viens d'effectuer la mise à jour et visiblement, tout s'est très bien passé :)
Pour info, lorsque l'on va à l'adresse www.mon_site/forum/upgrade.php, les instructions sont en Anglais. J'ai hésité et j'ai laissé par défaut la case du milieu cochée.
J'ai cependant un petit problème:
Quand je suis dans la section "Administration" et que j'arrive dans "Modifier les caractéristiques et les options", j'ai le message d'erreur suivant qui s'affiche 10 ou 11 fois de suite:

<i>Notice: Undefined index: allow_editDisplayName in /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/ModSettings.php on line 488</i>

Au dessous de ces messages, j'ai la liste des options modifiables et je pense que je peux les modifier quand même.

De quoi s'agit-il et surtout, comment rectifer cette erreur ?

Merci :)

Offline Percherie

  • Full Member
  • ***
  • Posts: 449
  • Gender: Male
  • Psycho-Pervers de service
    • ToutenKamion
Re: Demande diverse
« Reply #22 on: September 10, 2004, 01:39:39 AM »
J'ai pas encore installé la nouvelle version donc pour l'instant je peut pas vérifier ce qui ne vas pas à la ligne 488 du ficchier ModSettings mais ça doit venir d'un problème pendant l'installation ou des fichier

Avant de tout réinstalé remet tous tes fichier à jour pour voir si ça viens de là mais essais avec la version RC1 directement et non plus avec l'update maintenant que tu l'a appliqué une fois
Visitez :
Le site site des chépers du web et ToutenKamion, le blog de voyage autour du monde en camion

Offline Petitcurieux

  • Semi-Newbie
  • *
  • Posts: 32
  • Gender: Male
Re: Demande diverse
« Reply #23 on: September 10, 2004, 02:45:22 AM »
J'ai remplacé le fichier modesetting.php pour voir s'il n'y aurait pas eu une erreur hier soir en le tranférant sur le serveur, mais j'ai toujours le même message.
Petite question: Comment faire une mise à jour sans passer par l'update ?
J'ai peut-être mal compris ce que tu voulais me dire, Percherie, désolé ;)

Ap2, si tu passes dans le coin, tu as toujours la possibilité d'intervenir directement dans mon forum :)
« Last Edit: September 10, 2004, 03:08:22 AM by Petitcurieux »

Offline Alexandre P.

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,044
  • Gender: Male
    • LivreSansPage
Re: Demande diverse
« Reply #24 on: September 11, 2004, 12:28:39 AM »
Ap2, si tu passes dans le coin, tu as toujours la possibilité d'intervenir directement dans mon forum :)
Je suis passé par ton forum, et je vois que tu en as plus que tu le dis, petit cachotier ;)
Code: [Select]
Notice: Undefined index: allow_editDisplayName in /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/ModSettings.php on line 488
Notice: Undefined index: allow_hideOnline in /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/ModSettings.php on line 488
Notice: Undefined index: disabledBBC in /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/ModSettings.php on line 488
Notice: Undefined index: enableNewReplyWarning in /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/ModSettings.php on line 488
Notice: Undefined index: number_format in /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/ModSettings.php on line 488
Notice: Undefined index: databaseSession_enable in /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/ModSettings.php on line 488
Notice: Undefined index: databaseSession_loose in /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/ModSettings.php on line 488
Notice: Undefined index: databaseSession_lifetime in /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/ModSettings.php on line 488
Notice: Undefined index: redirectMetaRefresh in /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/ModSettings.php on line 488
Notice: Undefined index: notify_on_new_registration in /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/ModSettings.php on line 488
Notice: Undefined index: smtp_port in /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/ModSettings.php on line 488
La cause est des variables dans le fichier de langue qui ne sont pas trouvées.  On peut voir des trous où il manque du texte (oir en p.j. pour comprendre).

Vérifie les lignes suivantes dans ModSettings.french.php:
15 et 16
Code: [Select]
$txt['allow_editDisplayName'] = 'Autoriser les membres &agrave; changer leur pseudonyme?';

$txt['allow_hideOnline'] = 'Permettre aux non-administrateurs de cacher leur pr&eacute;sence en ligne?';

25
Code: [Select]
$txt['disabledBBC'] = 'Balises BBCodes d&eacute;sactiv&eacute;es (s&eacute;par&eacute;es par une virgule)';

27
Code: [Select]
$txt['enableNewReplyWarning'] = 'Avertir les membres des nouvelles r&eacute;ponses post&eacute;es lors de la r&eacute;daction d\'une r&eacute;ponse?';
29
Code: [Select]
$txt['number_format'] = 'Format des nombres par d&eacute;faut';
40, 41 et 42
Code: [Select]
$txt['databaseSession_enable'] = 'Utiliser des sessions en base de donn&eacute;es';

$txt['databaseSession_loose'] = 'Permettre aux navigateurs de revenir sur des pages cach&eacute;es';

$txt['databaseSession_lifetime'] = 'Secondes avant qu\'une session inutilis&eacute;e expire';

47
Code: [Select]
$txt['redirectMetaRefresh'] = 'Utiliser des redirections META plut&ocirc;t que HTTP<div class="smalltext">(pour les serveurs IIS 4.0 et quelques versions d\'Apache.)</div>';
54
Code: [Select]
$txt['notify_on_new_registration'] = 'Notifier les administrateurs lors de l\'inscription d\'un nouveau membre';
67
Code: [Select]
$txt['smtp_port'] = 'Port SMTP';
J'ai cru voir aussi d'autres erreurs du même genre ailleurs sur ton forum.  Essaye aussi de télécharger de nouveau le paquet de langue et de l'uploader encore.
Aucun support par M.P., courriel ou messagerie instantanée / No support by P.M., email or I.M.

Offline Petitcurieux

  • Semi-Newbie
  • *
  • Posts: 32
  • Gender: Male
Re: Demande diverse
« Reply #25 on: September 11, 2004, 03:06:37 AM »
Merci pour ces explications, Ap2 :)

Je suis allé vérifier toutes les lignes que tu m'as indiquées, mais d'après ce que j'ai pu constater, elles n'existent pas dans mon fichier ModeSetting.french.php.
J'ai à nouveau téléchargé la MAJ de la version française, je l'ai transférée sur le serveur en remplacement des anciens fichiers, mais le problème persiste. Toujours pas ces fameuses lignes de commande.
Je t'ai envoyé le fichier par e-mail pour une éventuelle vérification.
Par ailleurs, j'ai lu dans un des posts qu'après avoir uploadé un fichier, il faut mettre le forum à jour.
C'est une chose que je n'ai pas faite car je n'ai pas trouvé comment faire...

Encore merci :)

Offline Hellowen

  • Newbie
  • *
  • Posts: 8
    • Hellowen.net
Re: Demande diverse
« Reply #26 on: September 11, 2004, 01:27:21 PM »
Merci ap2,

J'ai enfin réussi à changer la bannière du forum. Après quelques essais infructueux, j'ai réussi à comprendre. Cependant je passe par le ftp en ligne de mon hébergeur lycos car mes deux accès ftp son pris pour mon site.

Encore une petite question ap2. J'aimerais changer la couleur blanche de la page de mon forum par un thème de fond personnel.  SI il s'agissait de changer la couleur Je sais que l'on peut faire cela avec un code de couleur mais déjà je ne sais pas dans quel fichier la modifier. Donc pour mettre un thème de fond personnel de mon disque dur, encore moins. Peux tu me renseigner à ce sujet.

Concernant tes indications précédentes, je n'ai changé que ma bannière, je n'ai pas encore eu le temps de voir le reste. lol.

Mon forum est visible ici. hxxp:forum.hellowen.net [nonactive]

Encore merci pour tes précisions très précieuses.

 ;)
Amitiés Fred

Offline Petitcurieux

  • Semi-Newbie
  • *
  • Posts: 32
  • Gender: Male
Re: Demande diverse
« Reply #27 on: September 11, 2004, 04:55:30 PM »
Une fois de plus, j'ai été parfaitement renseigné (par mail) par Ap2.
Résultat: tout fonctionne à merveille :)
Merci !

Offline Alexandre P.

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,044
  • Gender: Male
    • LivreSansPage
Re: Demande diverse
« Reply #28 on: September 11, 2004, 04:59:26 PM »
>> PetitCurieux:
Par ailleurs, j'ai lu dans un des posts qu'après avoir uploadé un fichier, il faut mettre le forum à jour.
C'est une chose que je n'ai pas faite car je n'ai pas trouvé comment faire...
Non, ça ne sert à rien,  du moins en ce qui concerne les fichiers de langue.  Ils sont reconnus automatiquement suite à leur upload dans /Themes/default/languages.

>> Hellowen: Pour changer l'arrière-plan de ton forum, voici comment faire.
  • Si tu ne l'as pas déjà fait, si tu ne fonctionnes pas avec un thème personnel autre que celui par défaut, crée-en un nouveau.  Va dans le Centre d'administration > Gestion des thèmes.  Dans l'option "Créer une copie de Default nommée:", donne le nom que tu veux que ton nouveau thème porte (évite les caractères accentués).  Puis cliques sur le bouton "Installer!", juste dessous.
  • Va dans Centre d'administration > Gestion des thèmes, puis cliques sur le nom de ton thème personnalisé.
  • Dans le haut de la page, clique sur le lien "Modifier le fichier style.css. (couleurs, polices, etc.)".
  • Recherche
    Code: [Select]
    body[/li][/list]
    {
       background-color: white;
       margin: 0px;
       padding: 0px;
    }
  • Remplace cela par
Code: [Select]
body
{
   background: white;
   background-image: url('http://www.monsite.com/image.jpg');
   background-repeat: no-repeat;
   margin: 0px;
   padding: 0px;
}
À vérifier:
  • background-image: url('http://www.monsite.com/image.jpg'); --> URL vers ton image en fond d'écran
  • background-repeat: no-repeat; --> l'image ne se répétera pas si la page est plus grande que l'image.  Pour que l'image se répète, change no-repeat par repeat
[/list]

Voilà, maintenant tu as ton image personnalisée en fond de forum :)
Aucun support par M.P., courriel ou messagerie instantanée / No support by P.M., email or I.M.

Offline Petitcurieux

  • Semi-Newbie
  • *
  • Posts: 32
  • Gender: Male
Re: Demande diverse
« Reply #29 on: September 11, 2004, 05:25:11 PM »
Une dernière question pour aujourd'hui...
Maintenant que tout est à jour, je peux modifier les erreurs de ponctuations dans les différents mails envoyés aux membres.
Quand on édite les fichiers pour les modifier, comment repérer les lignes qui correspondent aux phrases contenues dans les mails ?

Offline Percherie

  • Full Member
  • ***
  • Posts: 449
  • Gender: Male
  • Psycho-Pervers de service
    • ToutenKamion
Re: Demande diverse
« Reply #30 on: September 11, 2004, 07:19:58 PM »
Avec la version RC1 les modification sont déjas prise en compte :D
Visitez :
Le site site des chépers du web et ToutenKamion, le blog de voyage autour du monde en camion

Offline Alexandre P.

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,044
  • Gender: Male
    • LivreSansPage
Re: Demande diverse
« Reply #31 on: September 11, 2004, 07:35:10 PM »
Arf, non, en effet, certaines erreurs dans les emails sont encore présentes :-[

Comme les phrases utilisées dans les courriels sont pas mal éparpillées dans les différents fichiers de langue, il faut les fouiller un peu.  Comment les retrouver?  Il faut chercher les phrases avec leurs fautes (ex: chercher littéralement "Cliquez le lien suivant pour aller &agrave; l'&eacute;cran de gestion des approbations") puis les corriger.  Les variables sont sous la forme
Code: [Select]
$txt['nom_de_la_variable'] = 'La phrase à afficher';
Aucun support par M.P., courriel ou messagerie instantanée / No support by P.M., email or I.M.

Offline Petitcurieux

  • Semi-Newbie
  • *
  • Posts: 32
  • Gender: Male
Re: Demande diverse
« Reply #32 on: September 12, 2004, 04:57:39 AM »
Merci :)
Petite précision: Si on modifie des accentuations autres que celles contenues dans les e-mails, y-a-t'il un risque de messages d'erreurs dans le forum ?
Je suis conscient de poser des questions sans doute un peu stupides (voire complètement ;)), mais comme je ne préfère pas prendre de risques...

Enfin, dernier point: Depuis la mise à jour de la langue, à chaque fois qu'un membre envoie un message personnel, voici ce qu'on peut lire dans le journal d'erreurs:

Undefined index: pm_successfully_sent
Fichier: /data/members/paid/p/e/petitcurieux.net/htdocs/www/forum/Sources/Subs-Post.php
Ligne: 466

Pourtant, je n'ai rien modifié dans ce fichier :(

[Je viens de m'apercevoir que ce deuxième point a été signalé dans un autre thread. Si je suivais un peu... ;)]
« Last Edit: September 12, 2004, 05:01:40 AM by Petitcurieux »

Offline Percherie

  • Full Member
  • ***
  • Posts: 449
  • Gender: Male
  • Psycho-Pervers de service
    • ToutenKamion
Re: Demande diverse
« Reply #33 on: September 12, 2004, 08:23:36 AM »
Je viens de mettre à jour le forum... je vais enfin pouvoir m'occuper de vous dresser la liste des variables qui pose problème
Visitez :
Le site site des chépers du web et ToutenKamion, le blog de voyage autour du monde en camion

Offline Percherie

  • Full Member
  • ***
  • Posts: 449
  • Gender: Male
  • Psycho-Pervers de service
    • ToutenKamion
Re: Demande diverse
« Reply #34 on: September 12, 2004, 09:24:13 AM »
Je me suis penché sur le problème des emails et je n'arrive pas à comprendre d'où ça viens pourtant tous les test semble parfaitement correct, faudrait ce tourné vers les developpeur

Voici le type de caractère qui me gène :

é pour é
ê pour ê
ï¿œ pour és

Je pencherai vers un problème de caratère qui ne viendrait pas des fichiers de langue mais du fonctionne du forum. Si c'est l'alphabé UTF-8 (anglophone) qui est utilisé je crois que ça coince avec le notre.

Par contre voici la liste complete des variables qui sont utilisé pour les mails, A toi de jouer Ap2, je pense que si quelque une m'on echappé elle doivent etre rangé ensemble des les fichiers de langue mais ça te donne une bonne base

$txt[35]
$txt[118]
$txt[130]
$txt[318]
$txt[492]
$txt[512]
$txt[700]
$txt[701]
$txt[719]
$txt[1001]
$txt[1005]
$txt['rtm3']
$txt['rtm4']
$txt['rtm_email1']
$txt['rtm_email2']
$txt['rtm_email3']
$txt['rtm_email_comment']
$txt['change_password']
$txt[hello_member]
$txt[change_password_1]
$txt[change_password_2]
$txt['notifyXAnn2']
$txt['notifyXAnn3']
$txt['notify_boards']
$txt['notify_boards_once']
$txt['notify_boardsUnsubscribe']
$txt[activate_mail]
$txt['activate_reactivate_title']
$txt[activate_reactivate_mail]
$txt[activate_code]
$txt[approval_email]
$txt[hello_guest]
$txt[admin_approve_accept_desc]
$txt[admin_approve_reject]
$txt[admin_approve_reject_desc2]
$txt[admin_approve_remind]
$txt[admin_approve_remind_desc]
$txt[admin_approve_remind_desc2]
$txt[admin_notify_subject']
$txt[reminder_subject]
$txt[reminder_mail]
$txt[sendtopic_dear]
Visitez :
Le site site des chépers du web et ToutenKamion, le blog de voyage autour du monde en camion

Offline Alexandre P.

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,044
  • Gender: Male
    • LivreSansPage
Re: Demande diverse
« Reply #35 on: September 12, 2004, 02:28:54 PM »
Je pencherai vers un problème de caratère qui ne viendrait pas des fichiers de langue mais du fonctionne du forum. Si c'est l'alphabé UTF-8 (anglophone) qui est utilisé je crois que ça coince avec le notre.
Non: en version anglophone, le forum utilise un charset ISO-8859-1.  En français, on utilise le même charset, mais en version plus récente pour contenir le symbole Euro: ISO-8859-15.

Je crois que les emails sont envoyés au format texte, et non en HTML.  Ça serait une explication qui répondrait à la question "Pourquoi on voit des &Eacute; et des &agrave; dans les emails".

Petite précision: Si on modifie des accentuations autres que celles contenues dans les e-mails, y-a-t'il un risque de messages d'erreurs dans le forum ?
Je suis conscient de poser des questions sans doute un peu stupides (voire complètement ;)), mais comme je ne préfère pas prendre de risques...
(J'ai déjà dit qu'il n'y avait pas de questions stupides?)

Avant (avec la version Beta 4, si je me souviens bien), il y avait des problèmes si on insérait des lettres accentuées à des mauvais endroits.  Je crois que c'est bien géré maintenant, et qu'il n'y a plus de problème (à savoir que j'avais oublié de changer des é et des à à certains endroits et que je n'ai pas eu d'erreur).
Aucun support par M.P., courriel ou messagerie instantanée / No support by P.M., email or I.M.

Offline Percherie

  • Full Member
  • ***
  • Posts: 449
  • Gender: Male
  • Psycho-Pervers de service
    • ToutenKamion
Re: Demande diverse
« Reply #36 on: September 12, 2004, 04:23:54 PM »
voic ce que je recoi par exemple

Quote
>Le message suivant, "Quelle belle et bonne journée ! " par Luna a

ᅵᅵsignalᅵpar Percherie (percherie) sur un forum que vous modᅵez:

>>
>> http://afterfree.eurower.net/index.php?topic=3103.msg41896#msg41896
>>
>> Le rapportant a fait le commentaire suivant:
>>
>> test email
>>
>> Cordialement,
>> L'équipe  Afterfree.

Normalement avec la fonction mail( ) en php tout est envoyé au format texte sauf pendant l'envoie de mail à tous les membres et seulement si on le stipule
Visitez :
Le site site des chépers du web et ToutenKamion, le blog de voyage autour du monde en camion

Offline Hellowen

  • Newbie
  • *
  • Posts: 8
    • Hellowen.net
Re: Demande diverse
« Reply #37 on: September 16, 2004, 03:29:54 PM »
Merci pour tout ap2, tu m'as été d'un grand secours.  ;D

Encore une petite question dont je n'arrive pas à résoudre le problème. Cette après-midi encore, j'avais les icones servant, à mettre en gras, surligner, italique, une url etc.... lorsque je fais un message  Et là ce soir je n'ai plus rien. Il ne me reste que les smileys.

Qu'ai je fais encore comme bêtise. Peux tu m'aiguiller car j'ai cherché un bon bout de temps et pas moyen. Au moment même où je rédige mon message je m'aperçois que sur le forum de smf, il y a tout ce qui me manque, bouuuuuuh, comment dois-je faire? pour revenir à la normale ? >:( ??? ::)

Merci. 
Amitiés Fred

Offline Alexandre P.

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,044
  • Gender: Male
    • LivreSansPage
Re: Demande diverse
« Reply #38 on: September 16, 2004, 10:59:14 PM »
(Conseil-design: il est souvent recommandé d'éviter les images animées en arrière-plan ;) )

Est-ce que "Activer les codes forum (Bulletin Board Codes, BBC)" est coché dans Centre d'administration > Modifier les caractéristiques et options ?
Aucun support par M.P., courriel ou messagerie instantanée / No support by P.M., email or I.M.

Offline Hellowen

  • Newbie
  • *
  • Posts: 8
    • Hellowen.net
Re: Demande diverse
« Reply #39 on: September 17, 2004, 03:49:31 AM »
Est-ce que "Activer les codes forum (Bulletin Board Codes, BBC)" est coché dans Centre d'administration > Modifier les caractéristiques et options ?

Oui cette fonction est activée. Hier après-midi j'avais encore toutes les fonctions lorsque je me suis connecté du bureau et le soir à mon domicile, cela avait disparu  ::)
Je cherche encore, je vais voir!!!!!

(Conseil-design: il est souvent recommandé d'éviter les images animées en arrière-plan  )

Je suis d'accord avec toi, car en plus lorsque je clique sur l'aide je n'arrive plus à voir ce qui est écrit. Cela dois certainement jouer aussi sur la vitesse d'affichage de la page. Je vais changer cela, en effet. :P ;)
Amitiés Fred