• Welcome to Simple Machines Community Forum. Please login or sign up.

Allowed Groups Embedded Flash

Started by ディン1031, April 05, 2007, 07:23:56 AM

Previous topic - Next topic

Webbie

June 29, 2007, 02:41:35 PM #40 Last Edit: June 29, 2007, 02:48:44 PM by Webbie
Hi.
I've installed the Mod but this error appears when you try to post a new topic:
QuoteParse error: syntax error, unexpected T_STRING in /home/.../public_html/.../forum/Sources/Subs-Post.php on line 2161


The code from that page - from 2159 to 2163:
global $modSettings;

//Okay Let's look if this text is prepares or not :x
if(empty($modSettings['embededHtmlFlashConvert']) || empty($message))
return $message;


Any thoughts ?

Update - May not be the Mod actually...
I've uninstalled it and still get the same error.

I just upgraded the forum to the latest version so I suspect it's more than likely something to do with that.

ディン1031

New Version:

Version 1.2.1 (27.07.07)
! Bugfix for Moderator Board detection, the select Moderators work not each time correct. With this fix it work 100% ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

npereira

I installed the latest version on SMF 1.1.3 and when posting the flash URL from youtube, I only get a white box, no videos....?!?

npereira

ok, I got it to work, but I need to know if there is also a security issue and if so, is there a way to reduce this risk? without deleting the option of embeded flash as I think it's a neat feture.

ディン1031

A Security risk is evertime possible, but you can do nothing against ;). Only to give groups who you trusted the premission to post flash.

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

FuKuy

I can't make this MOD work properly. :(

I have done a clean installation of SMF 1.1.3, then installed Allowed Groups Embedded Flash 1.2.1


Then what? I've checked some groups but all users are able to embed flash.

What options need to be checked? What's the problem? I'm using default theme and english version....

Thanks for help.

ディン1031

Quote from: FuKuy on September 18, 2007, 05:40:18 AM
I can't make this MOD work properly. :(

I have done a clean installation of SMF 1.1.3, then installed Allowed Groups Embedded Flash 1.2.1


Then what? I've checked some groups but all users are able to embed flash.

What options need to be checked? What's the problem? I'm using default theme and english version....

Thanks for help.
You need only to select the groups who allowed to use it, if you select the standard option than it's automatic allowed to everyone!

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

FuKuy

Quote from: ディン1031 on September 18, 2007, 11:16:54 AM
Quote from: FuKuy on September 18, 2007, 05:40:18 AM
I can't make this MOD work properly. :(

I have done a clean installation of SMF 1.1.3, then installed Allowed Groups Embedded Flash 1.2.1


Then what? I've checked some groups but all users are able to embed flash.

What options need to be checked? What's the problem? I'm using default theme and english version....

Thanks for help.
You need only to select the groups who allowed to use it, if you select the standard option than it's automatic allowed to everyone!

Bye
DIN1031

I'm doing exactly that way....

I select the groups allowed to use it, but this take no effect.

I have the bbc tag [flash] disabled and the option "embed flash to posts" also disabled.

Even I've try all possible combinations and I have no results. Or everyone can post flash or no one.... O_o

AfroSamurai

September 21, 2007, 09:41:38 PM #48 Last Edit: September 22, 2007, 06:02:38 AM by AfroSamurai
Hi ディン1031,

I use the version 1.1.3 of SMF, and I've install successfully your MOD. But it doesn't work at all for me on my test forum, and nether on my fiend's forum.

I've created a "Team" group and authorize it to post flash but I only get the links. Only Admin and Global Moderator are able to post flash... I tried all sorts of option combinations and nothing seems to work... its like it was never installed.

Can someone help me please?! I really need the MOD to work.

Thanks in advance.

Afro.

P.S. I also have the YouTube and DailyMotion BB-code MODs install. Oh, and is it best to install the MOD manually? Because by the Admin panel download manager, it says that it installed OK but nothing works.

ディン1031

Hmmm i must try it with the other mods together... normal i had never problems with it <<.

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

AfroSamurai

September 22, 2007, 05:38:18 PM #50 Last Edit: September 22, 2007, 10:41:53 PM by AfroSamurai
OK, thanks...

Please let me know if you find out what's the problem. And if it can help you, here is also the MOD list of my fiends forum (the Allowed Groups Embedded Flash MOD doesn't work for Him either)

So, on my test forum, I have :

1. YouTube BBC Tag (XHTML Compliant) v1.0
2. DailyMotion BBC Tag (XHTML_Compliant) v1.0
3. Allowed Groups Embedded Flash   v1.2.1


And on my friends forum, he has :

1. Copyright      v3
2. MenuPerso    v2
3. Picture forum view par MkC    v12.1
4. Separe post epingle by MkC    v2.0
5. Downloads    v1
6. Filtre Mail    v1.0
7. PostPerso    v2
8. PostRecentMkc    v1
9. Hide Tag Special   v1.2.4
10. Traduction french Hide Tag Special 1.24 + bbc tag hide    v1.0.2   
11. vMoveTopic Notify by PM    v0.90
12. Traduction FR vMoveTopic Notify by PM    v1.0.2
13. Users Online Today Mod    v1.4.0
14. Allowed Groups Embedded Flash   v1.2.1


So, on both our forums, the Allowed Groups Embedded Flash MOD dos not work at all, only Admin is able to post Flash. I manage once to make your MOD work before but I had only this one installed I think. So, it might be a bug with other MODs... this should be fixable since other MODs work together, doesn't it? Hope it's gonna help you find the corrections. Thanks very much for your work, This MOD will be the best when it'll be adjusted!

See ya!
Afro.

ディン1031

Version 1.2.3 (24.09.07)
+ Now allowed Groups can also Preview the flash to see if it work correct.
- Upgrade included

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

ES23

November 05, 2007, 07:41:59 AM #52 Last Edit: November 05, 2007, 07:45:58 AM by ES23
http://www.mywebsite.com/forums/index.php?action=postsettings
8: Undefined index: allowedFlashGroups
File: /var/www/html/forums/Sources/ManagePosts.php
Line: 309

I found the above error :( Any idea how to solve that?It's creating alot of repeated errors in my forum error log...

ディン1031

Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

AfroSamurai

Hi DIN1031,

I would have a little request for something that would make a good add up to your MOD and that people (including me! ;D) would find very useful. I found on a forum by surfing on Google, a BBcode MOD that allowed the possibility to make the Flash file canvas transparent. Here's a sample of the description I've picked up on the site:

This mod will allow your users to specify 'transparent' or 'non-transparent' when using the [flash]http://bbcode tags to post a .swf - any objects on the Flash stage will appear, but the background (canvas) colour of the .swf file will not be visible, so the IPB background will show through.

This mod is particularly useful if you have variety of dark/light skins installed, since it will prevent colour-clashing between the swf background and the board colours

Usage:

[flash=400,60,0]http://server.net/folder/swfname.swf[/flash]
Will show the Flash normally, with an opaque background (the colour of the Flash canvas)

[flash=400,60,1]http://server.net/folder/swfname.swf[/flash]
Will show the Flash with a transparent background (Flash canvas colour will not show)


I know that this MOD is not for SMF but, If you would like to take a look at the coding to perhaps adapt it to SMF, please let me know and I will send you the files in PM. Then you could Post the update publicly.

Thanks very much and I hope you will like the idea!

See ya!

AfroSamurai.

ディン1031

I think this should be a extra mod, do you have this code that it make it transparent.

Than i can make a mod for it, should be not very difficult and will be work everytime in the flash tag :).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

AfroSamurai

Ok, I'm sending you the code right now! :)

Thank you very much! ;)

See ya!

AfroSamurai.

AfroSamurai

So DIN1031...

With no intention of pressuring O:), did you have a chance to look at that MOD? (for Flash BBcode canvas transparency) Is it something possible to adapt to SMF? :)

ディン1031

Quote from: AfroSamurai on December 03, 2007, 08:53:16 PM
So DIN1031...

With no intention of pressuring O:), did you have a chance to look at that MOD? (for Flash BBcode canvas transparency) Is it something possible to adapt to SMF? :)
Look there -> http://www.simplemachines.org/community/index.php?topic=209098.new#new

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

capitanqueso

could you help me seems that the admin does´t know how to enable the flash button to work could you tell me how it is.
I understand it ´s by default setted off i guess he doesn´t speak english or is plain stupid or just don't want to put it on.
are there a mod just for youtube or goear i been seen some bbc around like [youtube][/youtube][goear][/goear][yt][/yt]

Advertisement: