• Welcome to Simple Machines Community Forum. Please login or sign up.
December 07, 2021, 01:58:18 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


provlima me thn Gallery1.7.1

Started by dotbigboy, April 19, 2007, 06:17:06 AM

Previous topic - Next topic

dotbigboy

Γεια σας παιδια

Μετά από αναβάθμιση του φόρουμ με την τελευταία version έχω προβλημα να εγκαταστήσω την Gallery1.7.1 βγάζει το παρακάτω σφάλμα

Σφάλμα βάσης δεδομένων
Incorrect table name ''
Αρχείο: /var/www/vhosts/σιτε.gr/httpdocs/smf/Packages/temp/galleryinstall.php
Γραμμή: 39

Έχει κανένα φίλος αντιμετωπίσει παρόμοιο πρόβλημα?

thanks

Nefeli

April 19, 2007, 12:48:30 PM #1 Last Edit: April 19, 2007, 12:50:05 PM by Nefeli
Ποιες εκδόσεις ακριβώς χρησιμοποιείς; Είναι συμβατές;

Άνοιξε το αρχείο galleryinstall.php και βρες τη γραμμή 39. Τι λέει;

Προσθήκη: διάβασε το παρόμοιο ποστ και την απάντηση!

alexoudis

αυτο έχει στην γραμμή 39

PRIMARY KEY  (`ID_PICTURE`))", __FILE__, __LINE__);

dotbigboy

Quote from: Nefeli on April 19, 2007, 12:48:30 PM
Ποιες εκδόσεις ακριβώς χρησιμοποιείς; Είναι συμβατές;

Άνοιξε το αρχείο galleryinstall.php και βρες τη γραμμή 39. Τι λέει;

Προσθήκη: διάβασε το παρόμοιο ποστ και την απάντηση!

Χρησιμοποιώ SMF 1.1.2 και Gallery1.7.1

στην γραμμή 39 έχει το παρακάτω

PRIMARY KEY  (`ID_PICTURE`))", __FILE__, __LINE__);

Βοηθήστε ρε παιδιά σας παρακαλώ.

Nefeli

Δεν μπορώ να φανταστώ τι φταίει αλλά δοκίμασε το εξής:
1.Κάνε απεγκατάσταση της παλιάς προσπάθειας.
2. Διέγραψε το mod από τη διαχείριση του φόρουμ "Λίστα πακέτων"
3. Πριν επιχειρήσεις νέα εγκατάσταση, πήγαινε στο file manager του cpanel σου και μέσα στο φάκελλο paquages βρες το  συμπιεσμένο αρχείο της gallery και διέγραψέ το. Αν δεν το κάνεις, θα το βρίσκει συνεχώς και θα σου βγάζει σφάλμα (όπως αυτό του alexoudis)
4. Κάνε νέο κατέβασμα από εδώ
5. Ανέβασε ξανά το mod

Πες μας το αποτέλεσμα.

alexoudis

    Εκτέλεση τροποποίησης     ./Themes/default/languages/Modifications.english.php     Επιτυχία
2.    Εκτέλεση τροποποίησης    ./Themes/default/languages/Who.english.php    Επιτυχία
3.    Εκτέλεση τροποποίησης    ./index.php    Επιτυχία
4.    Εκτέλεση τροποποίησης    ./Themes/default/index.template.php    Επιτυχία
5.    Εκτέλεση τροποποίησης    ./Sources/Subs.php    Επιτυχία
6.    Εκτέλεση τροποποίησης    ./Sources/ManagePermissions.php    Επιτυχία
7.    Εξαγωγή Αρχείο    ./Sources/Gallery.php    
8.    Εξαγωγή Αρχείο    ./Themes/default/Gallery.template.php    
9.    Εξαγωγή Δένδρο    ./gallery    
10.    Εξαγωγή Αρχείο    ./Themes/default/languages/Gallery.english.php    
11.    Εξαγωγή Αρχείο    ./Themes/default/languages/Gallery.english-utf8.php    
12.    Εκτέλεση κώδικα    galleryinstall.php


εμάνα πάλι το ίδιο μου κάνει

3. Πριν επιχειρήσεις νέα εγκατάσταση, πήγαινε στο file manager του cpanel σου και μέσα στο φάκελλο paquages βρες το  συμπιεσμένο αρχείο της gallery και διέγραψέ το. Αν δεν το κάνεις, θα το βρίσκει συνεχώς και θα σου βγάζει σφάλμα (όπως αυτό του alexoudis)

απο την βάση δεδομένων λες να σβήσω?

Nefeli

Quote from: alexoudis on April 19, 2007, 04:32:34 PM
   απο την βάση δεδομένων λες να σβήσω?

Από το file manager του cpanel! Μην αγγίξεις τη βάση δεδομένων!!!!!!!!!!

agridoc

  For Greek aeromodellers and our friends around the world  - Greek Button sets for SMF - Greeklish to Greek mod
Δeν αφιερώνω χρόνο για μηνύματα σε greeklish.

dotbigboy

Δοκίμασα τα πάντα.... Ξανά και ξανά συνεχώς βγάζει το ίδιο σφάλμα. Ένα άλλο περίεργο που κάνει είναι ότι μέσα στο Packages εμφανίζετε μερικές φορές ένας φάκελος (temp) με Χ και δεν μπορώ να παρέμβω. Μέσα έχει τα αρχεία της Gallery για την εγκατάσταση. Μήπως εδώ είναι το πρόβλημα?

thanks

Nefeli

April 20, 2007, 01:21:18 PM #9 Last Edit: April 20, 2007, 01:22:53 PM by Nefeli
QuoteΈνα άλλο περίεργο που κάνει είναι ότι μέσα στο Packages εμφανίζετε μερικές φορές ένας φάκελος (temp) με Χ και δεν μπορώ να παρέμβω. Μέσα έχει τα αρχεία της Gallery για την εγκατάσταση. Μήπως εδώ είναι το πρόβλημα?

Αυτό καταλαβαίνω και εγώ, είναι όμως πολύ περίεργο!
Ποιος δημιούργησε το φάκελλο temp και μάλιστα μέσα στα Paquages;
Προσθήκη: Τι εννοείς "με Χ";;;;;; ::)

Και εγώ έχω εγκατεστημένη τη προηγούμενη έκδοση αλλά μέσα στα Paquages έχει μόνο τα ζιπαρισμένα mod και μερικά άλλα αρχεία.

Εγώ στη θέση σου θα έσβυνα το φάκελλο temp τελείως όπως και το ζιπαρισμένο αρχείο της gallery. Θα απεγκαθιστούσα το mod και θα το εγκαθιστούσα ξανά όπως περιγράφω πιο πάνω.
Μου φαίνεται παράλογο το temp να το δημιουργεί η εγκατάσταση της gallery. Αν αυτό συμβαίνει, με αυτή τη διαδικασία θα σιγουρευτείς.
Πες μας το αποτέλεσμα όποιο κι αν είναι.

dotbigboy

Nefeli δεν γίνετε τίποτα τελικά. Τα διέγραψα όλα και έκανα εγκατάσταση από τη αρχή, το αποτέλεσμα το ίδιο. Πιθανόν κάτι να πήγε στραβά στην αναβάθμιση του φόρουμ και βγάζει προβλήματα. :(

thanks

dimitrak

April 21, 2007, 11:36:42 AM #11 Last Edit: April 21, 2007, 11:45:01 AM by dimitr@k
Γεια χαρά...

Εχθές έκανα και εγώ εγκατάσταση του mod.
Όμως όπως όλα τα mod που έχω εγκαταστήσει, την εγκατέστησα και αυτή manual.

Το galleryinstall.php μου έβγαλε και εμένα errors.
Συγκεκριμένα εμένα δεν καταλάβαινε το db_query οπότε δεν προχώραγε...

Έτσι λοιπόν, το έριξα μέσα από την MySQL :


//Picture Table
CREATE TABLE IF NOT EXISTS `smf_gallery_pic`(
`ID_PICTURE` int(11) NOT NULL auto_increment,
`ID_MEMBER` mediumint(8) unsigned NOT NULL default '0',
`date` int(10) unsigned NOT NULL default '0',
`title` VARCHAR(100) NOT NULL,
`description` text,
`views` int(10) NOT NULL default '0',
`filesize` int(10) NOT NULL default '0',
`height` int(10) NOT NULL default '0',
`width` int(10) NOT NULL default '0',
`filename` tinytext,
`thumbfilename` tinytext,
`commenttotal` int(10) NOT NULL default '0',
`ID_CAT` int(10) NOT NULL default '0',
`approved` tinyint(4) NOT NULL default '0',
`allowcomments` tinyint(4) NOT NULL default '0',
`keywords` VARCHAR(100) NOT NULL,
PRIMARY KEY  (`ID_PICTURE`));


//Picture comments
CREATE TABLE IF NOT EXISTS `smf_gallery_comment`(
`ID_COMMENT` int(11) NOT NULL auto_increment,
`ID_PICTURE` int(11) NOT NULL,
`ID_MEMBER` mediumint(8) unsigned NOT NULL default '0',
`approved` tinyint(4) NOT NULL default '0',
`comment` text,
`date` int(10) unsigned NOT NULL default '0',
PRIMARY KEY  (`ID_COMMENT`));

//Gallery Category
CREATE TABLE IF NOT EXISTS `smf_gallery_cat`
(`ID_CAT` mediumint(8) NOT NULL auto_increment,
`title` VARCHAR(100) NOT NULL,
`description` VARCHAR(255) NOT NULL,
`roworder` mediumint(8) unsigned NOT NULL default '0',
`image` VARCHAR(255) NOT NULL,
PRIMARY KEY  (`ID_CAT`));


//Gallery Reported Images
CREATE TABLE IF NOT EXISTS `smf_gallery_report`
(`ID` int(11) NOT NULL auto_increment,
`ID_PICTURE` int(11) NOT NULL,
`ID_MEMBER` mediumint(8) unsigned NOT NULL default '0',
`comment` text,
`date` int(10) unsigned NOT NULL default '0',
PRIMARY KEY  (`ID`));

//Insert the settings
REPLACE INTO smf_settings VALUES ('gallery_max_height', '2500');
REPLACE INTO smf_settings VALUES ('gallery_max_width', '2500');
REPLACE INTO smf_settings VALUES ('gallery_max_filesize', '5000000');
REPLACE INTO smf_settings VALUES ('gallery_who_viewing', '0');
REPLACE INTO smf_settings VALUES ('gallery_commentchoice', '0');


Έπαιξε μια χαρά  ;)
Βέβαια δεν έχω εισαγάγει φωτογραφίες ακόμα. Αλλά από Δευτέρα θα ξεκινήσω...

Σημείωση :
Να πω εδώ ότι χρησιμοποίησα και τα μετεφρασμένα από την Eva αρχεία που βρήκα εδώ
[nofollow]

alexoudis

τωρα που άλλαξα theme πώς θα εμφανίσω το μενου της gellery

alexoudis

Καλησπέρα. Πως θα εμφανίσω στο μενού την gallery? Στην διαχήρηση Διαμόρφωση εικονοθήκης την εμφανίζει. Αλλά στο μενού δεν το εκεί το link.
Στο αρχικό template την εικονοθήκη την έχει αλλά μόλις βάζω άλλο template πουθενά το link τι πρέπει να κάνω

Nefeli

Δεν έχω δοκιμάσει άλλο theme εκτός από το default και παραλλαγές που έχω διαμορφώσει κατά την αισθητική μου αλλά κυρίως για να αποφύγω τέτοια ζητηματάκια όπως αυτό που περιγράφεις.

Σαν μια γρήγορη λοιπόν απάντηση στο πρόβλημά σου, θα σου πρότεινα να διαβάσεις το θέμα αυτό και  να προσπαθήσεις να προσθέσεις και εσύ ανάλογο κουμπί στην δική σου εμφάνιση.

Υπάρχουν και οδηγίες για το babylon και το classic εδώ.

Είτε καταφέρεις κάτι, είτε αντιμετωπίσεις δυσκολίες, δημοσίευσέ το σε παρακαλώ εδώ να μαθαίνουμε και μεις  ;) ή, ίσως, να σε βοηθήσουμε περαιτέρω.

alexoudis

Βρέθηκε τελικά λύση. Πήγα στο index.template.php του themes που έχω και πρόσθετα τον παρακάτω κώδικα, και όλα οκ δουλεύει κανονικά   :-* :-* :-* :-* :P :P :P :P ;D ;D ;D ;D :D :D :D





   
Quote// Edit Profile... [profile]
   if ($context['allow_edit_profile'])
      echo '<li><a href="', $scripturl, '?action=gallery">' , $txt[smfgallery_menu] , '</a></li>';

Advertisement: