Advertisement:

Author Topic: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7  (Read 4181 times)

Offline uJam

  • Newbie
  • *
  • Posts: 4
Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« on: April 09, 2007, 09:58:41 AM »
Hello,

Installed SMF (1.1.2), works perfect, compliments for this forum.
I work with Joomla! (1.1.12) so also installed the Bridge (1.1.7).

Now this is what happens:
When I run the SMF stand-alone (non-wrapped) the login works perfect.
In Joomla! the login (for Joomla!) works perfect too.
But...
When I used the forum wrapped, I cannot login into the forum it selves.
I login and am logged in in Joomla! but not in the forum.

This message appears:
An Error Has Occurred!
You were unable to login. Please check your cookie settings.


But I can't imagine that it is a cookie issue, the stand-alone forum works super!

Anyone an idea about what I don't see in here?  :D

Thankx,

DuJam

Offline SlammedDime

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,280
  • School of Air Ride
    • matt.zuba on Facebook
    • @mattzuba on Twitter
Re: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« Reply #1 on: April 09, 2007, 02:08:03 PM »
URL?
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,961
  • Gender: Male
    • Kindred-999 on GitHub
Re: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« Reply #2 on: April 09, 2007, 02:30:51 PM »
you must be using the mod_smf_login module... not the mod_login module that comes with joomla and not the stand-alone forum...
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline uJam

  • Newbie
  • *
  • Posts: 4
Re: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« Reply #3 on: April 09, 2007, 04:33:30 PM »
Thanks for the reply!

AirRideTalk: I'm running the whole stuff on a localhost, no URL yet...

Kindred: As far as I can see I am using the mod_smf_login module to login. The strange thing is that when I'm trying to login it works just a part: The registered Joomla! part of the site is available (I'm logged in) but the (wrapped)  forum still gives the 'cookie message' (and there I'm not logged in).

DuJam

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,961
  • Gender: Male
    • Kindred-999 on GitHub
Re: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« Reply #4 on: April 09, 2007, 04:39:12 PM »
what are your settings in SMF admin > Server settings for Local cookies?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Orstio

  • Guest
Re: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« Reply #5 on: April 09, 2007, 05:35:01 PM »
Quote
I'm running the whole stuff on a localhost

Do you have SMF and Joomla installed in the same database?  On localhost, you will have problems if they are not.

Offline uJam

  • Newbie
  • *
  • Posts: 4
Re: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« Reply #6 on: April 10, 2007, 05:17:14 AM »
Kindred:

Enable local storage of cookies = enabled
   
Use subdomain independent cookies = disabled

Orstio:

I have dutchjam_joom1 and dutchjam_smf, both under 'dutchjam'.
Does that means 1 or 2 database(s)?

DuJam

Orstio

  • Guest
Re: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« Reply #7 on: April 10, 2007, 06:26:36 AM »
Quote
Enable local storage of cookies = enabled

Local cookies should always be disabled when using the bridge.

Offline uJam

  • Newbie
  • *
  • Posts: 4
Re: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« Reply #8 on: April 10, 2007, 08:43:00 AM »
Yes, it works...  :D

However....
Now I can't logout....

This message is shown:
An Error Has Occurred!
Session verification failed. Please try logging out and back in again, and then try again.


I only can logout now by deleting the cookies of localhost by hand....

Orstio

  • Guest
Re: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« Reply #9 on: April 10, 2007, 05:18:17 PM »
Turn off database driven sessions in SMF.

Offline rklegman

  • Newbie
  • *
  • Posts: 5
Re: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« Reply #10 on: April 26, 2007, 11:34:43 AM »
Quote
Enable local storage of cookies = enabled

Local cookies should always be disabled when using the bridge.
What if your cookies are disabled and you still have this problem? I do have a name for the cookie however the subdomain and local cookies on the SMF Forum is disabled (no checkmarks).

Offline rklegman

  • Newbie
  • *
  • Posts: 5
Re: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« Reply #11 on: April 26, 2007, 11:36:11 AM »
Turn off database driven sessions in SMF.
Where is this located and how do you do it please? Will this help resolve the issue being discussed in this thread? I have the same issue when trying to use "Immediate Registration". The issue is NOT present when using "Member Activation".

Offline rklegman

  • Newbie
  • *
  • Posts: 5
Re: Login Problem Joomla! 1.0.12 / SMF 1.1.2 / Bridge 1.1.7
« Reply #12 on: April 26, 2007, 11:48:48 AM »
Turn off database driven sessions in SMF.
I have cookies turned off and the database driven sessions turned off..  I still get the same error using "immediate registration" thru smf forums.  Any other suggestions? "An Error Has Occurred!
You were unable to login. Please check your cookie settings".