News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

User Control Panel ( User CP ) V3.0

Started by Alan S, April 28, 2007, 12:59:54 PM

Previous topic - Next topic

Draffi

Installing v2.2 in SMF 2.0.4

Now i have hundreds of these errors in the error log:

8: Undefined index: usercp_field2enable
Datei: F:/xampp/htdocs/smftest/Themes/default/usercp.template.php
Zeile: 241

(the numbers are changing: field3enable, field4enable....)

I check the languages and all ist there. Somebody an idea?

Kindred

Did you look at the attachment just a few posts up? Posted in January, from me (which was a repost as well)? The one wit the updated usercp.php attachment?
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

TheListener

Not only that but wasn't 3.0 the ltest update?

Draffi

QuoteDid you look at the attachment just a few posts up? Posted in January, from me (which was a repost as well)? The one wit the updated usercp.php attachment?

yes, sir - i was doing and override the old one.
(BTW: Thank you for the work...)

QuoteNot only that but wasn't 3.0 the ltest update?

I don`t know why, but i was a little blond and installed v2.2..... :o

Will check v3

Thank you!!!

electricwildflower

Just wondered if it's been updated or anything to 2.0.5 i uploaded it and it wouldn't let me install as it said not compatible with my version of SMF.

Cool looking mod btw :)

Kindred

you have to use the emulate feature, under the advanced tab....   it works just fine on 2.0.5 - if you use my corrected version of the usercp.php file (although burkeknight did find one error that I made)
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Burke ♞ Knight

Okay, here is a fix for the Ignore Boards button, as it does not show after Kindred's update:

The ignore boards will not show, because the word group inside the call for it.

Sources/usercp.php

Code (Find) Select
'ignore_boards' => array(
'title' => $txt['usercp_ignore_boards'],
'href' => $scripturl . '?action=profile;u=' . $user_info['id'] . ';area=ignoreboards',
'img' => $settings['images_url'].'/usercp/kignore.png',
'txt' => $txt['usercp_ignore_boards_summary'],
'show' => !empty($modSettings['usercp_enable_group_ignore_boards']) &&  !empty($modSettings['allow_ignore_boards']),
),


Code (Replace With) Select
'ignore_boards' => array(
'title' => $txt['usercp_ignore_boards'],
'href' => $scripturl . '?action=profile;u=' . $user_info['id'] . ';area=ignoreboards',
'img' => $settings['images_url'].'/usercp/kignore.png',
'txt' => $txt['usercp_ignore_boards_summary'],
'show' => !empty($modSettings['usercp_enable_ignore_boards']) &&  !empty($modSettings['allow_ignore_boards']),
),

Burke ♞ Knight

Quote from: Kindred on September 05, 2013, 04:13:30 PM
you have to use the emulate feature, under the advanced tab....   it works just fine on 2.0.5 - if you use my corrected version of the usercp.php file (although burkeknight did find one error that I made)

Took me a bit to find it, too.
Only reason I noticed, is I saw it in control panel, but saw it not show up in UserCP.
Then I went hunting, as I changed a few things for personal use. :)

electricwildflower

Thank you i will play around with it when i get the chance :)

shadav

I tried to install this onto 2.0.17
no errors....
when I go to admin > configuration > modification settings

I get

Call to undefined function prepareDBSettingContext()

Kindred

Quote from: Alan S on April 28, 2007, 12:59:54 PM

UserCP V3.0 Released
UserCP V3.0 is for SMF2.0 Beta4 Only!!


that would be your problem, I think....    there were changes to the functions and database since beta4.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

shadav

Quote from: Kindred on June 18, 2020, 11:55:36 AM
Quote from: Alan S on April 28, 2007, 12:59:54 PM

UserCP V3.0 Released
UserCP V3.0 is for SMF2.0 Beta4 Only!!


that would be your problem, I think....    there were changes to the functions and database since beta4.

hm, ok.... yeah that's the one I was trying...

so then I need to use
UserCPV2.2_SMF2.X.zip
for any other 2.x?
I'll try it out later

or do i want to use
UserCPV2.0_Install.zip

after reading the description again it says
UserCP V2.0.2 is for SMF 2.0 Beta releases ONLY

:laugh: i'm confused, but then again that's nothing new

Arantor

This mod isn't available for your SMF version.

shadav

Quote from: Arantor on June 18, 2020, 02:02:26 PM
This mod isn't available for your SMF version.

well that sucks
but thank you for stopping me from trying again and getting frustrated ;D

Shambles

Quote from: shadav
Quote from: Arantor on June 18, 2020, 02:02:26 PM
This mod isn't available for your SMF version.
well that sucks

Well, what "sucks" more is you not reading the application criteria for the mod :P

QuoteUserCP V3.0 is for SMF2.0 Beta4 Only!!

shadav

Quote from: Shambles on June 18, 2020, 03:39:33 PM
Quote from: shadav
Quote from: Arantor on June 18, 2020, 02:02:26 PM
This mod isn't available for your SMF version.
well that sucks

Well, what "sucks" more is you not reading the application criteria for the mod :P

QuoteUserCP V3.0 is for SMF2.0 Beta4 Only!!

:-[ :laugh: true  :laugh:
assumed that i could use the emulate and install for 2.0 Beta or 2.0 Beta 4
not realizing that it wouldn't work on any 2.0.x
fairly sure I had installed this once on a 2.0.13, but then again, I removed it and don't remember exactly why, this may have been the reason why....  :-\

Antechinus

Just out of curiosity I took a look at the functions db. That function wasn't in 2.0 b4 either, so must be a custom one. Which is kinda odd, in that if it's a custom one that comes from install.php* or the mod's templates then you'd expect it to be present if you installed the mod without errors.

*I didn't go as far as checking where it was supposed to come from.

Arantor

Not everything was in the function DB, I think the issue is that it's the right function but not called in a way that was expected after 2.0b4, a lot of change happened after that in RC1.

Antechinus

Y'know, just idly looking at the thing, all it's really doing is re-styling the existing menu to take up the whole wrapper and have chunky icons. You could probably do that very simply. Just throw in a test to append a class to the standard menu on the summary page, and do something like {position:absolute;width:100%;) or whatever on the menu (add extra bits depending on what layout and sizing you want) then add chunky icons to your heart's content (could easily be targeted by link href for each menu link).

Antechinus

Basic proof of concept:

#left_admsection {
width: auto;
float: none;
padding-right: 10px;
}
.adm_section .cat_bar, .left_admmenu li:nth-child(4), .left_admmenu li:nth-child(8) {
display: none;
}
.left_admmenu {
display: inline;
background: transparent;
border: 0;
}
.left_admmenu li {
display: inline-block;
width: 30%;
overflow: hidden;
margin: 1em 1%;
vertical-align: bottom;
padding: 6px 0;
background: #14171B;
border: 1px solid #14171B;
border-top-color: #20272C;
}
.left_admmenu li:after {
display: block;
clear: both;
padding: .7rem;
content: 'Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.';
}
.left_admmenu li a, .left_admmenu li strong a,
.left_admmenu li a:hover, .left_admmenu li strong a:hover {
padding-top: 100px;
text-align: center;
background-image: url('https://avatars.simplemachinesweb.com/smf/avatar_129726_1318378297.png');
background-position: 50% 0;
background-repeat: no-repeat;
}


Looks like the shot. Quite good fun. Might play with it a bit. Running it in Stylem as a separate override to the dark theme, so it only applies on the Summary page. Would be easy to do the same with PHP.

Advertisement: