• Welcome to Simple Machines Community Forum. Please login or sign up.
November 27, 2021, 05:12:00 AM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Welcome Topic

Started by SMFHacks.com Team, May 07, 2007, 09:42:29 PM

Previous topic - Next topic

MadMick

Thank you so much mate, now to wait a little while until a new member joins :)
Regards,

Mick.

AHN Moderators - Can explain it to you, but they can't understand it for you"

mysimplesite

SMF 2.0.14, php 7

Does Welcome Topic automatically add a Welcome Post if the new member registers using a Social Login mod?

I have the registration set for 'email activation' in the Members Settings.

My concern is visitors joining the forum using Facebook or Twitter etc to sign in won't get the Welcome Topic posted in the board I've assigned.

vbgamer45

Not sure probably not.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

mysimplesite

Oh well, still it's a great mod and I thank you for it.


ivanr

I have created a Custom Profile;
First Name
Last Name

How do I put the correct syntex in the Welcome Member Topic
at the moment I have   

Welcome to the UKVGA {username}

How do I change it for First Name and Last name

vbgamer45

You would have to write the code to pull in custom profile fields. You would have to a query before that to load that data.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

ivanr

OK thanks,
Would anybody know what the script is? my PHP coding is very basic. I guess it would go in Managemembers.php under Welcome Topic Mod but I have not a clue on the script.

Our old script when using realname mod with SMF1.1.21 is as below but SMF 2.0.14 Welcome Topic Mod is different.

// Welcome Topic Mod
   require_once($sourcedir . '/Subs-Post.php');
   if ($modSettings['welcome_boardid'] != 0)
   {
      global $db_prefix;
      
      $result = db_query("SELECT welcomesubject, welcomebody FROM {$db_prefix}welcome
       ORDER BY RAND() LIMIT 1", __FILE__, __LINE__);
      if (mysql_num_rows($result) != 0)
      {
         $row2 =  mysql_fetch_assoc($result);

         foreach ($member_info as $member)
         {
                  $msgOptions = array(
                           'id' => 0,
                           'subject' => str_replace("{username}",$member['name'],$row2['welcomesubject']),
                           'body' => str_replace("{username}",$member['name'],$row2['welcomebody']),
                           'icon' => 'xx',
                           'smileys_enabled' => 1,
                           'attachments' => array(),
                        );
                        $topicOptions = array(
                           'id' => 0,
                           'board' => $modSettings['welcome_boardid'],
                           'poll' => null,
                           'lock_mode' => null,
                           'sticky_mode' => null,
                           'mark_as_read' => false,
                        );
                        $posterOptions = array(
                           'id' => $modSettings['welcome_memberid'],
                           'name' => $modSettings['welcome_membername'],
                           'email' => '',
                           'update_post_count' => (($modSettings['welcome_memberid'] == 0) ? 0 : 1),
                        );

            createPost($msgOptions, $topicOptions, $posterOptions);
         }
      }

      mysql_free_result($result);

skb

We use this mod. It works fine if we use email activation. But if we use immediate (direct) activation for new members, it doesn't work. Any suggestions ?

SMF 2.1 RC4 (default theme) / TP 2.1.0

pocttopus

Hello,

For new registrations there is no welcome topic... I must create all these topics by myself.  :-\
What is the issue!?  ???

pocttopus

WelcomeTopic mod is not working... still.  :-\
How can I solve this?  ???

vbgamer45

Check that the mod is completely installed in all parts.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

pocttopus

Quote from: vbgamer45 on November 27, 2018, 12:35:27 PM
Check that the mod is completely installed in all parts.
It was installed without issues and it's not working still.  :-\

vbgamer45

what is your settings for registration
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

pocttopus

Quote from: vbgamer45 on November 27, 2018, 12:49:10 PM
what is your settings for registration
Immediate registration.


Plantje

Hi,

I have a few (perhaps somewhat weird) questions....

I have taken over administration of a forum. I do notice, that a welcome topic is being created for every new user, but I cannot see how... I am completely unable to find the configuration for this. Is it possible, that this mod is installed and I cannot find it in the administration center?

Next to that: after creating the topic I would like to send an E-mail to the specific user notifying them of the just created welcome topic. Currently I do that manually, is it an option to automate that?

Thanks!

Kindred

No, there is no automatic option for that in this or any mod
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Plantje

Ok, thanks. That's too bad.

And as for the first question, any idea? Would it be possible I have a mod installed (like this one) that is currently working, but no settings can be found?

vbgamer45

Yes possible if doesn't install correctly. This does require configuring before it works so don't think it would be this one.
Other issue if you have a different language other than english then to apply the edits to your themes/default/languages/modifications.*.php files
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Plantje

I really can't think of any other mod that is installed that may cause this. I am still going through all of them :(

No, everything is still in English. Where would the configuration be for this one?

Advertisement: