• Welcome to Simple Machines Community Forum. Please login or sign up.
September 26, 2021, 01:55:20 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


[Theme] Themis (SMF v1.0.5 - 1.1RC2)

Started by bloc, October 03, 2004, 03:24:05 AM

Previous topic - Next topic

RCHawaii

October 19, 2004, 12:58:31 AM #40 Last Edit: October 19, 2004, 01:01:21 AM by RCHawaii
LOL - thanks I need a hammer on my head smiley- :S I will still need to know how to remove my problem with Themis :S - if anyone can help me locate wheer it inserts the information, I would appreciate it.

bloc

You have to be careful when putting other stuff than pure html - just adding functions from other scripts for instance WILL probably produce errors...! :o

Alright , with that out of the way, just upload this file, ( it will not use the sidebar data), go to admin section and edit out the offending bits, and just reupload your original Themis file(of the same name).

http://www.bloczone.net/files/themis/themis-fix.zip


RCHawaii

Thank you Bloc -I really appreciate it.

ViSioNaRy

Bloc is Awesome that way!

A personal thanks for the fantastic work you do! 
ViSioNaRy   ;D

bloc

Updated the theme for use with RC2.

New is 3 pre-configured color-sets , easy set in the admin section. See first post for details.

overhaul

There is a problem with the "Themis" theme  (at least it's a problem on my site)

While in theme settings,  (Theme Settings - Themis)  I was getting error accessing the following 2 links

- Modify the index template. (the main template)
- Modify the style.css file. (colors, fonts, etc.)

The error is
An Error Has Occurred!
The file you are trying to edit... can't even be found!

the code is trying to specify theme id using variabe "theme"  but I changed it to "id" to fix it.

broke: http://www.<url>/smf/index.php?action=theme;sa=edit;theme=3;style;sesc=1blahblah
works: http://www.<url>/smf/index.php?action=theme;sa=edit;id=3;style;sesc=18de6blahblah



I tried searching to see if it is known problem but could not find any mention of it.


[Unknown]

Themis doesn't include a copy of the Themes template, does it?

-[Unknown]

bloc

Hm, I thought I changed those. Its one of the changes from RC1 to RC2 and its mentioned in changelog-themes.txt - you will find it in your forum directory (if you have upgraded to RC2).

Thanks for letting me know.

bloc

Quote from: [Unknown] on November 11, 2004, 07:23:27 PM
Themis doesn't include a copy of the Themes template, does it?

-[Unknown]

Yes, it does. Its merely cosmetic changes though and the sidebar thing...I will implement them on the RC2 themes-template instead of changing the RC1 one.

overhaul

yes it does.   I changed only 5 entries still referring to "theme" in Themes.template.php. 

lines 211, 246, 276, 317, 318.

Burpee

Hmm... Bloc, perhaps you should add a title= tag with the same text as the alt tag for each of the buttons at the bottom of the display template.

When you're using FireFox, nothing pops up when you hover over those buttons.

bloc

November 17, 2004, 03:38:43 PM #51 Last Edit: November 17, 2004, 03:40:44 PM by Bloc
Quite right! Thanks for the heads-up. :) I will change those as soon as possible.

I see now it affects all the buttons really. Is it like this in default theme also? Have to check, but then again the buttons HAVE strings there, where Themis is just icons.

patkas

I have looked at the link anfdthe theme looks very very good.

can you explane to me how i can install the theme on my forum.

Regards,

patrick
:)

bloc

Quote from: patkas on November 18, 2004, 01:53:17 AM
I have looked at the link anfdthe theme looks very very good.

can you explane to me how i can install the theme on my forum.

Regards,

patrick
:)

Just unzip the contents in the themis.zip into a folder inside the Themes folder . Then go to admin section, and choose "install theme from folder" - put the name of the folder at the end and erase the name in the last textfield. then say "yes" to "install new theme?"

bloc

Update.
Firefox  now displays correctly the "alt" text when hovering over the buttons.

Thanks to Burpee for pointing it out. :)

BTW, I am now using Firefox - love the extras, especially the BBcode helper..! ;)

Burpee

Did you install the Web Developer Toolbar yet? :D


Eris Siva

November 19, 2004, 01:08:50 AM #57 Last Edit: November 19, 2004, 01:11:00 AM by Eris Siva
LOVE the theme, but I need to know how to made it fixed width....
Currently I'm using Curve, but that's only a place-holder while I work with Themis behind the scenes...


Anyways - I would really love to have it match my front page (http://www.zanthria.com), but all I can get it to do is slide all the way over to the left side of the screen. :P

This is what I inserted in the CSS to do that:

body
{
   align: center;
   margin: 20px auto;
   width: 760px;
   padding: 0px;
}


Bah! I'm stuck!!!   
You can see the result here: http://community.zanthria.com/index.php?theme=7

What am I doing wrong/not doing at all?

bloc

Use the original Themis files again, and find this in index.template.php:

echo '
</head>
<body style="margin-left: 20px; margin-right: 20px;"><table width="100%" cellpadding="0" cellspacing="0">';


Replace with this (change 800 to your preference) :

echo '
</head>
<body style="margin-left: 20px; margin-right: 20px;"><table width="800" cellpadding="0" cellspacing="0" align="center">';


just a note...if you use the sidebar, it will be included in the total width, making the forum even smaller. So if you want it to stay centered and same width, just dont use the sidebar at all.

Eris Siva

Awesome....One step closer to getting them matching. ;)
Thank you.


Actually, if anyone would be willing to help me match the .CSS files (both of the scripts [WordPress and SMF 1.0 preview] run off of CSS mainly), I would be grateful beyond belief.

Advertisement: