Advertisement:

Author Topic: MouseOver: topic preview!  (Read 213223 times)

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: MouseOver: topic preview!
« Reply #80 on: February 18, 2006, 09:47:05 PM »
The Recent.template.php should handle all of that :)
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline rosey

  • Jr. Member
  • **
  • Posts: 178
Re: MouseOver: topic preview!
« Reply #81 on: February 21, 2006, 09:13:44 AM »
in my recent.template.php, the only line with [first_post][link] in it is this one:

&#39; , $topic[&#39;is_sticky&#39;] && !empty($settings[&#39;seperate_sticky_lock&#39;]) ? &#39;<img src="&#39; . $settings[&#39;images_url&#39;] . &#39;/icons/show_sticky.gif" align="right" alt="" style="margin: 0;" />&#39; : &#39;&#39;, &#39; &#39;, $topic[&#39;first_post&#39;][&#39;link&#39;], &#39; <a href="&#39;, $topic[&#39;new_href&#39;], &#39;"><img src="&#39;, $settings[&#39;images_url&#39;], &#39;/&#39;, $context[&#39;user&#39;][&#39;language&#39;], &#39;/new.gif" alt="&#39;, $txt[302], &#39;" /></a> <span class="smalltext">&#39;, $topic[&#39;pages&#39;], &#39;


but if I use that line to put the preview stuff in, it messes up any sticky threads that show in the recent threads - it puts the preview line right there on top of the thread topic...  I really want to make this work with the 'view unread posts since last visit' feature...

Offline TinaCat

  • Newbie
  • *
  • Posts: 5
  • Gender: Female
    • JustUsers.net
Re: MouseOver: topic preview!
« Reply #82 on: February 22, 2006, 04:37:45 AM »

Rosey, try this code.
I use this code in my forum.


<td class="windowbg&#39; , $topic[&#39;is_sticky&#39;] && !empty($settings[&#39;seperate_sticky_lock&#39;]) ? &#39;3&#39; : &#39;&#39; , &#39;" width="48%" valign="middle" title="&#39;, $topic[&#39;first_post&#39;][&#39;preview&#39;], &#39;">&#39; , $topic[&#39;is_locked&#39;] && !empty($settings[&#39;seperate_sticky_lock&#39;]) ? &#39;
<img src="&#39; . $settings[&#39;images_url&#39;] . &#39;/icons/quick_lock.gif" align="right" alt="" style="margin: 0;" />&#39; : &#39;&#39; , $topic[&#39;is_sticky&#39;] && !empty($settings[&#39;seperate_sticky_lock&#39;]) ? &#39;
<img src="&#39; . $settings[&#39;images_url&#39;] . &#39;/icons/show_sticky.gif" align="right" alt="" style="margin: 0;" />&#39; : &#39;&#39;, $topic[&#39;first_post&#39;][&#39;link&#39;], &#39; <a href="&#39;, $topic[&#39;new_href&#39;], &#39;"><img src="&#39;, $settings[&#39;images_url&#39;], &#39;/&#39;, $context[&#39;user&#39;][&#39;language&#39;], &#39;/new.gif" alt="&#39;, $txt[302], &#39;" /></a>
hxxp:www.justusers.net/forums/index.php [nonactive]

Offline True Knight

  • Semi-Newbie
  • *
  • Posts: 26
  • Gender: Male
Re: MouseOver: topic preview!
« Reply #83 on: March 20, 2006, 11:05:05 PM »
I think my code has been modified by another Mod....how can I add the code I need? Here's my code.

Code: [Select]
', $topic['first_post']['link'], ' ', $topic['new'] && $context['user']['is_logged'] ? '<a href="' . $scripturl . '?topic=' . $topic['id'] . '.msg' . $topic['new_from'] . '#new"><img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/new.gif" alt="' . $txt[302] . '" border="0" /></a>' : '', ' <span class="smalltext">', $topic['pages'], '</span></td>

How do I edit this to use the mouseover feature...I tried the mod but it didn't fix it.

Thanks

Offline TheGamer

  • Sophist Member
  • *****
  • Posts: 1,040
  • Gender: Male
Re: MouseOver: topic preview!
« Reply #84 on: June 17, 2006, 02:04:15 AM »
I cannot get this to work in 1.1 RC2. Please help!

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: MouseOver: topic preview!
« Reply #85 on: June 17, 2006, 01:44:16 PM »
There is a mod for this.  Do a search in the mod site.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline JustJen

  • Jr. Member
  • **
  • Posts: 192
  • Step away from the admin panel, Jen....
Re: MouseOver: topic preview!
« Reply #86 on: August 25, 2006, 12:49:12 PM »
HELP! I applied the mod as described on pg 1 and it works, but my table is now out of allignment.

Here's a visual.

Offline snork13

  • SMF Friend
  • Sophist Member
  • *
  • Posts: 1,305
  • Gender: Male
  • so little time
    • simplemachines.org
Re: MouseOver: topic preview!
« Reply #87 on: August 25, 2006, 01:20:24 PM »
HELP! I applied the mod as described on pg 1 and it works, but my table is now out of allignment.

Here's a visual.


I don't know how the colspan got messed up, but you could undo the changes made and try the mod link below via the package manager. It looks like your using a custom theme, so check the mod install on the default theme first, then you can make the same changes to your custom theme.

http://mods.simplemachines.org/index.php?mod=263


-Snork13
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

Offline JustJen

  • Jr. Member
  • **
  • Posts: 192
  • Step away from the admin panel, Jen....
Re: MouseOver: topic preview!
« Reply #88 on: August 25, 2006, 01:31:05 PM »
Actually, it's the classic theme. I undid the changes and now have bigger text. Ugh.

Offline snork13

  • SMF Friend
  • Sophist Member
  • *
  • Posts: 1,305
  • Gender: Male
  • so little time
    • simplemachines.org
Re: MouseOver: topic preview!
« Reply #89 on: August 25, 2006, 06:11:59 PM »
Actually, it's the classic theme. I undid the changes and now have bigger text. Ugh.
if you no other modifications, then just upload the original file to your classic theme, and try it again...
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

Offline realdeal

  • Semi-Newbie
  • *
  • Posts: 51
    • SmackDown Vs. Raw 2007
Re: MouseOver: topic preview!
« Reply #90 on: September 07, 2006, 08:07:22 PM »
I can't get this to work!!! I am using 1.1 RC3.

Offline JustJen

  • Jr. Member
  • **
  • Posts: 192
  • Step away from the admin panel, Jen....
Re: MouseOver: topic preview!
« Reply #91 on: September 08, 2006, 08:27:15 AM »
I can get it to work in any theme except the one I'm using-YaBB Classic. Why's that?  ???

Offline snork13

  • SMF Friend
  • Sophist Member
  • *
  • Posts: 1,305
  • Gender: Male
  • so little time
    • simplemachines.org
Re: MouseOver: topic preview!
« Reply #92 on: September 08, 2006, 05:49:57 PM »
I can get it to work in any theme except the one I'm using-YaBB Classic. Why's that?  ???

the mod only installs on the default smf theme, you will need to install on your custom theme manually. check out the modification xml.

-Snork13
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

Offline snork13

  • SMF Friend
  • Sophist Member
  • *
  • Posts: 1,305
  • Gender: Male
  • so little time
    • simplemachines.org
Re: MouseOver: topic preview!
« Reply #93 on: September 08, 2006, 05:51:43 PM »
I can't get this to work!!! I am using 1.1 RC3.

doesn't help me tech you at all. i suspect you have another mod installed or are not using the default theme.

-Snork13
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

Offline JustJen

  • Jr. Member
  • **
  • Posts: 192
  • Step away from the admin panel, Jen....
Re: MouseOver: topic preview!
« Reply #94 on: September 08, 2006, 10:00:49 PM »
I can get it to work in any theme except the one I'm using-YaBB Classic. Why's that?  ???

the mod only installs on the default smf theme, you will need to install on your custom theme manually. check out the modification xml.

-Snork13
okay, but why would it then work on another downloaded theme?

Offline danskmacabre

  • Semi-Newbie
  • *
  • Posts: 90
Re: MouseOver: topic preview!
« Reply #95 on: November 09, 2006, 05:18:50 AM »
I can get it to work in any theme except the one I'm using-YaBB Classic. Why's that?  ???

the mod only installs on the default smf theme, you will need to install on your custom theme manually. check out the modification xml.

-Snork13
okay, but why would it then work on another downloaded theme?

One reason why it might work on another theme is if the other theme doesn't use a file that the mod is coded into (Meaning it might not have costom code using the files hte mod changes).
If t hat is the case, the other theme will go back to the default theme files and use them, which have the mod installed.

what you need to do is find out which files are modded (check out the mod file ) and insert the new code (or change your existing code, this can be sometimes tricky depending on how complex your theme is).


Website: cantref.org.uk chaos8.com | SmF version: 2 | Portal software: PortaMx 1.3 | Default theme: Coal Black

Offline JustJen

  • Jr. Member
  • **
  • Posts: 192
  • Step away from the admin panel, Jen....
Re: MouseOver: topic preview!
« Reply #96 on: December 12, 2006, 08:21:12 AM »
YIPPEE!! I got it to work!!

t.osberger

  • Guest
Re: MouseOver: topic preview!
« Reply #97 on: January 22, 2007, 07:59:34 PM »
Hello!

I was reading this thread, downloaded the mod and installed it.  It shows in the list that it is installed.  I'll just bet the reason that is not working is that I am using an alternate theme, as opposed to the default (actually using v1.1.1 - Ancient_and_Rusty).

So, to anyone who can assist, I would like to know how to make this work with the theme I currently using (or all themes - that would work too).  Such a nice feature I would hate to find that we can't use without using the default theme.

I look forward to any form of assistance.



Offline waggles

  • Semi-Newbie
  • *
  • Posts: 10
Re: MouseOver: topic preview!
« Reply #98 on: January 29, 2007, 09:45:51 PM »
Very nice. Works almost too well.

Offline perro88

  • Jr. Member
  • **
  • Posts: 358
    • techcoreforum
Re: MouseOver: topic preview!
« Reply #99 on: August 21, 2007, 11:29:59 PM »
I´m using smf 1.1.3 with tinyportal but this don´t work. on the admin section the option to show the max numbers of chars is showed but when i hover a topic nothing is showed.I tried in more than one smf 1.1.3 and didn´t worked in both. it install with any errors and I give it a look to the code changed and all seems in good place but nothing showed.
I tried on the theme I have that is a copy of the default and didn´t even have modified files by the mod and tried on the default and didn´t work either. Any idea about this? would be very apreciated
« Last Edit: August 21, 2007, 11:43:32 PM by perro88 »