News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Bookmarks

Started by Matthew K., July 16, 2007, 01:07:24 PM

Previous topic - Next topic

127.0.0.1

When deleting a topic,

QuoteFatal error:  Function name must be a string in forum/Sources/RemoveTopic.php on line 380

Line 380 is the first line in this block of code,    $smcFunc['db_query']('', '
        DELETE FROM {db_prefix}bookmarks
        WHERE id_topic IN ({array_int:topics})',
            array(
                'topics' => $topics,
            )
    );


I am using SMF 1.1.1

Aaron

Quote from: 127.0.0.1 on May 29, 2008, 02:38:36 PM
When deleting a topic,

QuoteFatal error:  Function name must be a string in forum/Sources/RemoveTopic.php on line 380

I am using SMF 1.1.1

You downloaded and installed the wrong version of the bookmarks mod. Version 1.x of the bookmarks mod is for SMF 1.1.x, and version 2.x is for SMF 2.0 beta 3!

127.0.0.1

Thanks for taking the time to reply.

I did download and install bookmarks11.zip. The package manager also reported a successful installation.

I also looked at the manual installation instructions exclusively for version 1.1.1: Bookmarks - Installation Instructions for 1.1.1.

The instructions say to,


./Sources/Subs.php

Find: [Select]
'login' => array(
'title' => $txt['login'],
'href' => $scripturl . '?action=login',
'show' => $user_info['is_guest'],
'sub_buttons' => array(
),
),
Add After: [Select]
'bookmarks' => array(
'title' => $txt['bookmarks'],
'href' => $scripturl . '?action=bookmarks',
'show' => !$user_info['is_guest'],
'sub_buttons' => array(
),
),


But I cannot find that anywhere in my Subs.php. I searched for 'login' => array and it is found nowhere in my Subs.php

Aaron

Seeing those instructions, that's definitely the version for SMF 2.0 you've downloaded.

christinedlrp

What is the actual file name of the the bookmark button for the default theme?  I don't see it anywhere?  ???

127.0.0.1

I am having problems with this mod and SQL. The mod installed fine and works great now. However, a problem arises here when I try to import my form database using phpMyAdmin.

I export the database in SMF's forum maintainance section. Then on my local web server using phpMyAdmin I import the database file and I get the following message...


Error

SQL query:

CREATE  TABLE  `bbs_bookmarks` (ID_MEMBER mediumint( 8  )  unsigned NOT  NULL default  '',
ID_TOPIC mediumint( 8  )  unsigned NOT  NULL default  '',
UNIQUE ID_MEMBER( ID_MEMBER, ID_TOPIC ) ) TYPE  =  MYISAM ;

     
     MySQL said: Documentation   #1067 - Invalid default value for 'ID_MEMBER'

-------------------
Bookmarks1.1 / SMF 1.1.1 / PHP5 / Apache2 / phpMyAdmin 2.11.6

ccbtimewiz

When you made a backup of the database, did you include table structure?

Greenarts

Is there a bookmarks.gif for the Babylon theme somewhere?

FireFreezer

german translation:


<file name="$languagedir/Modifications.german.php" error="ignore">
<operation error="ignore">
<search position="end" />
        <add><![CDATA[
$txt['bookmarks'] = 'Meine Lesezeichen';
$txt['bookmark_not_for_guests'] = 'Sorry, nur registrierte User können diese Funktion nutzen!';
$txt['bookmark_list'] = 'Lesezeichen';
$txt['bookmark_list_empty'] = 'Du hast momentan keine Lesezeichen angelegt. Dies kannst du mit \'Lesezeichen hinzufügen\' in den Threads erledigen.';
$txt['bookmark_open_window'] = 'In neuem Fenster öffnen';
$txt['bookmark_delete'] = 'Lesezeichen löschen';
$txt['bookmark_delete_success'] = '%1$s Lesezeichen wurden erfolgreich gelöscht!';
$txt['bookmark_delete_failure'] = 'Nicht alle Lesezeichen konnten gelöscht werden.';
$txt['bookmark_add'] = 'Lesezeichen hinzufügen';
$txt['bookmark_add_success'] = 'Thread erfolgreich Deinen Lesezeichen hinzugefügt!';
$txt['bookmark_add_exists'] = 'Dieser Thread befindet sich bereits in Deinen Lesezeichen!';
$txt['bookmark_add_failed'] = 'Es ist ein Fehler beim hinzufügen des Threads zu Deinen Lesezeichen aufgetreten!';
]]></add>
    </operation>
</file>

<file name="$languagedir/Modifications.german-utf8.php" error="ignore">
<operation error="ignore">
<search position="end" />
        <add><![CDATA[
$txt['bookmarks'] = 'Meine Lesezeichen';
$txt['bookmark_not_for_guests'] = 'Sorry, nur registrierte User k&ouml;nnen diese Funktion nutzen!';
$txt['bookmark_list'] = 'Lesezeichen';
$txt['bookmark_list_empty'] = 'Du hast momentan keine Lesezeichen angelegt. Dies kannst du mit \'Lesezeichen hinzuf&uuml;gen\' in den Threads erledigen.';
$txt['bookmark_open_window'] = 'In neuem Fenster &ouml;ffnen';
$txt['bookmark_delete'] = 'Lesezeichen l&ouml;schen';
$txt['bookmark_delete_success'] = '%1$s Lesezeichen wurden erfolgreich gel&ouml;scht!';
$txt['bookmark_delete_failure'] = 'Nicht alle Lesezeichen konnten gel&ouml;scht werden.';
$txt['bookmark_add'] = 'Lesezeichen hinzuf&uuml;gen';
$txt['bookmark_add_success'] = 'Thread erfolgreich Deinen Lesezeichen hinzugef&uuml;gt!';
$txt['bookmark_add_exists'] = 'Dieser Thread befindet sich bereits in Deinen Lesezeichen!';
$txt['bookmark_add_failed'] = 'Es ist ein Fehler beim hinzuf&uuml;gen des Threads zu Deinen Lesezeichen aufgetreten!';
]]></add>
    </operation>
</file>


greets and thx for this mod :)

Aaron

Quote from: Greenarts on June 22, 2008, 09:41:17 AM
Is there a bookmarks.gif for the Babylon theme somewhere?

I've attached one to this post. :)

Quote from: FireFreezer on June 25, 2008, 09:25:55 AM
german translation:

greets and thx for this mod :)

Thanks, FireFeeler!

SunilDVR

Hi Aäron,

I've been using this mod for several months on a reasonably well-frequented boards, and I've been very happy with it so far. I've done the default install with the package installer, but also manually installed it into Helios Multi.

I've only just checked the Error log for the first time since then (not needed to, I probably should more often!) and there are 998 pages of errors...

... the vast majority of them (well, that I can see!) seem to be in index.php referencing the Helios display_template, and one of two types:

Quote
8: Undefined index: Bookmark
File: <path>/forum/Themes/helios_multi11final/Display.template.php (main sub template - eval?)
Line: 234

Quote
8: Use of undefined constant Bookmark - assumed 'Bookmark'
File: <path>/forum/Themes/helios_multi11final/Display.template.php (main sub template - eval?)
Line: 234

Have you come across this before, and do you know of a "quick fix"? I could probably work it out given some time, but I'm not that familiar with the internal workings of themes so it would take a while. I'm happy to do this, but if you've come across the problem before and know how to sort it out quickly, that would be very helpful!

Thanks,

Sunil


Aaron

Hi Sunil,

Could you post line 234 and the surrounding lines in the Display.template.php file here please?

Aaron

LinK187

this is the result of the pre-install test:

Quote
1. Execute Modification ./index.php Test successful
2. Execute Modification ./Sources/RemoveTopic.php Test successful
3. Execute Modification ./Themes/default/index.template.php Test failed
4. Execute Modification ./Themes/default/Display.template.php Test successful
5. Execute Modification ./Themes/default/languages/Modifications.dutch.php Test successful
6. Execute Modification ./Themes/default/languages/Modifications.english.php Test successful
7. Extract File ./Sources/Bookmarks.php 
8. Extract File ./Themes/default/Bookmarks.template.php 
9. Execute Code install.php

Do i procede anyway?

ccbtimewiz

Proceed and attach your index.template.php file.

LinK187

Would it not be wiser to post the index.template.php first instead of ******ing up my forum first?

SunilDVR

Quote from: Aäron on June 28, 2008, 08:20:47 PM
Could you post line 234 and the surrounding lines in the Display.template.php file here please?

Hi Aaron,

Here are lines 232-236. Line 234 is the one beginning "$buttonArray[]" immediately after "if($context['can_reply'])"


//Helios bookmarks Edit here
        if ($context['can_reply'])
                $buttonArray[] = '<a href="' . $scripturl . '?action=bookmarks;sa=add;topic=' . $context['current_topic'] . '.' . $context['start'] . '.0;do=Bookmark' . $context['bookmark_message'] . '">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/addbm1.gif" alt="' . $txt[Bookmark] . '" border="0" />' : $txt[Bookmark]) . '</a>';       
        if ($context['can_mark_notify'])
                $buttonArray[] = '<a href="' . $scripturl . '?action=notify;sa=' . ($context['is_marked_notify'] ? 'off' : 'on') . ';topic=' . $context['current_topic'] . '.' . $context['start'] . ';sesc=' . $context['session_id'] . '" onclick="return confirm(\'' . ($context['is_marked_notify'] ? $txt['notification_disable_topic'] : $txt['notification_enable_topic']) . '\');">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/notify.gif" alt="' . $txt[131] . '" border="0" />' : $txt[131]) . '</a>';



Thanks,

Sunil

Eddy Matthews

Is it possible to have this mod so that it can be used to "bookmark" individual messages, rather than an entire topic? That would be much more useful for my users if it was possible....

Regards
Eddy


cr34t1v3

Hi Aaron,
I installed this mod and just realize that it isn't working in my site.
I've checked the installation manually, and found nothing wrong.
Here is the case, I try to bookmark a topic, but my bookmark list says: You don't have any bookmarks at the moment. Add one by clicking 'Add bookmark' in topics.
I tried to re-bookmark that topic again, and it says: This topic is already listed in your bookmarks! and below that: You don't have any bookmarks at the moment. Add one by clicking 'Add bookmark' in topics.

Am I missing something?
i run on 1.1.5+tp0.9.8
Notebook & Computer Online Store in Indonesia:
http://www.anugrahpratama.com
Computer & Notebook Forum in Indonesia:
http://forum.anugrahpratama.com
Computer & Laptop Review & News Blog:
http://blog.anugrahpratama.com

Aaron

Quote from: Eddy Matthews on June 30, 2008, 04:35:12 AM
Is it possible to have this mod so that it can be used to "bookmark" individual messages, rather than an entire topic? That would be much more useful for my users if it was possible....

Not at the moment, sorry. I might add something like that in the future, though.

Quote from: cr34t1v3 on July 02, 2008, 10:07:47 AM
I tried to re-bookmark that topic again, and it says: This topic is already listed in your bookmarks! and below that: You don't have any bookmarks at the moment. Add one by clicking 'Add bookmark' in topics.

Am I missing something?
i run on 1.1.5+tp0.9.8

Which version of PHP and MySQL power your server? You can find this information in Admin -> Support and Credits.

cr34t1v3

Quote from: Aäron on July 04, 2008, 06:34:04 PM
Which version of PHP and MySQL power your server? You can find this information in Admin -> Support and Credits.

Forum version: SMF 1.1.5 (more detailed)
Current SMF version: SMF 1.1.5
PHP version: 5.2.5
MySQL version: 5.0.51a-community
Server version: Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635
GD version: bundled (2.0.34 compatible)

Notebook & Computer Online Store in Indonesia:
http://www.anugrahpratama.com
Computer & Notebook Forum in Indonesia:
http://forum.anugrahpratama.com
Computer & Laptop Review & News Blog:
http://blog.anugrahpratama.com

Advertisement: