News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Bookmarks

Started by Matthew K., July 16, 2007, 01:07:24 PM

Previous topic - Next topic

Mick.

Quote from: searchgr on January 29, 2010, 01:58:22 AM
Quote from: BlueDevil on January 28, 2010, 05:11:29 PM
Quote from: Eclipse16V on January 19, 2010, 12:12:51 AM
Work on 2.0RC2

Yes indeed.

It doesn't work here. smf 2.0 rc2
Aäron, can you please update it?

It does work if installed manually using the parser.

p1tereq

Problem is that the parser is not working for SMF 2.0 RC2.
Seeing the beauty of diversity in...

KensonPlays

And I don't like using the parser, manually editing takes too much time...

Mick.

Quote from: p1tereq on January 29, 2010, 10:15:24 AM
Problem is that the parser is not working for SMF 2.0 RC2.

True.   Use the parser for 2.0 Beta 4   

I believe thats the one i used for my RC2 forum.

p1tereq

Quote from: BlueDevil on January 29, 2010, 11:25:36 AM
Quote from: p1tereq on January 29, 2010, 10:15:24 AM
Problem is that the parser is not working for SMF 2.0 RC2.

True.   Use the parser for 2.0 Beta 4   

I believe thats the one i used for my RC2 forum.

Yeah, it's working - thanks buddy.
Seeing the beauty of diversity in...

Mick.

Quote from: p1tereq on January 30, 2010, 02:20:58 AM
Quote from: BlueDevil on January 29, 2010, 11:25:36 AM
Quote from: p1tereq on January 29, 2010, 10:15:24 AM
Problem is that the parser is not working for SMF 2.0 RC2.

True.   Use the parser for 2.0 Beta 4   

I believe thats the one i used for my RC2 forum.

Yeah, it's working - thanks buddy.
No problem.

rgecy

Any word if this mod will be released for rc2?  I am trying to keep manual edits to a minimum!

Thanks,

RGecy

KensonPlays

Quote from: rgecy on February 04, 2010, 07:58:29 AM
Any word if this mod will be released for rc2?  I am trying to keep manual edits to a minimum!
DITTO!!

rgecy

Ok, I installed the mod by manually inserting the code, am I missing something?  Somehow the database fields need to be created.  I am getting this error:

Table 'sid0908711353209.smf_bookmarks' doesn't exist
File: /home/content/*/*/*/*****/html/forums/Sources/Bookmarks.php
Line: 153

What did I miss?

Also, is there a way to make it so the SMF Installer would not check the file version or can we make it so the package is not set to a specific version of 2.0 so it will install on RC2?

Thanks,

RGecy

Arantor

You didn't run the install script - it's a PHP file inside the mod package. Find the one for your SMF version, IIRC you put it into the folder where SSI.php and just browse to it (though its been a while)

rgecy

Ok, Now I am getting this error.  I had tried this last night and got the same thing.

Fatal error: Function name must be a string in /home/content/*/*/*/*****/html/forums/install.php on line 4

This is the code in the Install.php.

<?php
global $smcFunc;

$smcFunc['db_create_table']('bookmarks',
array(
array(
'name' => 'id_member',
'type' => 'mediumint',
'size' => 8,
),
array(
'name' => 'id_topic',
'type' => 'mediumint',
'size' => 8,
),
),
array(
array(
'name' => 'bookmark',
'type' => 'unique',
'columns' => array('id_member''id_topic'),
),
),
array(),
'ignore');
?>




Robert

searchgr

It;s a pity that this mod has not been updated yet.

Arantor

rgecy: Argh.

Code (find) Select
global $smcFunc;

Code (add before it) Select
require('SSI.php');

searchgr: The author is busy trying to work on SMF itself... which would you rather have, SMF 2.0 RC3 get a bit closer to release, or this mod updated for RC2?

rgecy

Arantor,

I got the same error, just now on Line 5 of the code!

Robert

Arantor

So what's line 5 of the code now?

rgecy

Same as above, it just moved down one line when I inserted the code!

$smcFunc['db_create_table']('bookmarks',

Arantor

So you included the require statement?

OK, I forgot something.

After require('SSI.php');, add:
dbextend('packages');

rgecy

Ok, I am missing something here.  I have copied the install.php to the /forums dir where the SSI.php is.  I made the modifications you said, but I am still getting an error.

QuoteFatal error: Call to undefined function dbextend() in /home/content/r/g/e/rgecy1/html/forums/install.php on line 3

Quote<?php
require('SSI.php');
dbextend('packages');
global $smcFunc;

$smcFunc['db_create_table']('bookmarks',
   array(
      array(
         'name' => 'id_member',
         'type' => 'mediumint',
         'size' => 8,
      ),
      array(
         'name' => 'id_topic',
         'type' => 'mediumint',
         'size' => 8,
      ),      
   ),
   array(
      array(
         'name' => 'bookmark',
         'type' => 'unique',
         'columns' => array('id_member', 'id_topic'),
      ),
   ),
   array(),
   'ignore');
?>

What am I missing? 

I really like this mod and a lot of my users have requested it.  Is there a way to just change the installer package to accept 2.0 RC2 or just ignor it.  The code will work from what I have seen.  All the edits were correct.

Robert

Arantor

(Please use the code tag, not quote tag, when posting code, please)

That's because I'm running on far too little sleep and didn't treble check things.

<?php
require('SSI.php');
db_extend('packages');
global 
$smcFunc;

$smcFunc['db_create_table']('{db_prefix}bookmarks',
array(
array(
'name' => 'id_member',
'type' => 'mediumint',
'size' => 8,
),
array(
'name' => 'id_topic',
'type' => 'mediumint',
'size' => 8,
),
),
array(
array(
'name' => 'bookmark',
'type' => 'unique',
'columns' => array('id_member''id_topic'),
),
),
array(),
'ignore');
?>


You cannot use the Advanced option in the package manager to override the version check for mods like this.

kicky

Great Mod

I Installed it in my SMF 1.1.11
And work properly

Thanks

Advertisement: